Contribute
Register

HP Envy 34 AIO

Status
Not open for further replies.
Joined
Mar 24, 2018
Messages
19
Motherboard
MSI Z390 Gaming plus
CPU
I7-9700K
Graphics
Vega 56
Can you post a step by step smstacy1?
Are you installing Sierra or High Sierra?

I successfully installed Sierra to learn the process. I skipped High Sierra and went straight to Mojave and Catalina.
I have a separate clover USB boot disk to run Catalina because of a changes I have to make in clover for Catalina.

Let me know if you which version of OS X you have access too to create the usb installer and I will provide steps. If you have High Sierra, I can install that on my system and provide assistance once it boots up successfully on my end.

Before you start, what drive do you plan on installing on you HP Envy?
If you replaced your nvme SSD with a samsung you won't be able to use it for your mac partition. It's unstable. Your 2nd SATA drive should be fine and will still let you dual boot with Windows 10.
 
Joined
Mar 24, 2018
Messages
19
Motherboard
MSI Z390 Gaming plus
CPU
I7-9700K
Graphics
Vega 56
I'll help you walk through the configuration.
Did you download the High Sierra Unibeast to create the usb installer? Do you sill have that usb installer?
 
Joined
Mar 24, 2018
Messages
19
Motherboard
MSI Z390 Gaming plus
CPU
I7-9700K
Graphics
Vega 56
I have the high sierra usb installer
Sorry about the delay. I was getting a bootcamp partition created and getting parallels to work by running windows directly off the windows partitions. I accidentally wiped my windows partition.

You running coffee lake so you I platform id
  • AAPL,ig-platform-id: 07009B3E
Can you compress and post your EFI from your clover good disk? I'll take a look at it.
 
Joined
Jul 21, 2011
Messages
36
Motherboard
Lenovo U410 Touch
CPU
Core I7 2.0GHz
Graphics
Intel HD4000 and Geforce 710M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Sorry about the delay. I was getting a bootcamp partition created and getting parallels to work by running windows directly off the windows partitions. I accidentally wiped my windows partition.

You running coffee lake so you I platform id
  • AAPL,ig-platform-id: 07009B3E
Can you compress and post your EFI from your clover good disk? I'll take a look at it.

hi does waking up from sleep for you.I get a black screen on mine. thanks
 
Joined
Feb 26, 2020
Messages
127
Motherboard
Lenovo 3122
CPU
i5-9500
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Same here. I finally gave up for awhile. I didn't get the correct search results searching the .dsl for _INI for any PCI0 to turn _OFF. It must be initialize as a non PCI device. I don't know. Sierra runs decent enough to play with using vmplayer but I want to run it natively in a dual boot.

Hey, your computer is also an All-In-One with Coffee Lake? Do you mind giving a hand? Mine is a ThinkCentre m920z, also All-In-One. It has a Coffee Lake GPU (i5 9500vPro) and an Intel UHD 630.

 
Joined
Jul 13, 2020
Messages
3
Motherboard
HP ENVY AIO 34 CURVED
CPU
i7-7700
Graphics
HD 630 / RX 460
Mac
  1. MacBook Air
I'll help you walk through the configuration.
Did you download the High Sierra Unibeast to create the usb installer? Do you sill have that usb installer?
Hi,

I also have an AIO HP envy 34 with kaby lake. Do you mind if I can grab a copy of your EFI? I've been trying to get it running for 2 weeks without success. I was able to finished the installation but my screen tears up when trying to boot it.
 
Last edited:
Joined
Jul 13, 2020
Messages
3
Motherboard
HP ENVY AIO 34 CURVED
CPU
i7-7700
Graphics
HD 630 / RX 460
Mac
  1. MacBook Air
Hi. I have installed Sierra using Unibeast. I have everything working except three items.
1. Audio.
2. Graphics are really annoying. I am aware of the issue with Skylake and Intel graphics.
3. Built in camera. I can see it on usb 3 but i cannot find where to change this to make it internal.

Graphics: My BIOS does not support changing the DVMT. The preallocate is already set to 156mb. How do I change this in Sierra? Lots of screen tearing and almost unusable. System says only 7mb for Intel HD 530. I am not sure how to change this. I am using Clover. Any help is appreciated.

Edit: I was able to resolve the audio. It uses the ALC 293 codec. Audio inject value was 28 and I used the reference guide from here
https://osxinfo.net/konu/applealc-kext-ile-hackintosh-cihazlarda-ses-aktif-etmek.66/sayfa-2
After a few weeks, I got my hp envy 34 up and running but I can't get any sound. I did the audio inject value method but no luck. Did you make any adjustments to alcid values?
 
Status
Not open for further replies.
Top