Contribute
Register

HP EliteDesk 800 G2 / HP ProDesk 600 G2 - SUCCESS

Joined
Jul 12, 2019
Messages
3
Motherboard
HP Prodesk 600 G2
CPU
i5-6600
Graphics
HD 530
Apologies. I've just updated.

I solved my issue. My problem was I couldn't properly boot with the EFI files here because of it gets stuck at 'appleacpicup' whole loading. Hence I kept booting from the USB EFI that I used to install Mojave.

Anyways oddly enough after researching and playing around I decided to move whatevergreen.kext and lilu.kext into /Systems/Library/Extensions and now my graphics work.

Honestly not sure if I even fixed the problem I had with appleacpicup but it somehow works now.
 
Joined
Oct 4, 2016
Messages
69
Motherboard
Gigabyte-Z170-GAMING-K3
CPU
Skylake i5 3.3GHz 6600
Graphics
Gigabyte Nvidia GTX 1060 G1 Gaming 3GB
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
Hey, Just installed on EliteDesk 800 G2 and everything is working except Graphics. The display works but no acceleration and Im stuck on a horrid resolution.

I've tried all the suggestions in this thread, tried OP's EFI folder, PastryChef's EFI, different ig-platform-id etc etc

I still have to manually edit FakeID at clover boot everytime or I get a boot loop.

Any ideas as to whats going on?

Thanks!
 
Last edited:
Joined
Feb 8, 2017
Messages
6
Motherboard
Q77 Express
CPU
i5-3570
Graphics
GeForce GT710 2GB
@Sprewy I assume you have installed clover to your install and aren’t booting from the usb every time?

to install the kexts go to EFI\Clover\Kexts\Other and copy them to the desktop. Download Kext Beast, run it and select \Library\Extensions. That will install all kexts on the desktop to said directory.

After that finishes, download and run Kext Utility. Don’t use this to install kexts. It is only to repair permissions after kext beast has installed them.

Delete all kexts from EFI\Clover\Kexts\Other apart from FakeSMC

Reboot and good luck

You can leave the kexts on the desktop till you’ve rebooted just incase
The EFI folders posted here did not work for me at all, for some reason.
I succeeded in getting everything working by starting from scratch and using the step-by-step instructions here:

I did have to do one modification however. These instructions tell you to put the supplied config.plist into EFI/CLOVER/ACPI/config.plist however, this put me into a clover boot loop. what fixed this was simply replacing EFI/CLOVER/config.plist with the supplied config.plist file.

Now everything important works: Video (via DisplayPort), audio and all the USB ports and installing Mojave updates. The EliteDesk G2 has proven to be a nice, powerful, hassle-free Hackintosh option for the price.

One thing I noticed was that I had to go into System Preferences and set the screen never to turn off. If I walked away from the computer and it turned the screen off to save power then the computer would crash and reboot as soon as I tried to "wake it up" by touching the mouse or keyboard. If someone knows a fix for this, I'd be happy to hear it.
Also, shutting down the computer doesn't work properly - it automatically restarts. The way to get around this is to exit Clover once it restarts and safely shut down using the power button from there. It's not "perfect" but it's a very small price to pay.
 
Last edited:
Joined
Feb 8, 2017
Messages
6
Motherboard
Q77 Express
CPU
i5-3570
Graphics
GeForce GT710 2GB
Can anyone suggest recommend video card options for the EliteDesk G2 SFF that is either OTB working with Mojave or easily compatible using Clover Nvidia or ATI settings that would give this Hackintosh some video brawn to go along with its processing power?
 
Joined
May 8, 2016
Messages
13
Motherboard
HP EliteDesk 800 G2 Micro Tower
CPU
i7-6700
Graphics
HD 530
Upload the EFI. You may be missing some kexts/settings.

Are you using the USBInjectAll kext and usb limit patch or have you created a custom USBPorts.kext?
Hi PaintArm2,

I believe I have the same PC as you, 800 G2 Tower. USB ports are either not working or going at 2.0 speeds or not recognising UBS 3.0 devices. I know there are guides to create custom USB ports but it looks rather complicated and I don't want to break anything, given that my setup is working otherwise and is very stable.

If my system is indeed the same as yours, is there a simpler method, eg can I just use your kext? Thanks
 
Joined
Oct 4, 2016
Messages
69
Motherboard
Gigabyte-Z170-GAMING-K3
CPU
Skylake i5 3.3GHz 6600
Graphics
Gigabyte Nvidia GTX 1060 G1 Gaming 3GB
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
The EFI folders posted here did not work for me at all, for some reason.
I succeeded in getting everything working by starting from scratch and using the step-by-step instructions here:

I did have to do one modification however. These instructions tell you to put the supplied config.plist into EFI/CLOVER/ACPI/config.plist however, this put me into a clover boot loop. what fixed this was simply replacing EFI/CLOVER/config.plist with the supplied config.plist file.

Now everything important works: Video (via DisplayPort), audio and all the USB ports and installing Mojave updates. The EliteDesk G2 has proven to be a nice, powerful, hassle-free Hackintosh option for the price.

One thing I noticed was that I had to go into System Preferences and set the screen never to turn off. If I walked away from the computer and it turned the screen off to save power then the computer would crash and reboot as soon as I tried to "wake it up" by touching the mouse or keyboard. If someone knows a fix for this, I'd be happy to hear it.
Also, shutting down the computer doesn't work properly - it automatically restarts. The way to get around this is to exit Clover once it restarts and safely shut down using the power button from there. It's not "perfect" but it's a very small price to pay.
Thanks - following the github now.

I previously tried to merge the github post and the OP's instructions but ended up in bootloop.

Now Im just following github to the letter
 
Joined
Oct 4, 2016
Messages
69
Motherboard
Gigabyte-Z170-GAMING-K3
CPU
Skylake i5 3.3GHz 6600
Graphics
Gigabyte Nvidia GTX 1060 G1 Gaming 3GB
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
I finally got my EliteDesk 800 G2 TWR running with Dual Monitors (see below)

I tried to follow @sakoula GitHub but kept ending up with boot loops before even booting into the installer.
I did a vanilla install - Created USB with UniBeast, installed clover using Clover Configurator and then used @PaintArm2 EFI folder.

All worked with Graphics Acceleration but no dual monitors.

I chatted with sakoula who took time of his own to try help me figure out the dual monitor thing, but we came up with nothing. We reverted to his EFI and Kext's and made a bit of progress but it still did not work. We think its because Im using DP-HDMI or DP-DVI cable (no adapters) and not DP-DP.

However, happened to have a Lenovo USB3.0 laptop dock that has DisplayLink standard. I installed the generic DisplayLink macOS drivers, rebooted and now have Dual Monitors working! W00000T

Only think that is missing is higher USB limit but TBH I may not need them anyway, especially now that the dock also has USB

So once again, a huge thank you to @sakoula for (first of all) putting together your GitHub guide and also trying to help me out with my build - what a champ.
 
Top