Contribute
Register

HP Elitebook 8570W Fully Stable Hackintosh

Status
Not open for further replies.
Joined
Feb 6, 2015
Messages
15
Motherboard
GA-Z87-HD3 (rev. 1.x)
CPU
i7-4790K
Graphics
GTX 760
Mobile Phone
  1. Android
Hi,

I have used a lot of information on the forums and now that everything is working correctly for me I figured I would give back to the community by writing a tutorial on how I got my HP Elitebook 8570w running Mavericks with no bugs.

Note: I dual booted with Windows. If you are not considering this, skip the windows sections.

Pre-BIOS Config:
I didn't have to do anything with the BIOS different from factory with the exception of unticking the "VTx" box. I also changed the boot order so that the USB booted first, followed by the primary SSD in which I was installing the OS. Keep in mind I am using an upgrade bay with an extra HDD where the DVD player would normally be.

OSX Installation:
I followed tonymac's guide and created a bootable Mavericks USB with Unibeast and a WIN7 bootable USB (search net for detailed instructions on creating either). I also put a copy of Multibeast on the USB for easy access. Removed all non-essential HD's before installation. Put the USB in, rebooted, booted from USB with the following flags: "-v -x GraphicsEnabler=Yes" (no quotes)

Formatted disk with OSX Disk Utility before install. I partitioned my 256GB SSD into two equal sizes, one for Windows and one for MAC. Make sure OSX is partitioned Journal-Extended. Windows will be reformatted anyway, but I think I used NTFS.

Install took approximately half hour. I booted into the USB, then selected my new OSX, which I named "MAVERICKS", using the flags "-v -x GraphicsEnabler=Yes". If those flags don't work or you receive errors, try "-v -x -F -f GraphicsEnabler=Yes". Trial and error worked for me but I more or less had no issues.

Once booted into OSX my trackpad and keyboard stopped running so I connected a USB keyboard/mouse. I ran Multibeast and installed the following kexts: FakeSMC, PS2, USB 3.0, NullCPU, ElliotForceLegacy, EvoReboot, AppleIntelE1000e. Then removed my Mavericks USB, inserted WIN7, and rebooted.

Install with WIN7 was easy. Chose the WIN7 partition I had created earlier, formatted, installed. When install was completed I pulled my WIN7 USB and put my MAVERICKS USB back. Rebooted into USB, chose Mavericks with these flags "-v GraphicsEnabler=Yes". Experiment. Removed USB. Installed Chimera bootloader and theme from Multibeast. Rebooted. I now had a basic MAVERICKS/WIN dual boot.

Few things that will not initially work: Airport/wifi, audio. For the wifi, I purchased an EDIMAX ew-7811un USB wifi adapter. The drivers on the website didn't work. I had to identify the chipset (RTL8188CUS)and download the latest drivers from the website. After sorting that out I navigated to ~"/System/Library/Extensions/" and searched for AppleHDA.kext. When found, I deleted it and rebooted (using whatever flags necessary). Then I ran Multibeast and installed the latest VoodooHDA.kext. I did not have to patch any DSDT's. I merely navigated to the same folder "System/LibraryExtensions/", right clicked VooDooHDA.kext, show package contents, edited info.plist and replaced IOPCIClassMatch with IOPCIPrimaryMatch (http://www.insanelymac.com/forum/topic/267905-voodoohda-common-problems/). I then added my own Device ID and Vendor ID for the Intel audio card. (See instructions). Save and run Kext Utility. Reboot.

Lastly I navigated to ~/Extra/org.chameleon.boot.plist and added the following:

<key>GraphicsEnabler</key>
<string>Yes</string>

Under kernel flags I added "PCIRootUID=1"

Save and close. Reboot.


I realize I could have organized this better but my Hackintosh is running flawlessly and I didn't have to modify my DSDT at all. I have full wifi capability, native sound, native 1080p, USB 3.0, fully working keyboard and trackpad, no errors. I didn't think this was possible on my machine, mostly stock, and wanted to share my success.

Thanks for all the help. Greatly appreciated. Happy to help others.

-warewolff

EDIT: I should also add that I had to install the latest VoodooBattery.kext to the same folder as the VoodooHDA and reboot to see that in my tray. Power management doesn't work entirely and I still sometimes have issues with sleep but have no other instability issues. Hope this helps someone.
 
Joined
Aug 6, 2012
Messages
9
Motherboard
Dell Precision M5510 (Clover)
CPU
i7-6820hq Intel HD530 4k Display
Graphics
Nvidia Quadro M1000M
Did you manage to boot from hard drive? I can't boot without the Unibeast USB stick drive.
 
Joined
Jul 28, 2012
Messages
55
Motherboard
Elitebook 8570w
CPU
Intel® Core™ i5-3360M
Graphics
k2000m
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Share your clover EFI files? My k1000m is not normal
 
Joined
Jul 28, 2012
Messages
55
Motherboard
Elitebook 8570w
CPU
Intel® Core™ i5-3360M
Graphics
k2000m
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
  2. iOS
I now basically stable, but certainly no 8470p integrated graphics models of perfect, now the problem is the backlight brightness!

How do you perfect now, PBI installation, to remove the intelbacklight.kext the drive,
 

Attachments

  • %u002525255BUNSET%u002525255D.png
    %u002525255BUNSET%u002525255D.png
    729.8 KB · Views: 2,168
Joined
Jan 23, 2014
Messages
44
Motherboard
Gigabyte X58A-UD3R-FH
CPU
X5650
Graphics
GT 710
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
  2. Other
how did u install your sound?
 
Joined
Sep 11, 2017
Messages
2
Motherboard
Elitebook 8570W ---16 Gb Ram
CPU
i7 3740QM 2,7Ghz
Graphics
Quadro K1000M
Mobile Phone
  1. iOS
Hello,
thanks for your feedback.
I'm about to buy a Elitebook 8570W ,Nvidia Quadro K1000M 2GB, i7 3740QM 2,7 GHZ,
I'm working a lot on reaper daw, with one 828 Motu card (Firewire) and one presonus card (firewire) linked together.
Question: does the firewire work fully on your configuration ?
Thanks



 
Joined
Jun 12, 2016
Messages
159
Motherboard
GIGABYTE B660 DS3H DDR4 AX
CPU
i5 12400f
Graphics
RX570
Mobile Phone
  1. Android
Hello,
thanks for your feedback.
I'm about to buy a Elitebook 8570W ,Nvidia Quadro K1000M 2GB, i7 3740QM 2,7 GHZ,
I'm working a lot on reaper daw, with one 828 Motu card (Firewire) and one presonus card (firewire) linked together.
Question: does the firewire work fully on your configuration ?
Thanks




Hi, i tried with a motu 8pre on a hp probook 6570b (same series, just lower grade chassis as the elitebooks) and i could not find a way to make it work. Firewire interface is dected by the system but even after installing motu drivers no interface was detected.
 
Joined
Sep 11, 2017
Messages
2
Motherboard
Elitebook 8570W ---16 Gb Ram
CPU
i7 3740QM 2,7Ghz
Graphics
Quadro K1000M
Mobile Phone
  1. iOS
Hi, i tried with a motu 8pre on a hp probook 6570b (same series, just lower grade chassis as the elitebooks) and i could not find a way to make it work. Firewire interface is dected by the system but even after installing motu drivers no interface was detected.
Hi !
Many thanks for answering.
So now, i won't waste my time anymore trying to get it works.
 
Joined
Mar 17, 2012
Messages
106
Graphics
Nvidia Quadro K2000m
Mobile Phone
  1. Android
Hello,

I have a color gradient issue and i don't find a way to figure it out.

Also i can't set SMBIOS MBP 10.1 that matches perfectly with my CPU (i5) instead of 10.2.

8570w Quadro K1000M

Anyone has an idea?
 
Status
Not open for further replies.
Top