Contribute
Register

HP EliteBook 8460p MEGA SUCCESS!!!! But I need help with one thing :-o

Joined
May 26, 2011
Messages
25
Motherboard
MBD-X8DAL-i -O
CPU
Xeon X5675 (2x)
Graphics
AMD Radeon HD 6870
Mac
MacBook, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
Hi Amigos!

I just wanted to post my succesful attempt at Hackintoshing my EliteBook 8460p.
About a year ago, I had purchased a used HP 8460p on Ebay for about 170,- €.
It had had an Intel Core i5 2520, 4 GB RAM and a 320 GB Harddrive.
I'd decided to try to Hackintosh it from the first moment I received the unit; unfortunately, it had an Intel WiFi card.
Over this past year, I've been reminded of why I hate Windows and how a Hackbook Pro is exactly what I need.

I've succesfully purchased a Broadcom WiFi module that is white listed, upgraded the processor to a 2630QM and had actually upgraded the RAM to 16 GB when I had been running Windows 10. I'm running a Vanilla 10.9.5 and have used ProBook Installer to setup my DSDT, SSDT and any other KEXT I might have needed with Clover being my boot-loader.

However, I can't seem to drag and drop any items and corners as well as controlling Plugins in Pro Tools isn't working the way it normally would, I can only adjust values via scrolling. I can't even click on the menu options when I right click something.
I tried using my magic mouse just to make sure it isn't my trackpad, but it still does the same thing. When I try to drag and drop an item it just stays attached to my arrow and doesn't go away untill I force quite the application or relaunch it when it's Finder. Has anybody ever experienced this? I tried to search the forums like a normally do to find a solution, but I haven't even found anybody with the same problem. Any help would be greatly appreciated!!!!!
Thanks!
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi Amigos!

I just wanted to post my succesful attempt at Hackintoshing my EliteBook 8460p.
About a year ago, I had purchased a used HP 8460p on Ebay for about 170,- €.
It had had an Intel Core i5 2520, 4 GB RAM and a 320 GB Harddrive.
I'd decided to try to Hackintosh it from the first moment I received the unit; unfortunately, it had an Intel WiFi card.
Over this past year, I've been reminded of why I hate Windows and how a Hackbook Pro is exactly what I need.

I've succesfully purchased a Broadcom WiFi module that is white listed, upgraded the processor to a 2630QM and had actually upgraded the RAM to 16 GB when I had been running Windows 10. I'm running a Vanilla 10.9.5 and have used ProBook Installer to setup my DSDT, SSDT and any other KEXT I might have needed with Clover being my boot-loader.

However, I can't seem to drag and drop any items and corners as well as controlling Plugins in Pro Tools isn't working the way it normally would, I can only adjust values via scrolling. I can't even click on the menu options when I right click something.
I tried using my magic mouse just to make sure it isn't my trackpad, but it still does the same thing. When I try to drag and drop an item it just stays attached to my arrow and doesn't go away untill I force quite the application or relaunch it when it's Finder. Has anybody ever experienced this? I tried to search the forums like a normally do to find a solution, but I haven't even found anybody with the same problem. Any help would be greatly appreciated!!!!!
Thanks!
Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
May 26, 2011
Messages
25
Motherboard
MBD-X8DAL-i -O
CPU
Xeon X5675 (2x)
Graphics
AMD Radeon HD 6870
Mac
MacBook, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
So, even though I'm running a different OS, I should still post there?
I thought about posting in the original Pro Book guide for Mavericks, but it said it isn't supported.
The only thing that makes sense to me is a possible VoodoPS2 Kext issue, but that thread is crazy long, I tried reading it.... not so much fun.

Before I post what I tried to do here, I thought I'd ask first since I get what your saying here.
 
Joined
May 26, 2011
Messages
25
Motherboard
MBD-X8DAL-i -O
CPU
Xeon X5675 (2x)
Graphics
AMD Radeon HD 6870
Mac
MacBook, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
Correction... it still doesn't work.... Please disregard, I'll post in that other thread. I need a solution asap.... ;-(
(Yo, I got it to work again, I just installed the latest version of your VoodooPS2 KEXT.
That actually shocked me that the PS2 KEXT would even effect the magic mouse... CRAZY!!!!
SHE'S RUNNING PERFECTLY NOW!!! WOOHOO!!!!

Now time to mix some records at my girlfriend's parents place ;-)

THANKS AGAIN!!!!)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Correction... it still doesn't work.... Please disregard, I'll post in that other thread. I need a solution asap.... ;-(
(Yo, I got it to work again, I just installed the latest version of your VoodooPS2 KEXT.
That actually shocked me that the PS2 KEXT would even effect the magic mouse... CRAZY!!!!
SHE'S RUNNING PERFECTLY NOW!!! WOOHOO!!!!

Now time to mix some records at my girlfriend's parents place ;-)

THANKS AGAIN!!!!)
No "Problem Reporting" files attached.
 
Joined
May 26, 2011
Messages
25
Motherboard
MBD-X8DAL-i -O
CPU
Xeon X5675 (2x)
Graphics
AMD Radeon HD 6870
Mac
MacBook, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
No "Problem Reporting" files attached.
I couldn't get the Clover to do anything when I booted and pressed F4.

All other files are in this zip. Thanks for the help!
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I couldn't get the Clover to do anything when I booted and pressed F4.

All other files are in this zip. Thanks for the help!
No EFI/Clover attached (F4 just writes native ACPI to ACPI/origin... you shouldn't expect to see any feedback).

Nothing wrong with PS2 trackpad that I see. Keep in mind a temporary (1 second) drag lock is normal. You can release the drag lock by waiting a second, or by tapping.

But it may depend on the specifics of the issue you mention. Your post is not very clear on what is happening, nor what you expect to happen.
 
Joined
May 26, 2011
Messages
25
Motherboard
MBD-X8DAL-i -O
CPU
Xeon X5675 (2x)
Graphics
AMD Radeon HD 6870
Mac
MacBook, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
No EFI/Clover attached (F4 just writes native ACPI to ACPI/origin... you shouldn't expect to see any feedback).

Nothing wrong with PS2 trackpad that I see. Keep in mind a temporary (1 second) drag lock is normal. You can release the drag lock by waiting a second, or by tapping.

But it may depend on the specifics of the issue you mention. Your post is not very clear on what is happening, nor what you expect to happen.
It's sort of like a drag lock, but one that never ends. Also, when I right click and the menu comes up, I can't use the mouse to navigate it or highlight items, I have to use the number pads. Active corners don't work, neither does clicking on items in mission control and when moving the pointer over the dock magnification doesn't happen unless I click on the app and then it stays large and no longer follows the arrow. I've attached some pictures showing this issue that don't even show my mouse icon which is really mind boggling.

In the photo where the right click options are being highlighted I had my mouse arrow pointing at something completely different, when I'm highlighting the battery menu my mouse pointer had been hovering over the "Show Percentages", but that item didn't get highlighted, and when the icon in the dock is magnified my mouse wasn't even on the dock. :-o

I don't know how to access the Clover folder since it's in the EFI portion of the drive. Is there a guide on how to do this? I don't mind reading it since I need to know this anyway. Thanks again!
Screen Shot 2017-04-16 at 01.50.15.png
Screen Shot 2017-04-16 at 01.49.51.png
Screen Shot 2017-04-16 at 01.44.53.png
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,716
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
It's sort of like a drag lock, but one that never ends. Also, when I right click and the menu comes up, I can't use the mouse to navigate it or highlight items, I have to use the number pads. Active corners don't work, neither does clicking on items in mission control and when moving the pointer over the dock magnification doesn't happen unless I click on the app and then it stays large and no longer follows the arrow. I've attached some pictures showing this issue that don't even show my mouse icon which is really mind boggling.

In the photo where the right click options are being highlighted I had my mouse arrow pointing at something completely different, when I'm highlighting the battery menu my mouse pointer had been hovering over the "Show Percentages", but that item didn't get highlighted, and when the icon in the dock is magnified my mouse wasn't even on the dock. :-o

I don't know how to access the Clover folder since it's in the EFI portion of the drive. Is there a guide on how to do this? I don't mind reading it since I need to know this anyway. Thanks again!
View attachment 248746
View attachment 248747
View attachment 248748
Did you follow the guide?
https://www.tonymacx86.com/threads/guide-hp-probook-elitebook-zbook-using-clover-uefi-hotpatch-10-11.189416/
 
Joined
May 26, 2011
Messages
25
Motherboard
MBD-X8DAL-i -O
CPU
Xeon X5675 (2x)
Graphics
AMD Radeon HD 6870
Mac
MacBook, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
I reinstalled and followed the guide step by step and still had the same issue.
When using the finder and dragging and dropping items, the dragged item refuses to drop and the finder won't let go of the dragged item unless I force quite Finder.

I after I force quite Finder everything is again OK. It doesn't matter if I'm using a mouse or if I'm using a track pad.

I did however find a solution, use an Apple Mouse and remove the Voodoo Trackpad and Mouse Kext from the Voodoo PS2 Kext bundle. I no longer have the issue with dragged items not being able to drop, but can no longer use the track pad.

I'm mostly using this as a mobile workstation so I use a mouse 90% of the time, but it would be nice to use the trackpad on occasion.

I will post the origin ACPI in my next post.

Thanks!

P.s. The drag lock was longer than a second, it never stopped even when I tapped.
 
Last edited:
Top