Contribute
Register

HP EliteBook 2570p(2x70p) macOS 10.14 Mojave EFI 99% Worked

Joined
Mar 12, 2015
Messages
39
2019-05-02 UPDATE Mojave 10.14.4
Update Clover r4925
Update Lilu.kext,WhateverGreen.kext

Download Links:
UPDATE:2019-05-02 (IMPORTANT UPDATE for Mojava 10.14.4) if you are New Clean Install please read all include Next "Generate New Serial Number for YOUR Hackintosh." part.
http://pc.cd/owe

if you want to Update Mojave 10.14.4 please make sure Backup Your All important Data by you self or Disk Cloner software.
I use Time Machine Backup All.
View attachment 403409
Update 10.14.4 successfully.
View attachment 403410

if you want to Update to 10.14.4 from any version. please read this
Update EFI Step:
1.use Clover Configurator App Mount your SSD/HDD EFI Partition.
2.Copy Your SSD/HDD EFI Folder to your USB stick(FAT32). or you want to backup EFI to other path or other disk.
3.Delete Your SSD/HDD EFI Folder.
4.Download HP 2570p EFI_20190502 and extract the zip file
5.Copy HP 2570p 20190502 only "EFI" Folder to your SSD/HDD EFI Partition.
6.Copy Your Step.2 Backup /EFI/CLOVER/config.plist to Your SSD/HDD EFI/CLOVER/config.plist(Replacement)IMPORTANT config.plist have your Generate Serial Number for YOUR Hackintosh.
7.Reboot,and check your clover version is r4925.
8.Update to 10.14.4
 
Joined
Mar 12, 2015
Messages
39
Why DisplayPort Audio Output not Work??
Because i found issue when external monitor sleep to wake or I close laptop screen(only use external Screen) and open laptop screen two times or three times when DisplayPort Audio Out is Worked.My external Screen PHILIPS BDM4350UC..show "NO Signal"...
And Disable DisplayPort Audio Output can sloved this issue.

I using AppleALC.kext worked with native macOS HD audio


i rebuild AppleALC.kext disable DP Audio Output


if you want to DP audio output,you can download AppleALC.kext from github
and replacment AppleALC.kext
AppleALC-gitHub
 
Joined
Jun 7, 2019
Messages
4
How can I test if power management is working? When I run Intel Power Management, it is stuck at 0.8 GHz, even if I run a benchmark test.
 
Joined
Mar 12, 2015
Messages
39
backup /EFI/CLOVER/ACPI/patched/delete your CPU SSDT
delete /EFI/CLOVER/ACPI/patched/delete your CPU SSDT
and run cpu benchmark test.
 
Joined
Jun 7, 2019
Messages
4
I see 4 ssdt inside the patched directory: the 2x70.aml, FANREAD, IGPU, and SSDT.aml. I don't know which one to delete.

Just run? No need to restart the laptop first after deleting the ssdt?


Nevermind. Speed step is working now when I use your EFI.



Were you able to make the CARD READER WORK?
I did the following in trying to make the SD Card reader work but I have had no success:


  1. Installed JMB38X.kext and HSSDBlockStorage.kext on EFI/Clover/kext/10.14 and rebooted. Did not work.
  2. Installed to /L/E/ using KextBeast and rebuilt cache
    Code:
    sudo kextcache -i /
    . Rebooted. Did not work.
  3. Removed the two kexts in /L/E/ and installed to /S/L/E/ using KextBeast and rebuit cache. Rebooted. Did not work.
 
Last edited:
Joined
Mar 12, 2015
Messages
39
i didn't put cpu ssdt in the EFI. but i see SSDT.aml(CPU ssdt delete this)
but i know if you generate wrong CPU ssdt,it will lock 0.8Ghz or 1Ghz.
 
Joined
Jun 7, 2019
Messages
4
Thank you hollowaysxp. Did you test if the SD card slot is working for you? The SD card slot is not working on my end. If I insert an SD card, it will mount the sd card but in read-only mode. I cannot wriite to it. Perhaps there's a problem with Mojave not loading the HSSDBlockStorage.kext during cache rebuild, because I can see that the other kext are loaded in cache but not the HSSDBlockStorage.
 

Top