Contribute
Register

HP dc7900 struggle

Joined
Jan 6, 2020
Messages
5
Motherboard
HP
CPU
Core 2duo
Graphics
HD3650
Mobile Phone
iOS
Hello to all

I was about to start developing apps on my iMac (late 2009) when it suddenly died. Unfortunately, I couldn't revive it.
As a student, I am very short on money so I couldn't afford a new one. But then I remembered that my father still holds his old computer in his garage.
I brought the computer to my home and I tried to start it...boy it fired up like on the first day.

Now, I heard about the Hackintosh scene and I wanted to "hack" this old computer too. It seems that the HP Compaq dc7900 has very compatible parts inside that are perfectly suitable for a Hackintosh conversion.

So I downloaded the macOS Catalina and moved it onto a usb stick with createinstallmedia. And then I made it bootable with Clover Legacy 2.4 r4961.

The PC first didn't want to recognise the usb stick as a bootable device. But after I changed the partition to MBR instead of GUID, it could start Clover and macOS.

The problem now why I am so deeply frustrated is that the Apple Logo just sits there for a while, then a filling bar appears and after the bar is half filled, it shows a stop sign (something like a circle with a line inside). I tried many things after a long research on the internet, like testing different boot flags (I tried around 20) removing the graphics card, tweaking some settings in Clover and in the BIOS, etc. nothing helped...

But it always stuck either on "Waiting on <dict ID="0"><key>IOProviderClass</key>...." or "PCI configuration begin". And then the whole screen just bugs up and gets fuzzy.

I really don't know how to move on with the installation, I would really appreciate some help of the experts here, I am really new with creating a Hackintosh.

If you need any kind of files (like the efi folder or a screenshot of the verbose startup, etc.) please let me know it, i'll send it to you.

Specs:
Name: HP Compaq dc7900
CPU: Intel Core 2 quad q9400
GPU: ATI Radeon HD3650
HDD: 2x Himachi 250 GB
RAM: 4 GB (Unknown manufacturer)
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,533
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hello to all

I was about to start developing apps on my iMac (late 2009) when it suddenly died. Unfortunately, I couldn't revive it.
As a student, I am very short on money so I couldn't afford a new one. But then I remembered that my father still holds his old computer in his garage.
I brought the computer to my home and I tried to start it...boy it fired up like on the first day.

Now, I heard about the Hackintosh scene and I wanted to "hack" this old computer too. It seems that the HP Compaq dc7900 has very compatible parts inside that are perfectly suitable for a Hackintosh conversion.

So I downloaded the macOS Catalina and moved it onto a usb stick with createinstallmedia. And then I made it bootable with Clover Legacy 2.4 r4961.

The PC first didn't want to recognise the usb stick as a bootable device. But after I changed the partition to MBR instead of GUID, it could start Clover and macOS.

The problem now why I am so deeply frustrated is that the Apple Logo just sits there for a while, then a filling bar appears and after the bar is half filled, it shows a stop sign (something like a circle with a line inside). I tried many things after a long research on the internet, like testing different boot flags (I tried around 20) removing the graphics card, tweaking some settings in Clover and in the BIOS, etc. nothing helped...

But it always stuck either on "Waiting on <dict ID="0"><key>IOProviderClass</key>...." or "PCI configuration begin". And then the whole screen just bugs up and gets fuzzy.

I really don't know how to move on with the installation, I would really appreciate some help of the experts here, I am really new with creating a Hackintosh.

If you need any kind of files (like the efi folder or a screenshot of the verbose startup, etc.) please let me know it, i'll send it to you.

Specs:
Name: HP Compaq dc7900
CPU: Intel Core 2 quad q400
GPU: ATI Radeon HD3650
HDD: 2x Himachi 250 GB
RAM: 4 GB (Unknown manufacturer)
best to boot verbose, take a pic where it hangs and zip and upload your Clover folder
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
22,715
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Intel Core 2 quad q400
Seems to have a missing digit ?
If you want to run Catalina then check that it supports SSE4.2 extensions.

Your twelve year old graphics card is unlikely to support Metal which is required to run Catalina.

I had a dc7900 and managed to run High Sierra ok with it but never took it any further than that.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,533
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Any ideas?
is your hardware profile complete? nvidia 1050 not supported on mojave

motherboard - hp, bit vague, should say make and model

Intel Core i5 is a bit vague as well
 
Joined
Jan 6, 2020
Messages
5
Motherboard
HP
CPU
Core 2duo
Graphics
HD3650
Mobile Phone
iOS
You should not watch at my profile specs, I put there the numbers and names of my main Computer (Omen 15 notebook).
Refer to the specs I added in the first post.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
15,533
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
You should not watch at my profile specs, I put there the numbers and names of my main Computer (Omen 15 notebook).
Refer to the specs I added in the first post.
thats all i look at is hardware profile
 
Joined
Jan 6, 2020
Messages
5
Motherboard
HP
CPU
Core 2duo
Graphics
HD3650
Mobile Phone
iOS
So I changed now my profile specs and I am still stranded with my hackintosh... It still won't get to the install screen it will only hang on the two errors mentioned before.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
16,000
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
So I changed now my profile specs and I am still stranded with my hackintosh... It still won't get to the install screen it will only hang on the two errors mentioned before.
Trying newer versions of macOS on that hardware is an exercise in futility. It will probably never work. If you want to run Catalina buy a used, refurb HP 8300 elite with an HD4000 gfx CPU. They don't cost much and work perfectly well with Catalina. See: https://www.tonymacx86.com/threads/...rm-factors-using-clover-uefi-hotpatch.279627/

If you want to play around with what you've got, see if you can get Mavericks, Yosemite etc. and try those instead. At least you'd have a chance at success.
 
Top