Contribute
Register

HP 8460p + Probook Installer 6.1 + Docking Station = No Video Out

Status
Not open for further replies.
Joined
Feb 8, 2014
Messages
26
Motherboard
HP EliteBook 8460
CPU
i5 > Need full model number > See Rules!
Graphics
HD 3000
There is also a patch in there for HDMI-audio. You could patch it just for HDMI-audio if you need that...

How can I go about doing that? Obtain the patched vga+hdmi audio kext and then modify the stock one?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
How can I go about doing that? Obtain the patched vga+hdmi audio kext and then modify the stock one?

There is information about patching for HDMI audio in the Audio forum. It should be a relatively well known patch to AppleIntelSNBGraphicsFB.

I've not looked into it as I have no need for HDMI-audio on a laptop.
 
Joined
Jul 3, 2014
Messages
5
Motherboard
8460p
CPU
i5
Graphics
HD3000
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Have any of you guys moved to Yosemite? And if so, would you happen to know how to get the dock (specifically the display port or the DVI?) to work?

Ive tried with multibeast to install different packages, but nothing seems to work... and im not sure where to find different kexts (ive tried the github for the probook installer, but i dont see any video drivers on it)...

Any help is appreciated
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Have any of you guys moved to Yosemite? And if so, would you happen to know how to get the dock (specifically the display port or the DVI?) to work?

Ive tried with multibeast to install different packages, but nothing seems to work... and im not sure where to find different kexts (ive tried the github for the probook installer, but i dont see any video drivers on it)...

Any help is appreciated

http://www.tonymacx86.com/hp-proboo...-install-yosemite-hp-laptops-clover-uefi.html
 
Joined
Jul 3, 2014
Messages
5
Motherboard
8460p
CPU
i5
Graphics
HD3000
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Thank you for the response RehabMan... Ive gotten Yosemite installed already. It works pretty much out of the box, and with PBI, tightens everything up. I used Multiman to get my wifi card to work. What im stuck on is the dock (external display specifically... I cant get anything other than VGA to work, and VGA is messed up... im not sure what its displaying... resolution is correct but nothing displays other than background).

Or are you saying that i missed something in the installer tutorial?

I think this post is probably what I need to do, but I have no idea how to patch clover (yet).

http://www.tonymacx86.com/hp-probook-mavericks/127832-clover-patch-external-display-13.html
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thank you for the response RehabMan... Ive gotten Yosemite installed already. It works pretty much out of the box, and with PBI, tightens everything up. I used Multiman to get my wifi card to work. What im stuck on is the dock (external display specifically... I cant get anything other than VGA to work, and VGA is messed up... im not sure what its displaying... resolution is correct but nothing displays other than background).

Or are you saying that i missed something in the installer tutorial?

I think this post is probably what I need to do, but I have no idea how to patch clover (yet).

http://www.tonymacx86.com/hp-probook-mavericks/127832-clover-patch-external-display-13.html

Follow the guide: http://www.tonymacx86.com/hp-proboo...-install-yosemite-hp-laptops-clover-uefi.html

Note: It does not use Multibeast. If you used it, you did something wrong.
 
Joined
Oct 21, 2015
Messages
2
Mac
Classic Mac
Mobile Phone
Hi,

I have the same problem.

I have follow this procedure: http://www.tonymacx86.com/hp-proboo...-install-yosemite-hp-laptops-clover-uefi.html but with osx el capitain on a elitebook 840 G2 with HD5500.

On my computer my DP port is Ok but when i plug my laptop on the docking station i can't get DP out to work.

I have search replacing AppleIntelSNBGraphicsFB.kext with stock one. But i can't find it in my desktop PBI backup folder, same in /Library/Extentions folder.

Maybe the kext have not the same name on my setup?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi,

I have the same problem.

I have follow this procedure: http://www.tonymacx86.com/hp-proboo...-install-yosemite-hp-laptops-clover-uefi.html but with osx el capitain on a elitebook 840 G2 with HD5500.

On my computer my DP port is Ok but when i plug my laptop on the docking station i can't get DP out to work.

I have search replacing AppleIntelSNBGraphicsFB.kext with stock one. But i can't find it in my desktop PBI backup folder, same in /Library/Extentions folder.

Maybe the kext have not the same name on my setup?

AppleIntelSNBGraphicsFB is Sandy bridge graphics kext.. You have Broadwell HD5500, not HD3000.
 
Joined
Mar 22, 2014
Messages
6
Motherboard
ProBook 6360b
CPU
i5 2450M
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
  1. Android
Hi there.

I've also been trying to get my docking station working with video out but no luck yet. I have an HP Elitebook 2560p (HD3000) which as far as I can tell is the same chipset as the 8460p, so I am still hopeful that I can get it working.

Currently I have OSX Yosemite installed with PBI 6.2.15.3 - I tried the latest PBI 6.4.4 but it prevents the laptop from going to sleep and doesn't seem to work with HWMonitor (it cannot read temps). So I have stuck with the version I know worked with it. Anyway, I read here about replacing AppleIntelSNBGraphicsFB.kext with the stock one, so I copied it from /S/L/E on my USB installer stick. I checksummed it and am sure I replaced it but it didn't make any difference. The laptop boots and external screen works during POST/Clover/boot progress screen but then the external screen switches off when it gets to the login screen.

Is there something I have missed or something else I could try?

Thanks!
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,100
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi there.

I've also been trying to get my docking station working with video out but no luck yet. I have an HP Elitebook 2560p (HD3000) which as far as I can tell is the same chipset as the 8460p, so I am still hopeful that I can get it working.

Currently I have OSX Yosemite installed with PBI 6.2.15.3 - I tried the latest PBI 6.4.4 but it prevents the laptop from going to sleep and doesn't seem to work with HWMonitor (it cannot read temps). So I have stuck with the version I know worked with it. Anyway, I read here about replacing AppleIntelSNBGraphicsFB.kext with the stock one, so I copied it from /S/L/E on my USB installer stick. I checksummed it and am sure I replaced it but it didn't make any difference. The laptop boots and external screen works during POST/Clover/boot progress screen but then the external screen switches off when it gets to the login screen.

Is there something I have missed or something else I could try?

Thanks!

The dock is probably going to require framebuffer patches. You'll need to do some reading...

Even though it is focused on HDMI audio and desktops, you might start here to begin learning: http://www.tonymacx86.com/graphics/125239-intel-hd4600-hd4000-hd3000-framebuffer-edits.html
 
Status
Not open for further replies.
Top