Contribute
Register

HP 8460p + Probook Installer 6.1 + Docking Station = No Video Out

Status
Not open for further replies.
Joined
Nov 7, 2013
Messages
4
Motherboard
Dell XPS 15Z; HP Elitebook 8460P
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I have been messing around with hackintosh on my 8460p. I had Mavericks running with a few issues and then found out about the pro book installer. Which is great. THis whole site is great. There are still a few issues after running the probook installer 6.1.11. The biggest issue is that before running probook installer I could use the docking station to use my 23 inch lcd via the DVI cable. Now I cannot and must use it like a laptop…which sucks (please no grief for not wanting to use a laptop in my lap). I see a few threads touching on the dock topic but not with my specifics.

other issues after pro book installer...

wake from sleep doesn't work, just blank screen, have to hard power down
battery information just shows as 0% and that I am plugged in to power source

but again, docking station video out is the biggest pain, it worked before pro book installer. Anyone found how to make the video out work after running pro book installer?

I should mention I have only tried this within mavericks.

Thanks and Regards,
Jake
 
Joined
Oct 21, 2012
Messages
3,464
Motherboard
HP Elitebook 8470p
CPU
i5 3320M
Graphics
HD 4000, 1600x900
Mobile Phone
  1. iOS
Did you install any kexts out of PBI?
 
Joined
Nov 7, 2013
Messages
4
Motherboard
Dell XPS 15Z; HP Elitebook 8460P
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Yes I believe I did. I followed the release notes per philppetev over on github. I clicked yes for os x support kexts…and pretty much followed that guid to a t except where it was not applicable for the 8x60p or mavericks. This also left the old kexts backed up on my desktop. No warnings or errors other than untrusted kexts popup that is to be expected.

Thank you again for responding nguyenmac…on two different sites no less!

If this is known working I can always just do a fresh install and use PBI without having first used multibeast. I just sorta wanted to know if DVI out on the dock should work with PBI as I have no display port cable and it was working prior to PBI. Ethernet and USB on the dock still work..just no video. The battery and sleep are much less important to me. Besides, this won't be fun if it just works! I want to learn something from all this!
 
Joined
Oct 21, 2012
Messages
3,464
Motherboard
HP Elitebook 8470p
CPU
i5 3320M
Graphics
HD 4000, 1600x900
Mobile Phone
  1. iOS
Yes I believe I did. I followed the release notes per philppetev over on github. I clicked yes for os x support kexts…and pretty much followed that guid to a t except where it was not applicable for the 8x60p or mavericks. This also left the old kexts backed up on my desktop. No warnings or errors other than untrusted kexts popup that is to be expected.

Thank you again for responding nguyenmac…on two different sites no less!

If this is known working I can always just do a fresh install and use PBI without having first used multibeast. I just sorta wanted to know if DVI out on the dock should work with PBI as I have no display port cable and it was working prior to PBI. Ethernet and USB on the dock still work..just no video. The battery and sleep are much less important to me. Besides, this won't be fun if it just works! I want to learn something from all this!

What did you choose while installing PBI? A DSDT maybe needed too. PBI is not tested for Dock yet, but others work quite well.
You can reinstall old AppleIntelSNBGraphicsFB.kext in desktop folder to see if it works for you. As know, only this kext + Extra/DSDT.aml is related to Graphics.

A clean reinstall may help http://www.tonymacx86.com/hp-probook-mavericks/
 
Joined
Nov 7, 2013
Messages
4
Motherboard
Dell XPS 15Z; HP Elitebook 8460P
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
so i backed out to the AppleIntelSNBGraphicsFB.kext that I had before I used PBI and I am writing this from my dock on my LCD display! Looks like that was the culprit. Now I just need to figure out the difference between the kexts.
 
Joined
Oct 21, 2012
Messages
3,464
Motherboard
HP Elitebook 8470p
CPU
i5 3320M
Graphics
HD 4000, 1600x900
Mobile Phone
  1. iOS
so i backed out to the AppleIntelSNBGraphicsFB.kext that I had before I used PBI and I am writing this from my dock on my LCD display! Looks like that was the culprit. Now I just need to figure out the difference between the kexts.

That AppleIntelSNBGraphicsFB.kext was patched to enable VGA port, maybe it interfered with other ports then.

EDIT: The patch change DP port to VGA, maybe that's why you can't use Displayport-to-DVI in dock.
 
Joined
Feb 8, 2014
Messages
26
Motherboard
HP EliteBook 8460
CPU
i5 > Need full model number > See Rules!
Graphics
HD 3000
I also have a 8460p and the docking station was not working. I found this thread and replaced with the old AppleIntelSNBGraphicsFB.kext and now my docking station works. I am also on dual displays! One through the dvi port on the docking station and one through the displayport(to dvi) on the docking station.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I also have a 8460p and the docking station was not working. I found this thread and replaced with the old AppleIntelSNBGraphicsFB.kext and now my docking station works. I am also on dual displays! One through the dvi port on the docking station and one through the displayport(to dvi) on the docking station.

The patch for AppleIntelSNBGraphicsFB.kext is to enable VGA and HDMI-audio. I think the VGA part of the patch causes a lot of issues with HDMI/DP, which is the reason I prefer to use stock.
 
Joined
Feb 8, 2014
Messages
26
Motherboard
HP EliteBook 8460
CPU
i5 > Need full model number > See Rules!
Graphics
HD 3000
Hm, I realized that when I went to the stock AppleIntelSNBGraphics it may have made my sound stop working (my sound has not been working and I just not noticed. I am pretty sure I have not done anything else. How do I get the new kext to put back in SLE to see if it is the kext?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,101
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hm, I realized that when I went to the stock AppleIntelSNBGraphics it may have made my sound stop working (my sound has not been working and I just not noticed. I am pretty sure I have not done anything else. How do I get the new kext to put back in SLE to see if it is the kext?

There is also a patch in there for HDMI-audio. You could patch it just for HDMI-audio if you need that...
 
Status
Not open for further replies.
Top