Contribute
Register

How to Update Clover v2.4k r4xxx to v2.5k r5xxx (v2.4k r4972 to v2.5 r5018 example)

Joined
Dec 21, 2013
Messages
40
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac Pro
Classic Mac
Plus
Mobile Phone
iOS
Very nice and worked....
 
Last edited:
Joined
Nov 11, 2014
Messages
24
Motherboard
Gigabyte Z-97M-D3H
CPU
I5-4440
Graphics
Intel 4600
Mac
iMac
Mobile Phone
Android
First of all, thank you for the post, Anachronaut!

Some months ago I tried to upgrade my clover 4937 to a newer version, but it broke the installation (I use Clonezilla before trying any upgrade, saved me a lot of headaches...). I was using Clover Configurator to upgrade Clover and it was showing a message, before starting the upgrade, that my system, which is pretty standard (a bit old...), was not compatible. Image attached.

Then I found your article. I followed it precisely but kept getting the same message. I used the Clover pkg in the link above instead of using Clover Configurator. Except for the version, I understand that there is not much difference between the methods.

Yesterday I decided to accept the risk and install it, ignoring the compatibility message. Clover installed and, after trying to boot, I get a reboot before getting to the login screen. And I never got to the configuration screens you show. (I am Brazilian, and the image below is in Portuguese - The message says that the package is incompatible with my Mac OS version - it is 10.15.2 and asks me to abort or to continue).

Any help on that?

Thanks!

1580671143443.png
 
Joined
Apr 5, 2012
Messages
112
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i5-7600
Graphics
RX 580
Mobile Phone
Android
Yesterday I decided to accept the risk and install it, ignoring the compatibility message. Clover installed and, after trying to boot, I get a reboot before getting to the login screen. And I never got to the configuration screens you show. (I am Brazilian, and the image below is in Portuguese - The message says that the package is incompatible with my Mac OS version - it is 10.15.2 and asks me to abort or to continue).

Any help on that?

Thanks!
This is an expected and standard message. Clover is not recognized by Apple, so it is listed as not compatible no matter which version you try to install it on. Just choose to continue and you should be able to install it successfully.
 
Joined
Nov 11, 2014
Messages
24
Motherboard
Gigabyte Z-97M-D3H
CPU
I5-4440
Graphics
Intel 4600
Mac
iMac
Mobile Phone
Android
This is an expected and standard message. Clover is not recognized by Apple, so it is listed as not compatible no matter which version you try to install it on. Just choose to continue and you should be able to install it successfully.

Thanks!
 
Joined
Jan 15, 2013
Messages
2
Motherboard
Windows
CPU
i7
Graphics
Nvidia
Mac
Classic Mac
Mobile Phone
This is an expected and standard message. Clover is not recognized by Apple, so it is listed as not compatible no matter which version you try to install it on. Just choose to continue and you should be able to install it successfully.
Check your system clock using terminal in recover mode. Might solve your problem.
 
Joined
Apr 11, 2018
Messages
67
Motherboard
Gigabyte H370M D3H
CPU
i5-8500
Graphics
RX 570
Mac
iMac, MacBook Pro
Just wanted to say great instructional post. I am currently on a new, and my second, build. I ran into a problem/question several days ago when I started the build. I posted a question on the forum here with no answers, so I plunged forward trying to solve the issue myself. It dealt with changing the clover bootloader version. Now, after a solid day of working on it, I just stumbled upon your great post, and like a magic wand, I am all done. Thanks Again
 
Top