How to Update Clover v2.4k r4xxx to v2.5k r5xxx (v2.4k r4972 to v2.5 r5018 example)

Apr 5, 2012
MSI Z270 Gaming Pro Carbon
RX 570
Mobile Phone
  1. Android
I really like to update Clover every time I update to a new version of Mac OS to help prevent issues. For 10.14.6 however, the Clover update would not work. I eventually found out that there are changes in Clover v2.5k that do not allow simple updating from v2.4k – detailed in a post by Slice here: Clover Changes (Scroll - when you see 5000 jumping up and down you are at the correct post)

The folder structure has changed. The folder drivers64UEFI is now drivers/UEFI and drivers64 is now drivers/BIOS. To update you must do some things manually or things will be in the wrong place and/or duplicated and the system will not boot correctly. Here is my experience updating my Clover v2.4k r4972 to Clover v2.5k r5018. As a bonus, I will also include a quick comment on updating from Clover v2.5k r5018 to Clover v2.5k r5033 at the end.

You can download the latest version of Clover here: Clover Bootloader

Before you start be sure to back up everything – really, don't skip this as you need something to fall back on if this fails. I made 2 backups for safety. Also, it is a good idea to have a bootable drive like the UniBeast USB drive you created when you installed your system. (I made clones and booted from one of them when I had trouble but I don't recommend this for technical reasons. Mac OS has a tough time with two identical drives in the system and things get confusing.) I think if you follow the procedure outlined below, you will likely not have a problem.

1. Mount the EFI Partition on your boot drive. You need to make a backup of this since the Clover installer will not be able to do it as it will not be there when the Clover installer is operating. You can use any method you like to mount EFI, I like the terminal. Here is my session:​

Last login: Mon Jul 29 07:07:54 on console
Anachronauts-iMac:~ Anachronaut$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         249.8 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +249.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Emerald                 83.4 GB    disk1s1
   2:                APFS Volume Preboot                 45.9 MB    disk1s2
   3:                APFS Volume Recovery                510.3 MB   disk1s3
   4:                APFS Volume VM                      2.1 GB     disk1s4

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Media 500 GB            499.8 GB   disk2s2

Anachronauts-iMac:~ Anachronaut$ sudo diskutil mount disk0s1
Volume EFI on disk0s1 mounted
Anachronauts-iMac:~ Anachronaut$

2. Backup your current EFI folder. Clover normally keeps backups on your boot drive. For me the backup for the last Clover install was at Emerald/EFI-Backups/r4972/2019-07-23-09h22. You can create a backup of your EFI partition anywhere you like, but I chose to use this location to keep everything consistent. I created the folder 2019-07-29-07h51 in r4972 for this purpose. Note that if you use this location for your backup as I did, you will need to enter your password for each change.​

EFI Copy1.jpg
EFI Copy2.jpg

3. Once this is backed up, delete the Clover folder from EFI/EFI and empty the trash. I think it is best for the Clover v2.5k installer to see a blank slate here this time because of the change in the folder structure.​

4. Start the clover installer and click through until you can choose Customize:​


5. Try to match up all of the drivers in your current drivers64UEFI (or drivers64) folder with the new choices from the installer:​


You can see that I was not able to match AptioMemoryFix-64, so I decided to try OsxAptioFix3Drv again (it didn't work, more on that later). Since I am using APFS, I did not know if I needed HFSPlus-64, so I decided to leave it out as it did not have a match. Here is what the UEFI folder looked like after the installer had completed:​


6. Now on to kexts. I keep a few kexts in kexts/Other as opposed to installing them somewhere like Library/Extensions for ease of use and updating. All of these needed to be copied to the new installation. Check the relevant folders on your installation to see what you need to copy. Here is what my folders looked like after copying from the backup to the new EFI/EFI/Clover/kexts folder:​


7. Copy all of the items in your backup Themes folder to your new EFI/EFI/Clover/Themes installation in the manner shown above to retain your preferred look and feel.​
8. Be sure to also copy the config.plist from your backup to EFI/EFI/Clover as shown in the image above.​
If your Clover installation is similar to mine, you should be good to go at this point to restart and test it. Mine failed the first time because my system just refuses to boot with OsxAptioFix3Drv, so I installed AptioMemoryFix-64 in its place. Also, I installed HFSPlus-64 for good measure. It is probably not needed, but also does no harm (I think!). After this my system booted properly. Here is the final look:​

Now for the test. I realized as I was preparing to write this that Clover v2.5k r5033 had been posted. I backed up my current system drive – ALWAYS!!! Then I ran the installer. I made sure to check everything using the Customize button. The installer wanted to replace AptioMemoryFix-64 with OsxAptioFix3Drv, so I unchecked it and ran the installer. When I checked EFI/EFI/Clover/drivers/UEFI, I found that the installer had replaced AptioMemoryFix-64 with OsxAptioFixDrv. Since I was quite sure that I have tried this one before without success, I replaced it with AptioMemoryFix-64.

All is now working like a charm with Clover v2.5k r5033. I really wish that the Clover developers would put AptioMemoryFix-64 back into the installer as an option. It would sure make my updates (and from reading comments others too) go a bit smoother in the future.

Edit: Oops! USB is not working. I just forgot to replace my custom SSDT that allows all of the USB ports to work. All is working correctly now (see below)...

USB Map.jpg

Edit 2019-11-20: Updated the Clover Bootloader link to reflect the change in location for new builds from SourceForge to GitHub.
Last edited:
Great post. I sweated so much today to make the system running again.
Fortunately I just had to copy-paste the .efi from the old to the new driver folder.
This post should be set to sticky!
Last edited:
Brilliant! Works beautifully.
Thx! Works!
wish I'd read this yesterday, would have saved me a heap of trouble last night.
Fortunately I had an old Yosemite USB installer which was enough to get me to a prompt with a network connection.
I realized the drivers64UEFI folder was missing drivers, so manually copied them from a network backup, but still had boot issues. It was only after reading the Clover installer readme in the EFI partition that I realized the folder structure and naming of the drivers had changed. A quick move and rename and was back up and running.

Good guide, it hope it saves others from the same trouble i had.
Thank you very much for this guide!!!
Same problem here with the AptioMemoryFix-64, hopefully they will include this driver in a future release again. (In r5045 it's still not included).
Thanks for this guide-- there seems to be little upgrade info available for the recent Clover changes.

I upgraded successfully to r5045 on my Z370 rig.

I did a first run by installing on a USB stick. I opened the EFI partition and erased its contents manually, then did a 'clean' install. I then added back in the kexts I use on my system and the 'config.plist' plus the ssdt patches for USB. After making sure it ran fine booting from the USB (F12 in BIOS to choose drive) a few times, I made the same changes to my regular boot drive.

I have always needed (at least in the past) an aptiomemoryfix component so installed the 'OsxAptioFixDrv.efi'.



Seems to boot fine with the new setup so far.
Updated to Clover v5045 from pre 5k version.

Checked EFI/CLOVER/UEFI and noticed a new "drivers" folder. It contained exactly the same drivers as my old EFI/CLOVER/drivers64UEFI folder, except the"64" of course.
Rebooting with this 2 folders side by side had no ill effect as it booted without a hitch.

I then manually removed the drivers64UEFI folder and rebooted. everything good.

Drivers:UEFI folder after Clover v5045 update.png

drivers64UEFI folder.png
Thank you, worked like a charm. I just copied those .efi files that I could not find in there, as well as the rest of the EFI folder.