Contribute
Register

How to solve the black screen with RX 470 in High Sierra 10.13.6?

Status
Not open for further replies.
Joined
Jan 23, 2018
Messages
66
Motherboard
GA-a320m S2H
CPU
Ryzen 5 1600 af
Graphics
AMD Radeon RX 470 4gb
Mac
  1. iMac
Mobile Phone
  1. Android
My configuration is:

CPU: Core 2 Duo E7400
Motherboard: Biostar G41D3
Ram: 8 gb DDR3
GPU: XFX RX 470 RS 4GB

My integrated graphics are GMA X4500, as I understand, they correspond to the motherboard and not to the processor, therefore, I can not use IGPU. When I use IGP in Bios, the system loads with intel graphics but without acceleration and it does not detect my GPU. When I change to PEG, clover loads perfectly and the system works only up to half the load of the apple logo, because then the video jumps and stays on the black screen. I have Lilu and Whatervegreen loaded in L \ E but still on black screen. I appreciate all your suggestions.
 
Joined
Jan 23, 2018
Messages
66
Motherboard
GA-a320m S2H
CPU
Ryzen 5 1600 af
Graphics
AMD Radeon RX 470 4gb
Mac
  1. iMac
Mobile Phone
  1. Android
My configuration is:

CPU: Core 2 Duo E7400
Motherboard: Biostar G41D3
Ram: 8 gb DDR3
GPU: XFX RX 470 RS 4GB

My integrated graphics are GMA X4500, as I understand, they correspond to the motherboard and not to the processor, therefore, I can not use IGPU. When I use IGP in Bios, the system loads with Intel graphics but without acceleration and does not detect my GPU. When I switch to PEG, the clover is loaded perfectly and the system works only up to half the load of the Apple logo, because then the video jumps and stays on the black screen. I have Lilu and Whatervegreen loaded in L \ E but still on the black screen. I appreciate all your suggestions. I attach my config.plist file. I appreciate your help
 

Attachments

  • config.plist
    23.4 KB · Views: 76
Joined
Jan 23, 2018
Messages
66
Motherboard
GA-a320m S2H
CPU
Ryzen 5 1600 af
Graphics
AMD Radeon RX 470 4gb
Mac
  1. iMac
Mobile Phone
  1. Android
Hello @macnb. I would appreciate your help in this situation. I see that you have a lot of knowledge and you have contributed a lot in the problem of aldo.riese.
 
Joined
Oct 23, 2010
Messages
969
Motherboard
GA-Z77X-UP5-TH
CPU
i7-3770K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello @macnb. I would appreciate your help in this situation. I see that you have a lot of knowledge and you have contributed a lot in the problem of aldo.riese.
If you are trying Mojave, then I'm afraid your motherboard/CPU is too old and not supported as iMac10,1
 
Joined
Jan 23, 2018
Messages
66
Motherboard
GA-a320m S2H
CPU
Ryzen 5 1600 af
Graphics
AMD Radeon RX 470 4gb
Mac
  1. iMac
Mobile Phone
  1. Android
If you are trying Mojave, then I'm afraid your motherboard/CPU is too old and not supported as iMac10,1
Yes, I have made other queries and indeed, my configuration is very old to get a full acerleración. Similarly, thank you for answering.
 
Status
Not open for further replies.
Top