Contribute
Register

How to Prepare for Big Sur

Joined
May 31, 2011
Messages
13
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
GT 640
Mobile Phone
  1. Android
  2. iOS
I am also looking to move away from my iMac 13,2 definition which has worked wonderfully up till now. Any hint on what I should try with my older system?
 

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,307
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
From my experience there are only two values that allow you to properly sign in and use iMessage without getting a single error code.

MLB (Board Serial Number) and ROM, if you take those two values from a real mac hardware that is either discontinued or damaged, generate your own unique(unused) serial number according to the SMBIOS that you want to use and your own UUID, paste the MLB and ROM taken from that Mac, you have 100% successful sign-in rate and never get any error.

Newer AppleID(s) no matter if all values are correctly generated and properly match, you won't be able to ever sign in to iMessage, you will get the error with customer code and have to call Apple, even that route didn't work on my case and simply gave up, grabbed a few old non usable MLB and ROM pairs for my devices and use that way.
 
Joined
Jan 22, 2020
Messages
86
Motherboard
AORUS Z390 Master
CPU
i9-9900K
Graphics
Vega 64
Did a fresh install from an USB-Installer.
OpenCore 0.6.3, updated Kext.
Installation process was very slow, although I have a very fast Hackintosh.
Ethernet was not working. I had to set DisableIOMapper to yes, in order to make it work.
 
Last edited:
Joined
Jul 5, 2016
Messages
59
Motherboard
ASUS Z97 A+
CPU
i7-4790
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
boot verbose so you can get an idea of the issue, make sure you added the new config.plist entries
Hello there !!! ... Finally I managed to install Clover 5123.1 and it is working fine in my Catalina 10.15.7 OS !!! ... I have modified my config.plist file to include the "Quirks" ... and I started the Big Sur update !!! ... In the first reboot ... the computer goes into the installation but it NEVER does something beyond the Apple Sign !!! ... It stays there as waiting for something !!! ... As you mentioned ... I rebooted in verbose but I have no idea about what is happening !!! ... Here I include a screen capture of the last screen when it stops ... And ... I also include the actual config.plist which is being use !!! ... I appreciate your time and any help you can give me !!! ... THKSM ...
 

Attachments

  • Screen Capture.jpg
    Screen Capture.jpg
    1.9 MB · Views: 53
  • config.plist
    8.6 KB · Views: 47
Joined
Jul 26, 2012
Messages
249
Motherboard
Z270 GAMING K3
CPU
I7-7700K
Graphics
AMD RADEON RX 580
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Hello there !!! ... Finally I managed to install Clover 5123.1 and it is working fine in my Catalina 10.15.7 OS !!! ... I have modified my config.plist file to include the "Quirks" ... and I started the Big Sur update !!! ... In the first reboot ... the computer goes into the installation but it NEVER does something beyond the Apple Sign !!! ... It stays there as waiting for something !!! ... As you mentioned ... I rebooted in verbose but I have no idea about what is happening !!! ... Here I include a screen capture of the last screen when it stops ... And ... I also include the actual config.plist which is being use !!! ... I appreciate your time and any help you can give me !!! ... THKSM ...
hi it is the quirks which are badly set for your cpu, the settings change depending on the cpu generation and the version of clover, macOS version
it will be easier to use this tool to make a basic EFI opencore the name of this program is OC GEN-X

once your installation is done you can finalize by following the guide
https://dortania.github.io/OpenCore-Install-Guide/config.plist/haswell.html#deviceproperties

you can check your config.plist opencore at
 
Joined
Jul 5, 2016
Messages
59
Motherboard
ASUS Z97 A+
CPU
i7-4790
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
hi it is the quirks which are badly set for your cpu, the settings change depending on the cpu generation and the version of clover, macOS version
it will be easier to use this tool to make a basic EFI opencore the name of this program is OC GEN-X

once your installation is done you can finalize by following the guide
https://dortania.github.io/OpenCore-Install-Guide/config.plist/haswell.html#deviceproperties

you can check your config.plist opencore at
THKSM Gerard71 ... I will read ... and try !!!
 
Joined
Sep 18, 2015
Messages
3
Motherboard
Asus Z170 Sabertooth S
CPU
I5 7600K
Graphics
Rx 480 Strix
Mobile Phone
  1. iOS
I updated to VirtualSMC but it says "keys not found" while booting.
How do I fix that?
 
Joined
Nov 13, 2011
Messages
34
Motherboard
Z77X-UP4 TH
CPU
Intel Core i7-3770
Graphics
R9-280X(GV-R928XOC-3GD) / GTX-780(N780-3GD5) / VEGA56
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
I am also looking to move away from my imac 13,2 definition which has worked wonderfully up till now. Any hint on what I should try with my older system?
I've tried Big Sur beta 5 before. I changed from iMac 13,2 (Clover 5117) to iMacPro1,1 (OpenCore 0.6.1) , and it works well.
 
Top