Contribute
Register

[HOW TO] OpenCore 0.6.4 > 0.6.5 differences

Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
Your efi partition booted for me but the one I updated wouldn't even boot to the open core menu. not sure what is that different other than you have it set to 19.1 and mine was set to 17. minor differences in the config plist so not sure why it didn't boot. If you have time to look, I attached the efi.
Thanks
Dear friend, it is always a good idea to check config.plist file with the ocvalidate utility.
ocvalidate is included in the Utilities folder of each version of OpenCore.
config.plist and ocvalidate must be of the same OpenCore version.
The easiest way is to open Terminal in the ocvalidate folder and type ./ocvalidate followed by the path to config.plist (you can drag the file onto the Terminal window).
In your EFI, when I check config.plist I get these messages:
  • OCS: Missing key AllowRelocationBlock, context <Quirks>!
  • OCS: Missing key Patch, context <Booter>!
  • OCS: Missing key PickerVariant, context <Boot>!
  • OCS: Missing key BlacklistAppleUpdate, context <Security>!
  • OCS: Missing key RealPath, context <Tools>!
  • OCS: Missing key TextMode, context <Tools>!
  • OCS: Missing key RealPath, context <Tools>!
  • OCS: Missing key TextMode, context <Tools>!
  • OCS: Failed to calculate size of false field containing <empty> as type integer, context <PlayChime>!
  • OCS: Missing key SetupDelay, context <Audio>!
  • OCS: No schema for DeduplicateBootOrder at 0 index, context <Quirks>!
Missing warnings say that those keys are missing:
  • AllowRelocationBlock, BlacklistAppleUpdate added in 0.6.4
  • PickerVariant, SetupDelay added in 0.6.5
  • You have removed Patch in Booter
  • In Tools, 2 properties are added to each tool: RealPath and TextMode, in 0.6.4.
Failed to calculate: PlayChime key has changed its type, from boolean to string, in 0.6.4.

DeduplicateBootOrder key has been removed (in 0.6.5).

But apart from those messages, in your EFI folder there are OpenCore files that are not from 0.6.5, this is the main bug preventing booting.

I have taken OpenCore 0.6.5 files and fixed config.plist and now your EFI boots fine.

Review these articles:
 

Attachments

  • EFI-065.zip
    2.6 MB · Views: 40
Last edited:
Joined
Nov 3, 2013
Messages
77
Motherboard
Ga-Z390-AORUS-PRO
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
@miliuco Have you been able to see if power management is working on your Hack? I am using Intel Power Gadget and I am not sure I am reading it correctly. Core Max is always at 5.0, I that normal?
Screen Shot 2021-03-03 at 8.43.31 PM.png
 
Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
@IAmSpectre
Have you fixed the problems with your EFI? Tell me something.

Sure you have power management. Max freq of your CPU is 5 and min freq is 1.2 (or 0.8 as I have read somewhere). As seen in your pics. Current freq oscillates between both numbers. This is how it should be.
The only noteworthy thing is that freq is around 2 and does not go down to 1.2, this is normal if you are performing some task while Intel Power Gadget is running but it is a bit high when it is the only app started.
 
Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
@IAmSpectre
There is a kext called CPUFriend that allows to generate custom configurations for CPU power management. It is a Lilu plugin and can be downloaded from Acidanthera's GitHub. It is intended for cases in which the CPU is not well recognized and frequency settings are not detected correctly, but it is also useful when the CPU is well recognized but some parameter needs to be tweaked.

Our CPU seems to have a floor (CORE MIN) of 0.8 GHz, not 1.2 as I see in your image. The top (CORE MAX) is 5 which is the maximum turbo frequency it can get. And the basic frequency is 3.6, which is the one in which the TDP is measured (thermal consumption in watts, which is 95).

I have prepared CPUFriend for our CPU so that the minimum freq is 0.8. CPUFriend.kext (plugin that allows adjusting power management) is always accompanied by CPUFriendDataProvider, which is the one generated by the user with the configuration for his CPU. Both kexts are into the attached zip. You have to copy the 2 files to kexts folder and add them in config.plist. Reboot. Look at Intel Power Gadget to see if freq drops to lows of 0.8 or oscillates with dips below 2.

I attach an image of my PC, I have started only Safari and Chrome as I write this and read the forum, there you see that CORE MIN is 0.7 (I don't know why it comes out like this because I chose 0.8) and that it oscillates more than in your case with some lowered to less than 2.

Keep in mind that Intel Power Gadget running raises the freq 300-800 MHz so without that app the numbers are lower.

Try and comment.

ipg.png
 

Attachments

  • CPUFriend.zip
    18.1 KB · Views: 19
Last edited:
Joined
Aug 25, 2012
Messages
1,088
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
  1. MacBook Pro
Classic Mac
  1. Performa
  2. Power Mac
  3. PowerBook
  4. Quadra
Mobile Phone
  1. iOS
My core min hovers between 0.7 and 1.2, all without CPUfriend. My core avg is a bit higher than @milliuco, but I have lots of daemons/bg processes running, so I guess that is expected behaviour.
 
Joined
Dec 10, 2010
Messages
738
Motherboard
Gigabyte Z390 Aorus Elite
CPU
i9-9900K
Graphics
RX 580
Mobile Phone
  1. iOS
My core min hovers between 0.7 and 1.2, all without CPUfriend. My core avg is a bit higher than @milliuco, but I have lots of daemons/bg processes running, so I guess that is expected behaviour.
Then I think you have CPUPM well working.
 
Joined
Nov 3, 2013
Messages
77
Motherboard
Ga-Z390-AORUS-PRO
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
@IAmSpectre
Have you fixed the problems with your EFI? Tell me something.

Sure you have power management. Max freq of your CPU is 5 and min freq is 1.2 (or 0.8 as I have read somewhere). As seen in your pics. Current freq oscillates between both numbers. This is how it should be.
The only noteworthy thing is that freq is around 2 and does not go down to 1.2, this is normal if you are performing some task while Intel Power Gadget is running but it is a bit high when it is the only app started.
I am sorry I didn't get back to you on that. Yes I did a lbunch of reading and found OC_GEN-X which helped a lot on getting new updates for OC Plus a few videos on how to compare and upgrade the Plist's. I didn't thank you for helping me last time with that and again I am sorry. I am understanding how OC works much better now.
The EFI's you sent worked flawlessly, thank you.
 
Top