Contribute
Register

How to Install OS X Mavericks using Clover

Joined
May 5, 2012
Messages
27
Mac
Classic Mac
Mobile Phone
I just recently got Clover up and running on my GA Z87X-UD7-TH using UEFI. Everything seems to work fine except one last bit I can't shake out: The startup disk value doesn't get saved to nvram. Everything else gets saved to nvram between reboots just fine without the use of EmuVariableUefi. But for some reason the efi-boot-device and efi-boot-device-data variables do not. Whenever I reboot, Clover doesn't automatically choose my startup drive. It does pick up other settings.

Anyone have any ideas?

Solved it. Apparently when you have the DefaultVolume config option set, it nukes your efi-boot-device and efi-boot-device-data on startup. This seems extremely weird given the description on the wiki, which states: "Alternatively the default entry can be set in NVRAM using the Startup Disk preference panel and it will be given preference over the value given here."
 
Joined
Oct 1, 2014
Messages
3
Motherboard
Asus Maximus V Formula
CPU
Intel 3770k
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Hello

I hv

Asus Maximus V Formula
Intel 3770k
HD4000
Dell Ultrasharp U2414H (mini dp to dp connect)


boot with clover

but graphics on installer is pathetic i.e. 640x480 :confused:

so could not click on install button :banghead:

pls help



EDIT :


Install successful :thumbup::thumbup:

ps: missing CsmVideoDxe-64.efi this bad boy cuz bad graphics on boot screen :evil:


Happy Happy :D:D
 
Last edited:
Joined
Apr 15, 2010
Messages
61
Motherboard
HP Spectre x360
CPU
i7 8565U
Graphics
MX150 + UDH 620, 1920 x 1080
I'm stuck at getting the Installer to show on my Z97X-UD5H • 4790k • GeForce 9800GT

I have tried the Nvidia config.plist with the UEFI setup and it gets me as far as screenshot 1 shows, before the screen goes black. For all I know the Installer's there in the background.

There are a couple of people claiming to have it working without DSDT & SSDT (see http://trick77.com/2014/08/03/new-hackintosh-build-based-gigabyte-ga-z97x-ud5h/) but with that config.plist I can't get past screenshot 2. I am using only FakeSMC, however.

Any ideas?
 

Attachments

  • 1.jpg
    1.jpg
    956.9 KB · Views: 164
  • 2.jpg
    2.jpg
    688.5 KB · Views: 155
Joined
Aug 4, 2014
Messages
67
Motherboard
ASUS z97 deluxe
CPU
4790k
Graphics
r9 280x
Mac
Classic Mac
Mobile Phone
Hello

I hv

Asus Maximus V Formula
Intel 3770k
HD4000
Dell Ultrasharp U2414H (mini dp to dp connect)


boot with clover

but graphics on installer is pathetic i.e. 640x480 :confused:

so could not click on install button :banghead:

pls help



EDIT :


Install successful :thumbup::thumbup:

ps: missing CsmVideoDxe-64.efi this bad boy cuz bad graphics on boot screen :evil:


Happy Happy :D:D


Hi Sayatan did you get audio to work?
 
Joined
Jan 10, 2013
Messages
9
Motherboard
ASUS ROG MAXIMUS VIII HERO/Whetstone LGA1151
CPU
i7 4770k
Graphics
R9 390 MSI 8GB
nice guide everything works but i have sometimes problems with usb when it boot i cant use keyboard or mouse lol i have to reset few times then works idk what i miss maybe some1 know how to fix it ?? and is it possible to install chameleon bootloader over clover ? cause i cant boot windows form clover :( i have to press F8 then choose windows if i need it :(
sorry im not a pro with all that :)
is it possible to make usb3 works on my board ? i don't really care about it
my system
Sabertooth Z77 ati HD 7850 al boot exept audio (have to install from multibeast)
Thank you for this guide
 

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,722
Motherboard
PRIME Z490-A
CPU
i5 10600K
Graphics
Vega 56
Mac
  1. MacBook Air
Classic Mac
  1. Apple
  2. PowerBook
Mobile Phone
  1. iOS
Just added config.plist-Intel-HD4600-desktop-fixed.zip to top post. The fixed version should give full acceleration for HD 4600 graphics.
 
Joined
Oct 11, 2014
Messages
1
Motherboard
OSX 10.9.5
CPU
Intel Core i7 2600K
Graphics
Intel Graphics HD 3000 0x01228086
Mac
Classic Mac
Mobile Phone
Just added config.plist-Intel-HD4600-desktop-fixed.zip to top post. The fixed version should give full acceleration for HD 4600 graphics.

Hi, may you provide a config.list for Core i7 2600K HD3000(0x01228086) full acceleration?
I had try inject EDID + Inject Intel + FakeID 0x01268086 with Clover r2953, but that only cause a stop after AppleIntelE1000.
 
Joined
Apr 15, 2010
Messages
61
Motherboard
HP Spectre x360
CPU
i7 8565U
Graphics
MX150 + UDH 620, 1920 x 1080
Using the HD4600 config.plist with Clover r2593 and the onboard HDMI connection, I was finally able to get to the 10.9.5 installer screen on my Z97X-UD5H + 4790k combo. There were errors about CPU management and states, as the chip is currently unsupported, but that's a clear win for me.

Now that Yosemite is likely only a few days away, I think I'll just wait and see how I do with it.

Peas out!
 
Top