Contribute
Register

How to install Broadcom BCM94352 (0a5c:216f) ?

Joined
Sep 15, 2015
Messages
12
Motherboard
Dell 7348
CPU
i7-5500U
Graphics
HD 5500
Hey all! :)

I've been struggling with installing this WiFi+BT combo card in my laptop Dell Inspiron 13 7000 Series. So far Sierra seems to be working okay. It originally came with an Intel WiFi+BT combo I had to replace with this one and so far I've spent around two full days trying to get it working with no avail :(

I've attached an IOReg report here as I've read in the forum with the requested IOReg app version (I know, there's some other stuff missing such as CPU power management, Intel driver and so on (which I would gladly appreciate some insights!)). It seems that while it is detected, the firmware does not get updated (for some unknown reason). I've checked that the repo kext has a matching .zhx file in it and while it does seem to partially load (BT is detected but I haven't tested it yet), I need WiFi and I'm not getting it :(.

I've also attached a screen capture of the message I get regarding the card. For installation, I've put FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, BrcmFirmwareRepo.kext, BrcmFirmwareData.kext and BrcmPatchRAM2.kext in /S/L/E using the latest Kext Utility app.

Any ideas are welcome and greatly appreciated!

Thanks in advance :)
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hey all! :)

I've been struggling with installing this WiFi+BT combo card in my laptop Dell Inspiron 13 7000 Series. So far Sierra seems to be working okay. It originally came with an Intel WiFi+BT combo I had to replace with this one and so far I've spent around two full days trying to get it working with no avail :(

I've attached an IOReg report here as I've read in the forum with the requested IOReg app version (I know, there's some other stuff missing such as CPU power management, Intel driver and so on (which I would gladly appreciate some insights!)). It seems that while it is detected, the firmware does not get updated (for some unknown reason). I've checked that the repo kext has a matching .zhx file in it and while it does seem to partially load (BT is detected but I haven't tested it yet), I need WiFi and I'm not getting it :(.

I've also attached a screen capture of the message I get regarding the card. For installation, I've put FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, BrcmFirmwareRepo.kext, BrcmFirmwareData.kext and BrcmPatchRAM2.kext in /S/L/E using the latest Kext Utility app.

Any ideas are welcome and greatly appreciated!

Thanks in advance :)
Firmware is pushed to the BT controller only when it is not loaded. This is on cold boot, and wake from sleep only. Firmware is retained on a restart as the BT controller did not suffer a power loss.
 
Joined
Sep 15, 2015
Messages
12
Motherboard
Dell 7348
CPU
i7-5500U
Graphics
HD 5500
Firmware is pushed to the BT controller only when it is not loaded. This is on cold boot, and wake from sleep only. Firmware is retained on a restart as the BT controller did not suffer a power loss.
Thanks for your prompt answer!

Indeed you are right, it's related to BT but not to WiFi. I managed to install your latest versions (great job btw!) of the BrcmFirmwareRepo/Data + PatchRAM2 and it seems to work. However, although my WiFi is working and such, it seems to have a ghost WiFi device instead, and WiFi is being served through a Bluetooth PAN (weird). It works, yeah, but it kinda makes me feel uneasy xD.

Here's what I have:

Screen Shot 2016-11-19 at 16.43.36.png


Also, I had to use these patches to make the WiFi work. I was using them, but I placed them in the wrong sections. Using the Clover Configurator helped me see the correct place to add them (I was placing them in DSDT patches instead of Kext patches):

Total of 4 patches:
Screen Shot 2016-11-19 at 16.48.02.png

Screen Shot 2016-11-19 at 16.48.22.png


Thanks again for your help!. I now have other issues, specially with the display not coming back after sleep (backlight does though), but I will make another thread for that so to not mix topics. :)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks for your prompt answer!

Indeed you are right, it's related to BT but not to WiFi. I managed to install your latest versions (great job btw!) of the BrcmFirmwareRepo/Data + PatchRAM2 and it seems to work. However, although my WiFi is working and such, it seems to have a ghost WiFi device instead, and WiFi is being served through a Bluetooth PAN (weird). It works, yeah, but it kinda makes me feel uneasy xD.

Here's what I have:

View attachment 221526

Also, I had to use these patches to make the WiFi work. I was using them, but I placed them in the wrong sections. Using the Clover Configurator helped me see the correct place to add them (I was placing them in DSDT patches instead of Kext patches):

Total of 4 patches:
View attachment 221527
View attachment 221528

Thanks again for your help!. I now have other issues, specially with the display not coming back after sleep (backlight does though), but I will make another thread for that so to not mix topics. :)
You should probably reset your network interfaces to correct the names.

Instructions are in the FAQ.
 
Joined
Sep 15, 2015
Messages
12
Motherboard
Dell 7348
CPU
i7-5500U
Graphics
HD 5500
You should probably reset your network interfaces to correct the names.

Instructions are in the FAQ.
I'm sorry, I'm kinda new in this hackintosh world (2nd hack so far). What FAQ are you referring to? and by "reset your network interfaces", what do you mean? sorry to ask these questions, but it's not clear for me :).

Also, if I press Fn+PrnScr (the key combo to enable/disable WiFi by hardware) it turns the WiFi off, but it doesn't turn on again until a reboot and some trial and error setting it on before first boot. No big deal, but it would be awesome if it worked correctly :(
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,395
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm sorry, I'm kinda new in this hackintosh world (2nd hack so far). What FAQ are you referring to? and by "reset your network interfaces", what do you mean? sorry to ask these questions, but it's not clear for me :).

Also, if I press Fn+PrnScr (the key combo to enable/disable WiFi by hardware) it turns the WiFi off, but it doesn't turn on again until a reboot and some trial and error setting it on before first boot. No big deal, but it would be awesome if it worked correctly :(
There is only one laptop FAQ around here...

http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html
 
Top