Contribute
Register

trs96

Moderator
Joined
Jul 31, 2012
Messages
18,904
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Just for curiosity, I was wondering why is the ROM ID not reported in the System Report? is there any other place where this value could be found?
Go to System Preferences/Network/Advanced and then click on the Hardware tab and you'll see it.

You can generate a random 12 character ROM by using Clover Configurator but using your own hardware's MAC address guarantees that no one else is using that ROM on their real Mac or hackintosh. Only your NIC has that address burned in.

Screen Shot 23.jpg
 
Last edited:
Joined
Feb 7, 2021
Messages
2
Motherboard
Optiplex 7070
CPU
i7 << need model # >> See Forum Rules !!
Graphics
UHD 630
I have a Dell Optiplex 7070 that is running Catalina. I've been unable to get iMessage to work. I've generated new unique MLBs, Serial Numbers, SmUUIDs, and have the correct type. I also have created a couple of new Apple IDs to avoid locking out my normal Apple ID. I'm using OpenCore. I tried four times prior to taking a holiday during Christmas last year. I always got the message that there was an error and to contact Apple.

Today I tried again using this guide: https://dortania.github.io/OpenCore-Post-Install/universal/iservices.html

I have a friend that has the exact same model 7070 and used his USB install stick with the MLB, serial number, and UUID changed. iMessage works just fine on his.

I'm wondering if there's another setting in my config.plist that matches his that's throwing off mine. Any ideas?
 
Top