Contribute
Register

How to Fix iMessage

Joined
Aug 9, 2010
Messages
119
Motherboard
Gigabyte Z87X-UD5H
CPU
Intel Core i5 4670K
Graphics
Intel HD Graphics 4600 1536 MB
Mac
iMac, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
Power Mac, Quadra
Mobile Phone
iOS
OK, so I finally managed to get it working. The solution, reset your password, and to think I must have installed / re-installed about 5 / 6 times.

Very Happy!!!!

Thanks
 
Joined
Feb 28, 2013
Messages
173
Motherboard
Gigabyte GA-Z77N-WIFI
CPU
i7 3770K
Graphics
NVIDIA GeForce GTX 770
Mac
iMac, MacBook, Mac Pro
Mobile Phone
Android, iOS
Yay! Password reset was the trick. My only complaint is that it made me change it to something else that is longer with lots of rules, (cap letter, no 3 characters in a row) But now I have iMessages working on all my computers. Thanks!
 
Joined
Sep 1, 2012
Messages
56
Motherboard
PC
CPU
3770K
Graphics
570 HD
Mac
Classic Mac
Mobile Phone
Yay! Password reset was the trick. My only complaint is that it made me change it to something else that is longer with lots of rules, (cap letter, no 3 characters in a row) But now I have iMessages working on all my computers. Thanks!

It is very strange, although I posted that step 5 (you can use the same password), when I tried to reset it again, it told me I needed a new password. I absolutely guarantee that I used the same password the first time I reset my imessage account. Not sure why it let me do that the first time and not again.

Just to add to my steps. I stated that I did not need FileNVRAM.dylib... I performed a clean install of mavericks again just to clean up all my mess from trying to get imessage working. I did require FileNVRAM .2 to log into imessage with a fresh install.
 
Joined
May 23, 2011
Messages
10
Motherboard
HackPro
CPU
i7-3770k
Graphics
GTX 660 2GB
Mac
Classic Mac
Mobile Phone
iOS
This guide has been the only one to get me *close* to iMessages working on my Mavericks hackintosh. Logging in from a genuine Mac and viewing the account details did the trick to get iMessage on the hackintosh to at least log in. But nothing would show up in the message list, and when I go to preferences, it shows my iMessage account as "inactive". Closing the app and reopening causes it to ask for my password again, and then we're back to the same problem - won't log in and errors out with an activation problem.

What can I do to make it work, and make it "stick"?
 
Joined
May 23, 2011
Messages
10
Motherboard
HackPro
CPU
i7-3770k
Graphics
GTX 660 2GB
Mac
Classic Mac
Mobile Phone
iOS
OK... I think I got it figured out. You MUST have FileNVRAM.dylib version 1.1.2 installed, and NOT version 1.1.3, as apparently this latter does not work. To check your version, run
Code:
otool -L /Extra/modules/FileNVRAM.dylib
and if necessary download the correct version from http://public.xzenue.com/downloads/

This allows you to login to iMessage, and exiting the app does not log you out again.

However, iMessage on the computer only allows messaging using an email address, and NOT the phone number. As a matter of fact, the right side of the preferences pane ('Accounts" tab) in iMessage is just blank. Nothing is shown, so I can't change any address options or log out of the iMessage account).
 
Joined
Dec 30, 2011
Messages
11
Motherboard
P7P55D-E LX
CPU
Intel Core i5 650@3.20GHz
Graphics
ATI Radeon HD 5700
Mac
Classic Mac
Mobile Phone
Worked for me perfectly. I only deleted the necessary files and copied the first version of the linked file. After reboot works like CHARM! Thanks very much guys!
 
Joined
Sep 14, 2012
Messages
34
Motherboard
Asus Hero X Z370
CPU
i7-8700K
Graphics
2x RX 580
Mobile Phone
Android
worked great with 10.9 on Asus P8z68 V-Pro gen3 with patched BIOS, i7-2600k


  1. trashed prefs
  2. ran chimera wizard and updated the serials with the random buttons
  3. copied the FileNVRAM.dylib (original one, not the latest one) to the modules folder
  4. repaired permissions
  5. reboot

works :)

thx !
 

ccm

Joined
Apr 27, 2012
Messages
10
Motherboard
Gigabyte
CPU
i7
Graphics
GTX 670
Mac
Classic Mac
Mobile Phone
I can confirm that I tried every step here (and quite a few others elsewhere) and in the end I downgraded from 1.1.3 FileNVRAM.dylib to 1.1.2 and that almost fixed it.

I had deleted all the Messages related preference files per the original post so when I opened messages it prompted me to set up fresh. Initially it took my password and all the email addresses and my iphone number showed up but the check boxes would not allow me to select them. I hit the back button and did my password again and they all came up checked as they should. I continued and after 10-15 seconds I got the error again that it could not register.

I quit and opened Messages again and again is prompted me as if it was a new install except my appleid was in the window that came up. I again entered my password, had the same check box issue that cleared up when I went back and tried again. This time I did not get a registration error however when I went to send a message the txt that is "iMessage" when working said "iMessage inactive". On a whim I send a test message and though I got a red circle with an exclamation point next to the message that said "Your message could not be sent. Click “Try Again” to send this message" it did actually send. I quit Messages again and this time when I opened them it said "iMessage" in the text box as expected and seems to work flawlessly for the moment.

I initially had zero issues with Messages/iMessage and my father who has the exact same build as I do has not had issues. As I was working I initially did not start out trying to fix this methodically as I should have. I also jumped ahead and put the 1.1.3 FileNVRAM.dylib in place right away. I think this and the settings reset is what actually got me working, but, I cannot be sure. I only know that my last step of downgrading to 1.1.2 worked and 1.1.3 would not work.

So in conclusion:

1. Be methodical
2. Persist (try things that don't work several times)
3. Don't trust the feedback from Apple. Messages itself has lots of quirks on official apple devices e.g. it will often say a message was not delivered because there was one iDevice/system your recipient doesn't have the right password in etc.
4. Document better than I did so you can help people here better than I am.
 
Joined
May 23, 2011
Messages
10
Motherboard
HackPro
CPU
i7-3770k
Graphics
GTX 660 2GB
Mac
Classic Mac
Mobile Phone
iOS
Can anyone comment on my problem of nothing being shown on the right side of the preferences pane? Anyone else experiencing this? iMessage is working, and I can send and receive messages, but only from email addresses, and the messages do not show up on my phone threads. Of course, I can't adjust my options on the computer because nothing is shown in that window. Screenshot attached.
 

Attachments

Joined
Jun 15, 2013
Messages
235
Motherboard
GA-Z77X-UP4 TH
CPU
i7 3770K OC:4.2GHz
Graphics
GTX960 (Asus strix)
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
iOS
1.1.2 worked. Although i got some errors after reboot and after i started iMessage. Then i realised i forgot to repair permissions. I did. Then i had to reenable my accounts in iMessage. But all the chats and pictures are gone now. I wonder if deleting the messages and com.appe etc plist's was necessary. I try to put them out of the trash back on place now.

edit: For me, just replacing the version 1.1.2 is all that was needed, and not deleting all the files mentioned in the first post.
 
Top