Contribute
Register
Joined
Mar 9, 2012
Messages
2,630
Motherboard
Gigabyte Z590 AORUS MASTER
CPU
i7-11700k
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Hi,
Thanks to your guide I managed to fix iMessage but each time I use a new serial number it works for once and after I shutdown my laptop and start it again it shows me the " You cannot sign in to iMessage on this Mac at this time. To use iMessage with this Mac, contact Apple Support and provide the code below." message.
I have checked iMessageDebug output and it's the same between reboots. What's the problem?

Stop injecting new serial numbers, use one that is unique to your pc only and stick with it, then log into your iCloud account on the web and remove any with the serial numbers you've tried leaving your current one. When you try iMsg again and it doesn't logon, don't be tempted to change the S/N again just leave it as it is.
 
Joined
Jul 31, 2014
Messages
7
Motherboard
Asus K55VJ
CPU
3630QM
Graphics
HD4000,GT635M - 1366*768
Ok, I checked my appleID and only my current serial number was assigned to it. But I still get that message. I have no problem with App Store though.
 
Joined
Jan 17, 2011
Messages
5
Motherboard
High Sierra
CPU
I78700
Graphics
GeForce® GTX 1050-
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi again,

imessage don't work on my system.
I read all the forum entries and set all parameters.
Imessage_debug has no errors.

But on login to imessage, i got the Error: Please contact ....

Could someone out there help me?

I add my config.plist

/jörg
 

Attachments

  • config.plist
    7 KB · Views: 168
Joined
Mar 9, 2012
Messages
2,630
Motherboard
Gigabyte Z590 AORUS MASTER
CPU
i7-11700k
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Ok, I checked my appleID and only my current serial number was assigned to it. But I still get that message. I have no problem with App Store though.

Ok - If you ran iMsgDeBugger and all looks good then don't change anything just leave as and one day hopefully not too distant, it will start to work. Maybe Apple is applying a probationary period for some Builds/Apple ID's we don't know but if you read through some posts, you'll find numerous cases where others in your situation their logon started to work.
 
Joined
Oct 28, 2010
Messages
133
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i9-9900K
Graphics
RX 570
I've had a working iMessage/Facetime for *years*. Suddenly sometime after 6/10 it just stopped working. I get activation errors every time I try to sign in. I've tried all the "iMessage fix" things to no avail.

Did anyone else have a perfectly working iMessage/Facetime and them it stopped working. I'm not entierly sure, but I think this was right after I updated to 10.13.5
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,977
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I've had a working iMessage/Facetime for *years*. Suddenly sometime after 6/10 it just stopped working. I get activation errors every time I try to sign in. I've tried all the "iMessage fix" things to no avail.

Did anyone else have a perfectly working iMessage/Facetime and them it stopped working. I'm not entierly sure, but I think this was right after I updated to 10.13.5
Some have said that it is related to Clover.
Try reverting if you have recently upgraded it.
 
Joined
Oct 28, 2010
Messages
133
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i9-9900K
Graphics
RX 570
Yea, I though that too. I reverted to two versions (4497) back but I think the damage is done. Still can’t access iMessage/Facetime. I really don't want to mess with serial numbers and IDs too much. I even tried to boot into an older back up but that didn't work either.
 
Joined
Aug 21, 2011
Messages
27
Motherboard
Gigabyte GA-EP45-DS3
CPU
Q9550
Graphics
GT640
Yea, I though that too. I reverted to two versions (4497) back but I think the damage is done. Still can’t access iMessage/Facetime. I really don't want to mess with serial numbers and IDs too much. I even tried to boot into an older back up but that didn't work either.

You (and the Threadadmin) should be aware of this: #9

Took me hours to find out too :-O
 
Joined
Oct 28, 2010
Messages
133
Motherboard
Gigabyte Z390 Aorus Pro Wifi
CPU
i9-9900K
Graphics
RX 570
Yes, all hail ApexDE for figuring this out. I reset all my settings back to what I had originally except for the LAN injection and it all works!

Having trouble signing into iTunes but that may clear up.

I'm guessing that Apple has gotten a little more particular about this setting in the last update.
 
Joined
Apr 26, 2018
Messages
2
Motherboard
ASUS Z370-F Strix Gaming
CPU
Intel i7 8700K
Graphics
MSI GTX 1070 Ti Gaming
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Anyone got this weird problem with imessage? Can't get imessage to work on my 10.13.5 hackintosh, tried every solution possible. Even got a new sim and create new appleID, no effect. BUT, signed in by my gf's account(which is more than 3 years old), imessage work perfectly.
Right now I'm very confused of what causing the problem, my hackintosh or my appleID?
 
Top