Contribute
Register
Joined
Feb 12, 2012
Messages
618
Motherboard
GA Z77 DS3H
CPU
2500K
Graphics
GTX 560 SC
Mac
  1. MacBook
Classic Mac
Mobile Phone
  1. iOS
Called them and after a while of being transferred around they said that they had documentation on my error/customer support code (9921-9784-3910) they said it had to do with not having a valid serial number. Any ideas? Has anyone else had this exact error code?

Edit: Just booted up the clone of my main drive and for about two minutes iMessage worked fine but then went back to the same error. What a tease.
 
Joined
Dec 15, 2012
Messages
74
Motherboard
motherboard OR system make and model # > See Rules!
CPU
i7-3770K
Graphics
GTX 660 Ti
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Called them and after a while of being transferred around they said that they had documentation on my error/customer support code (9921-9784-3910) they said it had to do with not having a valid serial number. Any ideas? Has anyone else had this exact error code?

Did you try this http://www.tonymacx86.com/general-help/110471-how-fix-imessage.html#post671803

Or try the adding a credit card to your apple ID.both off my builds all i had to do was add the 'FileNVRam.dynib', copy the ‘modules’ folder and paste it in the ‘/Extra’ my account has a credit card an i have no problem with imessage.
 
Joined
May 28, 2013
Messages
24
Motherboard
HP Probook 4430s
CPU
Intel Core i5-2410M
Graphics
Intel HD3000
Mac
Classic Mac
Mobile Phone
  1. iOS
This kinda ties in with my last post..

I called Apple and they just unregistered all my devices from iMessage and sent a verification code to my iPhone, registering it again. They told me they didn't need the activation code from my Mac. So I went back to iMessage on my iPhone, which still works, and iMessage on my Mac, which worked for a few seconds, then my Contacts turned red and it gave me another code like before. Then I noticed that on self solve.apple.com, where my S/N was previously invalid, there is a MacBook Pro with no purchase date, and now I can't use my S/N to contact Apple without paying the $19 for support.

So what do you suggest doing here? Changing my S/N and/or SystemId?
 
Joined
Feb 12, 2012
Messages
618
Motherboard
GA Z77 DS3H
CPU
2500K
Graphics
GTX 560 SC
Mac
  1. MacBook
Classic Mac
Mobile Phone
  1. iOS
My UUID in the nvram.uuid.plist and in IORegistryExplorer are identical, Both "9402de03-8004-6905-4106-d40700080009". The UUID listed in System Information is completely different, "8DC91BAC-42A2-5B48-8F5B-155317FFE0ED".

Is the UUID supposed to be the same in all 3 of the locations?
 
Joined
May 24, 2014
Messages
11
Motherboard
Asos
CPU
i7
Graphics
AMD
Mac
  1. iMac
Hey,

my imassage conacts but then it shows that it´s inactive.

Bildschirmfoto 2014-06-07 um 03.47.29.png Bildschirmfoto 2014-06-07 um 03.47.50.png

Anybody nows the problem?
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,989
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
.....
Then I noticed that on self solve.apple.com, where my S/N was previously invalid, there is a MacBook Pro with no purchase date, and now I can't use my S/N to contact Apple without paying the $19 for support.

So what do you suggest doing here? Changing my S/N and/or SystemId?

My UUID in the nvram.uuid.plist and in IORegistryExplorer are identical, Both "9402de03-8004-6905-4106-d40700080009". The UUID listed in System Information is completely different, "8DC91BAC-42A2-5B48-8F5B-155317FFE0ED".

Is the UUID supposed to be the same in all 3 of the locations?

@Garetty, @Albertsw + Others ...

The UUID in nvram.uuid.plist and in IORegistryExplorer ideally should be identical (but for some users this is sometimes not the case), The UUID listed in System Information should always be different.

To be honest I'm not sure what to advise, both of you have tried to call Apple with the customer code and both of you still have issues which puts you in uncharted waters, so far this has worked for everyone who has tried it ...... if it where me i would try the following:-

1. Logout of all Apple iCloud services & physically disconnect form your network (if possible)
2. Use the SId bug fix to override the BIOS SystemId regardless if your BIOS has SId bug or not.
3. Use Chameleon Wizard, check you have correct System Def for your Hack and generate new S/N
4. Use Step 3 in Part 1 of the guide to clear iMessage setup / config / data
5. Delete nvram.uuid.plist in /Extra
6. Reboot and check that new S/N and UUID's have taken
7. Check that the OSX Hardware UUID is different to the one you had originally.
8. Connect to network and create a new AppleID, make sure to register Credit Card against it.
9. Try iCloud, AppStore and iTunes first, if that works try iMessage

The above procedure will create a totally new identity for you and your hack (MAC) which has not been registered with Apple so hopefully no UUID lock out and iMessage will work for you. If not then we need to look a little deeper as to whats going on in your logs ... etc

If it works, try to avoid changing the S/N & UUID in the future, write them down and keep the safe, my personal theory is that the lock out occurs when the S/N has changed too many times against a OSX UUID, however it may be the other way round, I cover this in more detail part 2 of the guide.

Like i said in Post #628 its also possible that we're on the verge of seeing a new set of iMessage issues with the release of the new iMessage features in OSX 10.10 & IOS 8, lets hope that its not the case .....

FYI, iMessage is still working for me across all five of my Hacks and my iPhone 4.

Good Luck
Cheers
Jay
 
Joined
Feb 12, 2012
Messages
618
Motherboard
GA Z77 DS3H
CPU
2500K
Graphics
GTX 560 SC
Mac
  1. MacBook
Classic Mac
Mobile Phone
  1. iOS
Thanks Jaymonkey for the reply. Ive tried all those things and still can't log in. Hopefully we won't have this issue when 10.10 comes out.

Albert
 
Joined
Jul 18, 2011
Messages
13
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i5-3570K
Graphics
GTX 560 Ti
I am still having this issue. For me I keep getting the message: "An error occurred during activation. Try again." whenever I try to login to iMessage. I have tried all of the fixes and know that iMessage is communicating with apple because when I type in a wrong password it tells me so.

Any ideas on what else I can do? I started having the issue in Mavericks.
 
Top