Contribute
Register
Joined
Mar 9, 2012
Messages
2,518
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
i7 << need model # >> See Forum Rules !!
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Did the following install (see attached), ran through entire iDiot's guide again, still failing ROM and MLB in Debug...

Your NvRAM is not retaining your ROM and MLB values hence the failure of iMsg. I suggest download the latest version of Clover Configurator -> mount your EFI partition -> check that the two fore mentioned values are present if not input them again -> then go to this section of Configurator as shown in the pic and tick the box to the right of 'NVRAM emulation' and save to config.plist -> reboot and try iMsg with new settings. Good luck.
 

Attachments

  • Screen Shot 2017-01-26 at 21.30.20.png
    Screen Shot 2017-01-26 at 21.30.20.png
    342 KB · Views: 170
Joined
Dec 30, 2016
Messages
5
Motherboard
Gigabyte Z170 Gaming 5
CPU
2.7 GHz Intel Core i5 6400
Graphics
EVGA GeForce GT 740 2GB Super Clocked GDDR5
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iMac
  2. PowerBook
Mobile Phone
  1. iOS
Tried this additional setting, seems like it turns itself off after a restart, can't get it to stay checked. MLB/ROM still failing.
 
Joined
Jan 4, 2015
Messages
70
Motherboard
GA-B75M -D3H
CPU
pentium
Graphics
gt 210
Hello .. imessage and my face time only works on guest user in my hackintosh ... how to solve this ...?
 
Joined
Mar 9, 2012
Messages
2,518
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
i7 << need model # >> See Forum Rules !!
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Tried this additional setting, seems like it turns itself off after a restart, can't get it to stay checked. MLB/ROM still failing.

Maybe you'll have to reinstall because if the tip offered up by PILGR1M which usually solves that problem also what I suggested failed, signs point to slight corruption. I don't know what else you can do to overcome NVRAM failing, hopefully another member can offer a less drastic solution other than a complete reinstall - are you running the latest clover build and truthfully I'm clutching at straws here to find some sort of solution.
 
Joined
Mar 9, 2012
Messages
2,518
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
i7 << need model # >> See Forum Rules !!
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Hello .. imessage and my face time only works on guest user in my hackintosh ... how to solve this ...?

Can you logon to the Guest Account with your Apple ID? maybe you can try creating a new Apple ID, just make a small change to your ID and try to logon.
 
Joined
Mar 9, 2012
Messages
2,518
Motherboard
Gigabyte Z390 AORUS Pro WFI
CPU
i7 << need model # >> See Forum Rules !!
Graphics
RX 580
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Yes ... but how to do that.? could you explain me ?

If you can logon in the guest account with your ID but not in the 'Admin Account' then you can try creating another Apple ID and test both the 'Guest Account' and the 'Admin Account' with the newly created ID as I suspect your ID is causing a security flag to be thrown up in the 'Admin Account'. One way to circumvent the problem is to create a new Apple ID.
 
Joined
Oct 10, 2012
Messages
100
Motherboard
Asus Prime Z370-A
CPU
i5-9600K
Graphics
RX 560
I have followed the idiot's guide. Now iMessage works greatly. sincronize instantly with my iPad, instead before it did not recognize the recipient as a imessage owner.
Anyway, in the process of the guide, my bluetooth stopped working, i think it happened in the last 2-3 steps of the guide.
I use an adaptor with an original apple card (bcm943602cs) that worked OOB

do you have any idea why it happened?
ethernet is en0 and built-in
wifi is en1, not built-in
I switched also from iMac 14,1 to 13,2, that was the proper profile for my configuration
Tried to rebuild cache and repair permission,but still the situation does not change

EDIT - SOLVED
tried to change the usb on the mainboard that the adapter uses to power bluetooth and now it works.
Maybe the other old port is not recognized anymore and it does not power up? (shouldn't be like that anyway)

Something is wrong with USB recognition--> unibeast usb recognized at boot, but then in Sierra it's not recognized at all :|
All the USB ports used to work without issues
 
Last edited:
Joined
Jan 23, 2017
Messages
27
Motherboard
Gigabyte GA-B75M-D3H
CPU
i7-3770K
Graphics
GTX 960
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
I have followed the idiot's guide. Now iMessage works greatly. sincronize instantly with my iPad, instead before it did not recognize the recipient as a imessage owner.
Anyway, in the process of the guide, my bluetooth stopped working, i think it happened in the last 2-3 steps of the guide.
I use an adaptor with an original apple card (bcm943602cs) that worked OOB

do you have any idea why it happened?
ethernet is en0 and built-in
wifi is en1, not built-in
I switched also from iMac 14,1 to 13,2, that was the proper profile for my configuration
Tried to rebuild cache and repair permission,but still the situation does not change

EDIT - SOLVED
tried to change the usb on the mainboard that the adapter uses to power bluetooth and now it works.
Maybe the other old port is not recognized anymore and it does not power up? (shouldn't be like that anyway)

Something is wrong with USB recognition--> unibeast usb recognized at boot, but then in Sierra it's not recognized at all :|
All the USB ports used to work without issues


@klaphd How did you find a serial number compatible for the model 13,2? I don't find any :'(
 
Joined
Jan 4, 2015
Messages
70
Motherboard
GA-B75M -D3H
CPU
pentium
Graphics
gt 210
I can not send messages from Imessage from my Hackintosh to Imessage from my Iphone 4 ... a message appears stating that my Imessage id of my Iphone 4 is not registered in Imessage ... how to solve this ..?
 

Attachments

  • Captura de Tela 2017-01-31 às 20.06.44.png
    Captura de Tela 2017-01-31 às 20.06.44.png
    1.2 MB · Views: 104
  • Captura de Tela 2017-01-31 às 20.07.02.png
    Captura de Tela 2017-01-31 às 20.07.02.png
    1.2 MB · Views: 81
Top