Contribute
Register

How to Fix iMessage

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,474
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Same result of resetting the Networksettings (see the attachments):

Extra info: after every reboot I'm twice asked to enter my iCloud password.
When I enter my password it is not accepted. When I twice click "cancel" it disappear.
@tebogo,

I assume that you are trying to connect via WiFi .... if so ... turn off wireless and connect to your LAN via Ethernet if possible and try again ...

Try resetting local account info and server plists ...

Enable 'Show all Files', open finder and navigate to :-

Code:
/StartupDrive/Users/~Username/Library/Preferences
Delete the following files :-

  • com.apple.ids.service.com.apple.madrid.plist
  • com.apple.imessage.bag.plist
Empty trash, reboot and try again.

Cheers
Jay
 
Joined
Jul 26, 2012
Messages
272
Motherboard
Z77X-UP5 TH
CPU
i7-3770
Graphics
GTX 650 TI
Mac
Mac mini
Mobile Phone
iOS
to properly configure the machine you must:
- ethernet BSD en0
- Generate a smbios that corresponds to your CPU
-make a number of series with clover
- Make a SMUUID with terminal command "uuidgen"
-restard computer
-make a MLB AND ROM , MLBGen17V3 with this program can be found here (preferred a 17 MLB with SMBIOS recent Machine) "http://www.insanelymac.com/forum/topic/303073-pattern-of-mlb-main -logic-board / page 20 "
-restard computeur


if you have this message there is a problem with your computer configuration


Schermafbeelding 2015-02-28 om 19.40.52.png
if you have problems on this message does not necessarily comes from your computer, but Apple's servers (e.g. my hacks my Apple ID works, but if I use other ID of my family I have this message call Apple)
appleid-cant-be-used.jpg
 
Joined
Feb 25, 2011
Messages
42
Motherboard
Dell XPS 13 9370
CPU
i7-8550U
Graphics
Intel HD 620 UHD 4K
Mac
MacBook Pro
Mobile Phone
iOS
Hi,

I am having issues with getting my real mac working with iMessage and FaceTime

I followed the procedure on the first page to sign out and delete the MLB and ROM from the cloned Macs.

But after 10 days i am still getting the same errors on the genuine mac. I am on a call with apple as i write this but they seem to be lost too.

Wonder what i should tell them to get the real macbook clear from blacklist.

thanks for any help on this
 
Joined
Jul 26, 2012
Messages
272
Motherboard
Z77X-UP5 TH
CPU
i7-3770
Graphics
GTX 650 TI
Mac
Mac mini
Mobile Phone
iOS
wait a little
for me it took 15 days to get back to my real mac when I had done
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,474
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Hi,

I am having issues with getting my real mac working with iMessage and FaceTime

I followed the procedure on the first page to sign out and delete the MLB and ROM from the cloned Macs.

But after 10 days i am still getting the same errors on the genuine mac. I am on a call with apple as i write this but they seem to be lost too.

Wonder what i should tell them to get the real macbook clear from blacklist.

thanks for any help on this
@ravic,

For most it's a waiting game i know some people who have had to wait a month and others just a few days, i think it must be related to the expiry of the security token(s) ...

You could try forcing iMessages hand by clearing the local account and server files & plists ...

See Chapter 3.3

Not sure if will help but it's what i would try ...

Cheers
Jay
 
Joined
Apr 1, 2013
Messages
125
Motherboard
GA-Z77X-UD5H
CPU
Intel i7 3770K
Graphics
Gigabyte 680 SOC
Mac
iMac
Classic Mac
Mobile Phone
iOS
I tried to fix message using clover configurator. I used a ROM and MLB value from my iMac mid 2011. I rebooted and was prompted to enter Apple-ID password. I could now enter iMesseges. However, when i try to send a message to someone else than my self, it says: message not delivered or XXXX is not registered with imessage.

I've rebooted and am currently stuck. Any thoughts?
 
Joined
Dec 28, 2012
Messages
56
Motherboard
Fractal Node 304
CPU
Intel i7-4770k
Graphics
Gigabyte GTX 770
Mac
Classic Mac
Mobile Phone
I can't believe I got mine fixed too like 15 minutes ago! I've been trying for weeks off and on again to get this working, always checking this Guide to see if there has been an update, trying new techniques as they've been mentioned but still nothing. At one point I almost gave up but my terrible habit of never letting things go got the best of me and I kept trying and trying and finally I just started the whole process over by regenerating my System Definition, smUUID, ROM and MLB and low 'n behold it works!!

I feel such a relief that it works now. I should also note that I have 2FA turned on for my account so it becomes increasingly more annoying having to generate app-specific passwords, but its all worth it in the end for better security.
Yep, I also turned on 2FA before realizing the fix I applied that made it start working again. I already use Google 2FA, LastPass, and LastPass 2FA with an authenticator, and I didn't even know Apple was offering 2FA, so it was a nice surprise for me.
 
Joined
Jan 30, 2012
Messages
22
Mac
Classic Mac
Mobile Phone
Is it normal that even though I'm getting a "contact support" message that my iPhone tells me I've sign into iMessage on another device?
 
Joined
Jul 30, 2011
Messages
127
Motherboard
Asus R510CA (Clover UEFI)
CPU
i5-3337U/HM76
Graphics
Intel HD4000, 1366x768
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Hello Jay,

Thanks for the reply,

I tried your suggestions:
I assume that you are trying to connect via WiFi .... if so ... turn off wireless and connect to your LAN via Ethernet if possible and try again ...
No effect ;-(

Try resetting local account info and server plists ...

Enable 'Show all Files', open finder and navigate to :-

Code:
/StartupDrive/Users/~Username/Library/Preferences
Delete the following files :-

  • com.apple.ids.service.com.apple.madrid.plist
  • com.apple.imessage.bag.plist
Empty trash, reboot and try again.
Managed to delete these and other files (Chapter: 3.3 Reset iMessage Configuration files) by deleting the files, reboot in single user mode, use cmd
Code:
sudo rm -rf ˜/.Trash/
followed with normal boot, and then empty the Trash-bin.

It solved the twice prompt for iCloud password related to [Service Type: com.apple.private.alloy.multiplex1] and [Service Type: com.apple.private.alloy.maps] ;-)

But the iMessage and FaceTime errors are still there:

iMessage:

identityservicesd[462]: [Warning] Registration failed for Registration info (0x............): [Registered: NO] [Type: AppleID] [Device Name: (null)] [Service Type: iMessage] [Env: (null)] [Main ID:

identityservicesd[462]: [Warning] Needs deletion: NO (Registration info (0x............): [Registered: NO] [Type: AppleID] [Device Name: (null)] [Service Type: iMessage] [Env: (null)] [Main ID:

FaceTime:

identityservicesd[462]: [Warning] Registration failed for Registration info (0x............): [Registered: NO] [Type: AppleID] [Device Name: (null)] [Service Type: iMessage] [Env: (null)] [Main ID:

identityservicesd[462]: [Warning] Needs deletion: NO (Registration info (0x7fd9b3752ef0): [Registered: NO] [Type: AppleID] [Device Name: (null)] [Service Type: iMessage] [Env: (null)] [Main ID:

FaceTime[633]: [Warning] Attempting to delete a non iMessage account IMAccount: 0x............ [ID: .............................................. Service: IMService[FaceTime] Login: (null) Active: NO LoginStatus: Offline]
The last one is very strange, because I'm online, and why "Attempting to delete a non iMessage account...."

Other suggestion??

Thank you!
 
Top