Contribute
Register
Joined
Mar 17, 2010
Messages
119
Motherboard
ASUS sabertooth z97 mark 2
CPU
i7 4790k
Graphics
HD 4600
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
For step 4, when you say you took 4 numbers out from the middle to make the 17char MLB 13chars.... Which 4 numbers? What position did you start at to take them out?

Lets pretend this, obviously invalid MLB, is the 17 char MLB: ABCDEFGHIJKLMNOPQ

Which 4 letters did you remove?

thanks

I took 4 numbers from the middle, not letters. In the end l don't think it really matters. When I tried using my Apple ID I got the contact Apple message. Started reading other sites and forums and there's a lot more about S/N and MLB. I think I'm not allow to put those links here, but you can easly find it through Google.
2010 and before models use 11 digit SN and 13 digit MLB. Newer models use 12 digit SN and 17 digit MLB. As SN, MLB has logic to it, like manufactured date, place, part model, etc, etc.
Therefore, using random numbers or deleting random numbers in Clover generated MLB will probably end up failing sooner or later. Actually I found out, that clover generated exactly the same MLB in another hack (obviously this other hack uses a different SN, ROM, etc). So this MLB is probably blacklisted by Apple servers, and probably just works temporarily. And probably is the same MLB a few of us have used (it was a big surprise for me to see the exact same MLB I got a few days ago, when I ran iMessage debug to extract the MLB in this other hack).
There's work being done to make a MLB generator tool. I'm not part of it, but seems it is going to be out soon (just my guess).
Personally I'm trying to generate my own MLB, ROM and SN, with all the info gather in this and other websites.
If that fails I may try to get the 13 MLB working by calling Apple in my Apple ID.
 
Joined
Nov 7, 2012
Messages
61
Motherboard
Z68-MX-UD2H-B3
CPU
i5-2500K
Graphics
RX 580
Mobile Phone
  1. Android
  2. iOS
I have working Messages about a month, now after one of restarts, login to my account then I start Messages and it was log out. I try to log in, but I got Customer Code error.
Data from iMessage_debug are the same before and after restart.

Any progress to fix Messages?
 
Joined
Aug 21, 2011
Messages
7
Motherboard
GA-Z68X-UD3H-B3
CPU
Sandy Bridge i7 2600K
Graphics
GeForce 9500 GT
Mac
Classic Mac
Mobile Phone
Same thing here. Stayed at Mavericks and never upgraded to Yosemite and iMessage has been working since I called Apple a few weeeks ago.

However, two days ago it failed again and I am now shown a dialog with a customer code when I try to login. The utility imessage_debug is showing exactly the same information now as it did when it was working.
 
Joined
Jan 26, 2010
Messages
240
Motherboard
MSI X99A SLI PLUS
CPU
5930K
Graphics
Vega 64
Weird iMessage problem. Works for newly created user. Not for old

Weird one guys....

Changing my password brought up the code. I called Apple, gave them code, just like I have 5 or 6 previous times. This time it didn't work. Got a senior tech that called me. we went through and deleting the prefs and Messages folder; nothing worked.

He had me log out and create a new user. That worked! So it's not Chameleon or a serial issue....

So any ideas to get my older user account & iMessages working again?
 
Joined
Feb 23, 2013
Messages
4
Motherboard
GA-B75M-HD3
CPU
i5 3570K
Graphics
HD 4000/GTX 650
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Weird one guys....

Changing my password brought up the code. I called Apple, gave them code, just like I have 5 or 6 previous times. This time it didn't work. Got a senior tech that called me. we went through and deleting the prefs and Messages folder; nothing worked.

He had me log out and create a new user. That worked! So it's not Chameleon or a serial issue....

So any ideas to get my older user account & iMessages working again?

hi herb, what you mean new user? you mean the senior tech told you to create a new apple id? i'm just confused. thank you.
 
Joined
Feb 23, 2013
Messages
4
Motherboard
GA-B75M-HD3
CPU
i5 3570K
Graphics
HD 4000/GTX 650
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
He means he created a new user on the computer, not Apple ID.

thank you for the clarification rockinwaggy. did you try this method also? i'll try this when i got home. been trying to solve my imessage since last night i was forced logout without noticing how did it happen.
 
Joined
Dec 10, 2012
Messages
30
Motherboard
Custom G5
CPU
Intel i7 2600
Graphics
Sapphire HD7870 GHz Edition
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Weird one guys....

Changing my password brought up the code. I called Apple, gave them code, just like I have 5 or 6 previous times. This time it didn't work. Got a senior tech that called me. we went through and deleting the prefs and Messages folder; nothing worked.

He had me log out and create a new user. That worked! So it's not Chameleon or a serial issue....

So any ideas to get my older user account & iMessages working again?

I can confirm that this worked for me too. 100%.
No other changes were made at all. Didn't change Apple ID passwords, or sign out of devices ect.

Running Clover v2k r2976. All the proper values & injections ect. Had previously been working fine for months.

Turned on my Hackintosh to discover I was booted from iMessage, for no apparent reason. Couldn't sign back in, getting the Call Customer Support error. I can't call them at the moment, the line is closed this time of night.

But creating a new OS X User & signing in with the exact same iMessage account info worked straight away.
Seriously considering just migrating everything over to this User, or creating a new one.
Does anyone know of a simple or integrated way in OS X to do this? Besides backing everything up then using Migration Assistant.
 
Joined
Jan 26, 2010
Messages
240
Motherboard
MSI X99A SLI PLUS
CPU
5930K
Graphics
Vega 64
dj-ek,

Glad it worked for you too!

I have the very same question. What's the best way to migrate from one user to another?
 
Joined
Dec 17, 2012
Messages
171
Motherboard
GA-Z87-HD3
CPU
i5-4670
Graphics
Intel 4600
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Screen Shot 2014-12-08 at 9.36.34 AM.png

I wonder if it has to do with the "com.apple.idms.appleid.prd.xxxxxxxxxxxxxxx." (Xs blocked with Red). Maybe someone can logout of all apple services, including iTunes and App Store, and remove that. Also remove any other ids, like Apple ID from the User, Reboot, then relogin.

EDIT: My hack doesn't have the Aliases or Apple ID lines. I created the new UUID and tried it. Didn't work.
 
Top