How to extend the iMac Pro to X99 [Successful Build/Extended Guide]

Discussion in 'High Sierra Desktop Guides' started by kgp, Jul 12, 2017.

  1. mimixa

    mimixa

    Joined:
    Nov 28, 2010
    Messages:
    27
    Motherboard:
    Asus x99-e ws/usb3.1
    CPU:
    E5-2696 v3
    Graphics:
    GTX 780 Ti
    Oct 8, 2017 at 7:19 AM #631
    mimixa

    mimixa

    Joined:
    Nov 28, 2010
    Messages:
    27
    Motherboard:
    Asus x99-e ws/usb3.1
    CPU:
    E5-2696 v3
    Graphics:
    GTX 780 Ti
    Bios 3601 new.
     
    kgp and dj_adam21 like this.

    Attached Files:

    • 171008060731.jpg  (158.3 KB, 79 views)
    • 171008060749.jpg  (119.2 KB, 85 views)
    • 171008060802.jpg  (136 KB, 94 views)
    • 171008060821.jpg  (129.1 KB, 100 views)
    • 171008060849.jpg  (122 KB, 98 views)
    • 171008060910.jpg  (113.9 KB, 99 views)
    • 171008060928.jpg  (117.7 KB, 97 views)
    • Снимок экрана 2017-10-08 в 8.49.02.png  (1.2 MB, 92 views)
    • Снимок экрана 2017-10-08 в 8.54.46.png  (378.3 KB, 86 views)
  2. dj_adam21

    dj_adam21

    Joined:
    Jul 23, 2012
    Messages:
    171
    Motherboard:
    ASUS X99 AII
    CPU:
    Intel XEON E5-2696 v3
    Graphics:
    AMD RX 560
    Mobile Phone:
    iOS
    Oct 8, 2017 at 8:12 AM #632
    dj_adam21

    dj_adam21

    Joined:
    Jul 23, 2012
    Messages:
    171
    Motherboard:
    ASUS X99 AII
    CPU:
    Intel XEON E5-2696 v3
    Graphics:
    AMD RX 560
    Mobile Phone:
    iOS
    Thanks for the pictures , tried with those settings, even used your ssdt for cpu same results ...I can't crack it for some reason :(
     
  3. michaeljeger

    michaeljeger

    Joined:
    Jul 24, 2011
    Messages:
    24
    Motherboard:
    Mac Pro
    CPU:
    Intel i7
    Graphics:
    GT9600
    Oct 8, 2017 at 9:53 AM #633
    michaeljeger

    michaeljeger

    Joined:
    Jul 24, 2011
    Messages:
    24
    Motherboard:
    Mac Pro
    CPU:
    Intel i7
    Graphics:
    GT9600
    Hi
    I used the guide very successfully, really a great help.
    Now however, using the Migration Assistant to get my data from 10.12.6 to 10.13, System will not boot after migration anymore.
    Anyone with experience what could be the cause?
    Are the old NVIDIA drivers from 10.12.6 also migrated and that could cause the trouble?

    What happens when I reboot is that the system instantly reboots just before entering desktop.

    MB: Asus X99 Deluxe II (bios 1401 unlocked) CPU: Intel i7 6900k GPU: Gigabyte GeForce GTX 980 Ti, G1 Gaming, 6Gb SSD: Samsung 960 Evo 256 Gb RAM: G.SKILL TRIDENTZ 32GB 2X16GB KIT-3200 Case: Fractal Design Define R5 PCGH Edition (all Noctua Fans) PSU: Be Quiet DARK POWER PRO 11 650W

    Thanks, Mike
     
  4. kgp

    kgp

    Joined:
    May 30, 2014
    Messages:
    4,475
    Motherboard:
    Asus Prime X299 Deluxe, Asus X99-A II
    CPU:
    Intel i9-7980XE, Intel I7-6950X
    Graphics:
    AORUS GTX 1080 TI-X WB, AORUS GTX 1080 TI-X
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Oct 8, 2017 at 9:57 AM #634
    kgp

    kgp

    Joined:
    May 30, 2014
    Messages:
    4,475
    Motherboard:
    Asus Prime X299 Deluxe, Asus X99-A II
    CPU:
    Intel i9-7980XE, Intel I7-6950X
    Graphics:
    AORUS GTX 1080 TI-X WB, AORUS GTX 1080 TI-X
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Why don't you just clone your 10.12.6 System Disk by means of Carbon Copy Cloner (CCC), and directly perform the 10.13 macOS High Sierra Update on the latter clone drive? No need for migration in this case! The only thing you have to consider for the latter approach is to copy the working 10.13 EFI-Folder in the empty EFI-partition of your 10.13 clone drive immediately before performing the macOS High Sierra 10.13 Upgrade!
     
    Last edited: Oct 8, 2017
  5. michaeljeger

    michaeljeger

    Joined:
    Jul 24, 2011
    Messages:
    24
    Motherboard:
    Mac Pro
    CPU:
    Intel i7
    Graphics:
    GT9600
    Oct 8, 2017 at 10:20 AM #635
    michaeljeger

    michaeljeger

    Joined:
    Jul 24, 2011
    Messages:
    24
    Motherboard:
    Mac Pro
    CPU:
    Intel i7
    Graphics:
    GT9600
    That is probably a good option now that I have my Efi-Folder cleaned up.
    The reason I went for a clean install was to have a more stable system. I did not really expect any challenges with the Migration Assistant.
    But you are right if no other users have any feedback regarding the migration assistant, I will do exactly what you proposed.
    Thanks, Mike
     
  6. michaeljeger

    michaeljeger

    Joined:
    Jul 24, 2011
    Messages:
    24
    Motherboard:
    Mac Pro
    CPU:
    Intel i7
    Graphics:
    GT9600
    Oct 8, 2017 at 10:23 AM #636
    michaeljeger

    michaeljeger

    Joined:
    Jul 24, 2011
    Messages:
    24
    Motherboard:
    Mac Pro
    CPU:
    Intel i7
    Graphics:
    GT9600
    One question regarding you Geekbench results.... I assume those were done with Brummbärs Pmdrv.kext?
    I only really get good performance using that kext for the Geekbench for multicore results especially.
    But the drawback is that it breaks sleep.... so the choice seems....either good performing system or sleep.
    Thanks Mike
     
  7. kgp

    kgp

    Joined:
    May 30, 2014
    Messages:
    4,475
    Motherboard:
    Asus Prime X299 Deluxe, Asus X99-A II
    CPU:
    Intel i9-7980XE, Intel I7-6950X
    Graphics:
    AORUS GTX 1080 TI-X WB, AORUS GTX 1080 TI-X
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Oct 8, 2017 at 10:43 AM #637
    kgp

    kgp

    Joined:
    May 30, 2014
    Messages:
    4,475
    Motherboard:
    Asus Prime X299 Deluxe, Asus X99-A II
    CPU:
    Intel i9-7980XE, Intel I7-6950X
    Graphics:
    AORUS GTX 1080 TI-X WB, AORUS GTX 1080 TI-X
    Mac:
    iMac, MacBook Pro, Mac mini
    Mobile Phone:
    iOS
    Yes with PMDrvr.kext and EIST enabled in BIOS!
     
    nmano likes this.
  8. mikjess

    mikjess

    Joined:
    Sep 30, 2017
    Messages:
    9
    Motherboard:
    MSI X99A SLI Krait Edition
    CPU:
    Intel i7-5820K
    Graphics:
    GIGABYTE GeForce GTX 980Ti 6GB WINDFORCE 3X OC EDITION
    Oct 8, 2017 at 10:55 AM #638
    mikjess

    mikjess

    Joined:
    Sep 30, 2017
    Messages:
    9
    Motherboard:
    MSI X99A SLI Krait Edition
    CPU:
    Intel i7-5820K
    Graphics:
    GIGABYTE GeForce GTX 980Ti 6GB WINDFORCE 3X OC EDITION
    Apologies for all the posts, I have tried this so many times and I would love to make some progress...

    Recap I have:
    MSI X99A SLI Krait
    i7-5820K
    Gigabyte GTX 980 Ti
    Samsung 850 500GB SSD

    I have this now (Step D.1 / 13.) :

    IMAG2047.jpg

    Then...
    IMAG2045.jpg

    Then if I let it go some more it turns into this:
    IMAG2046.jpg
     
  9. nmano

    nmano

    Joined:
    Oct 12, 2010
    Messages:
    495
    Motherboard:
    X99Gaming G1 Wifi/X58A UD7
    CPU:
    5960X
    Graphics:
    GTX970/ATI4870
    Mac:
    Mac Pro
    Oct 8, 2017 at 11:58 AM #639
    nmano

    nmano

    Joined:
    Oct 12, 2010
    Messages:
    495
    Motherboard:
    X99Gaming G1 Wifi/X58A UD7
    CPU:
    5960X
    Graphics:
    GTX970/ATI4870
    Mac:
    Mac Pro
    Thanks KGP
    NVMe SSD 960 PRO I tested.
     
    kgp likes this.

    Attached Files:

    • Screen Shot 2017-10-08 at 6.53.50 AM.png  (173.5 KB, 48 views)
    • Screen Shot 2017-10-08 at 6.54.46 AM.png  (113.7 KB, 50 views)
  10. mimixa

    mimixa

    Joined:
    Nov 28, 2010
    Messages:
    27
    Motherboard:
    Asus x99-e ws/usb3.1
    CPU:
    E5-2696 v3
    Graphics:
    GTX 780 Ti
    Oct 8, 2017 at 1:11 PM #640
    mimixa

    mimixa

    Joined:
    Nov 28, 2010
    Messages:
    27
    Motherboard:
    Asus x99-e ws/usb3.1
    CPU:
    E5-2696 v3
    Graphics:
    GTX 780 Ti

    Attached Files:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice