Contribute
Register

How to extend the iMac Pro to X99 [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Jun 4, 2018
Messages
62
Motherboard
Asus Z390-I
CPU
I7-8700K
Graphics
Vega 56
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android, iOS
@kgp yes, my setup from my prior post(with my efi, ioreg, etc) is what I am still using outside of the new performance patch and the updated lilu, whatevergreen & applealc.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,786
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
@kgp yes, my setup from my prior post(with my efi, ioreg, etc) is what I am still using outside of the new performance patch and the updated lilu, whatevergreen & applealc.
You did not answer my question.. Did you also enable the 2 SMT patches and the pkg_scope patch?
 
Joined
Jun 4, 2018
Messages
62
Motherboard
Asus Z390-I
CPU
I7-8700K
Graphics
Vega 56
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android, iOS
You did not answer my question.. Did you also enable the 2 SMT patches and the pkg_scope patch?
Yes those 2 was already enabled as well as the pkg_scope patch per my prior efi posting.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,786
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Yes those 2 was already enabled as well as the pkg_scope patch per my prior efi posting.
Then it must work!

Good luck ;)
 

kgp

Retired
Joined
May 30, 2014
Messages
6,786
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
https://browser.geekbench.com/v4/cpu/10564005

Attached is my efi and ioreg

I know Asrock has not updated the bios in 6 months since last microcode updated:
https://www.asrock.com/mb/Intel/Fatal1ty X99M Killer3.1/index.us.asp#BIOS
You want my help even before any X99 guide has been updated?

I am currently updating 4 guides, man! I really have not time for your issues right now.

I also cannot update the microcodes of your BIOS firmware for you. My guide implements a detailed guideline how to update the microcodes in ASUS BIOS firmware. If this does not work for your ASRock motherboard firmware, it is out of my hands.

Anyway, OC was working for you under 10.13.6, thus I absolutely see no reason why it should not work under 10.13.6 SU too!

Please get your things set by yourself. I am really busy with the guide updates now, which are also important for other users.

Thanks for your comprehension,

KGP
 
Joined
Jun 4, 2018
Messages
62
Motherboard
Asus Z390-I
CPU
I7-8700K
Graphics
Vega 56
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android, iOS
Well, I was able to update the microcode to my Asrock bios! =) Almost have the performance of what I had before the SU with prior performance patch, the new one you provided still terrible. But I think I might be making some progress.

Been thinking that microcode was part my issue with the latest apple update. Seems that is partially true.

Just an update as I keep plugging away. BTW, when you get time, revert to your prior performance patch and run geekbench and let me know if your score is similar to the one you posted here #2572.

Oh and never think I expect you to drop everything, it is always a "when you get a moment of time IF you would".

Anywho...Cheers!
 

kgp

Retired
Joined
May 30, 2014
Messages
6,786
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Well, I was able to update the microcode to my Asrock bios! =) Almost have the performance of what I had before the SU with prior performance patch, the new one you provided still terrible. But I think I might be making some progress.

Been thinking that microcode was part my issue with the latest apple update. Seems that is partially true.

Just an update as I keep plugging away. BTW, when you get time, revert to your prior performance patch and run geekbench and let me know if your score is similar to the one you posted here #2572.

Oh and never think I expect you to drop everything, it is always a "when you get a moment of time IF you would".

Anywho...Cheers!
Don't worry... ;)

The performance patch for 10.14.0 does not work with 10.14.1! No reason to do the testing you propose above. I already know the result, which would be just terrible..
 
Joined
Jun 4, 2018
Messages
62
Motherboard
Asus Z390-I
CPU
I7-8700K
Graphics
Vega 56
Mac
MacBook Pro, Mac mini, Mac Pro
Mobile Phone
Android, iOS
Don't worry... ;)

The performance patch for 10.14.0 does not work with 10.14.1! No reason to do the testing you propose above. I already know the result, which would be just terrible..
Ok I seen you put the new Performance patch in the guide. I just took a look at it. I know why what you posted was causing me issues. the last 909090 was missing in the replace!!!!

Code:
In your post:
Find:      C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF0579C8 6B004883 C4085B5D C3662E0F 1F840000 000000
Replace: B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 79C86B00 4883C408 5B5DC390 90909090 909090

In your guide:
Find:    C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF0579C8 6B004883 C4085B5D C3662E0F 1F840000 000000
Replace: B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 79C86B00 4883C408 5B5DC390 90909090 909090 909090
 

kgp

Retired
Joined
May 30, 2014
Messages
6,786
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Ok I seen you put the new Performance patch in the guide. I just took a look at it. I know why what you posted was causing me issues. the last 909090 was missing in the replace!!!!

Code:
In your post:
Find:      C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF0579C8 6B004883 C4085B5D C3662E0F 1F840000 000000
Replace: B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 79C86B00 4883C408 5B5DC390 90909090 909090

In your guide:
Find:    C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF0579C8 6B004883 C4085B5D C3662E0F 1F840000 000000
Replace: B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 79C86B00 4883C408 5B5DC390 90909090 909090 909090
Wrong!

The patch I provided you originally in the post was correct. There was a typo in the patch implemented in the guide, which I now corrected.

Find and Replace values MUST have SAME amount of digits! Logics, isn't it?

Thus the correct patch is:

C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF0579C8 6B004883 C4085B5D C3662E0F 1F840000 000000
B800FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 79C86B00 4883C408 5B5DC390 90909090 909090

And don't tell me that I cause you issues. At first place I try to help. And at second place there is a new EFI-Folder on Github where the patch is directly implemented in the config.plist!
 
Status
Not open for further replies.
Top