Contribute
Register

How to extend the iMac Pro to X99 [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Jun 28, 2016
Messages
17
Motherboard
ASUS Rampage V Extreme
CPU
5960X
Graphics
SLI Titan X
Maybe you need to inject an audio ID different from 1? This mainly depends on your onboard sound chip.
Ok got audio working. Here's what I did. I have a Asus Rampage V Extreme so my Audio Codec is ALC1150. I installed the ALC1150.kext Codec using Multibeast. I downloaded toleda's patched X99 SSDT-HDEF-ALZA-1.aml from his Github and put it in the /EFI/Clover/ACPI/patched folder as well as enabling the ACPI replacement ALZA -> HDEF in the config.plist. I then ran toleda's audio_cloverALC-130_v0.5.command script to patch the ALC1150 kext. Rebooted and audio's working!

New question: It seems my sleep/wake is broken because after I tried to wake from sleep, I got post-code 30 and no display out -- black screen and completely unresponsive. I have the SSDT.aml generated using Piker-Alpha's ssdtprgen.sh script in my /EFI/Clover/ACPI/patched folder. Any suggestions?
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Ok got audio working. Here's what I did. I have a Asus Rampage V Extreme so my Audio Codec is ALC1150. I installed the ALC1150.kext Codec using Multibeast. I downloaded toleda's patched X99 SSDT-HDEF-ALZA-1.aml from his Github and put it in the /EFI/Clover/ACPI/patched folder as well as enabling the ACPI replacement ALZA -> HDEF in the config.plist. I then ran toleda's audio_cloverALC-130_v0.5.command script to patch the ALC1150 kext. Rebooted and audio's working!

New question: It seems my sleep/wake is broken because after I tried to wake from sleep, I got post-code 30 and no display out -- black screen and completely unresponsive. I have the SSDT.aml generated using Piker-Alpha's ssdtprgen.sh script in my /EFI/Clover/ACPI/patched folder. Any suggestions?

Which connection there is between sleep/wake and Piker-Alpha's SSDT.aml? Did you implement/adopt the ACPI patches and SSDT-X99.aml distributed in the originating post of this thread?
 
Joined
Jun 28, 2016
Messages
17
Motherboard
ASUS Rampage V Extreme
CPU
5960X
Graphics
SLI Titan X
Which connection there is between sleep/wake and Piker-Alpha's SSDT.aml? Did you implement/adopt the ACPI patches and SSDT-X99.aml distributed in the originating post of this thread?
Oh, I'm dumb, sorry I mistakenly thought the power management and sleep/wake were connected. I hadn't done those steps yet, sorry, I'm going to implement them now. Thanks for your help btw.
 
Joined
Feb 8, 2017
Messages
26
Motherboard
Asus X99 A-II
CPU
6800K
Graphics
Nvidia geforce gtx 1060
Hi, I want to go through the CPU power management section but I am confused could you please help me with my hardware which settings I must choose specifically. Thank you
 
Joined
Sep 6, 2017
Messages
3
Motherboard
Asus x99
CPU
intel i-7 6850k
Graphics
GTX 1080
Mac
  1. MacBook Pro

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Joined
Mar 16, 2017
Messages
34
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
No need for video helper card with Lilu and whatevergreen worked oob with @kgp guide.

I tried to delete lilu and whatevergreen kexts from S / L / E in the system disk and in Clover Kexts / Other but the result is the same plus now I no longer have the sound card. Could it be a problem with bios settings? My Asrock x99 Taichi has MSR 0xE2 locked and if possible can it be unlocked? My CPU benchmarks in geekbench are low, in multicore I'm just 16000 and I have Sync All Cores active. How did you set the FrequencyVectors for the 6800k?
Thank you.
 
Joined
Feb 8, 2017
Messages
26
Motherboard
Asus X99 A-II
CPU
6800K
Graphics
Nvidia geforce gtx 1060
Hi, I want to go through the CPU power management section but I am confused could you please help me with my hardware which settings I must choose specifically. Thank you
No one :(
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS

Not the best moment to ask that question. You know about the Broadwell-E OC issue since 10.13.4?

If you want to have proper XCPM power management, stay with 10.13.3 and follow all steps outlined in the guide.

Good luck,

KGP
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
I tried to delete lilu and whatevergreen kexts from S / L / E in the system disk and in Clover Kexts / Other but the result is the same plus now I no longer have the sound card. Could it be a problem with bios settings? My Asrock x99 Taichi has MSR 0xE2 locked and if possible can it be unlocked? My CPU benchmarks in geekbench are low, in multicore I'm just 16000 and I have Sync All Cores active. How did you set the FrequencyVectors for the 6800k?
Thank you.

See post #1657.
 
Status
Not open for further replies.
Top