Contribute
Register

How to extend the iMac Pro to X99 [Successful Build/Extended Guide]

Status
Not open for further replies.

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Sure. BIOS configuration is as detailed in the guide through step E.7. Attached is my EFI.zip. Not sure what's causing the freezes/crashes, so instructions on what I should do to gather bug/crash logs would be appreciated. Absolutely no audio devices, no HDMI audio, no USB audio, nothing. Any advice?

5960X
2x Titan X (Maxwell)
Rampage V Extreme
64GB RAM

EDIT: When I opened Clover Configurator right after logging in, it flashed white indicating I had a notification, but it froze the whole screen. Hard reset didn't help, and when I logged back in macOS reopened the frozen windows and kept them frozen. Had to reboot several times to get it back to normal. Don't know if this is a coincidence since the freezes have happened even when I hadn't opened Clover Configurator. Just thought this might provide a bit more info.

EDIT 2: Now all my stuff is crashing/freezing on login, but if I login as guest everything works fine. It keeps loading the same windows and is crashing before it lets me close them. Screen flashes black very briefly on login. Clearing the nvram also fixes the problem, but the problem comes back.

EDIT 3: Uninstalling and Reinstalling the Nvidia Web Drivers seems to have fixed the login problems (unsure yet if it fixed the white-flash freeze/crash thing). However audio remains broken.

Your EFI-Folder would benefit from a clover update.

Disable nvda_drv=1 bootflag in the config.plist (obsolete)
 
Joined
Mar 16, 2017
Messages
34
Motherboard
Gigabyte Z390 Designare
CPU
i7-9700K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Hey, thanks for the guide once again. I've Updated my X99 10.12.6 to 10.13.4. One problem, and it’s a big one, I cannot access my Windows SSD anymore. I can’t open it’s EFI any which way I try. It doesn’t show up in my BIOS (delete or F12). No way to access via Clover screen. Some how, during update, it’s erased or hidden the Windows’s EFI.

Anyway to fix this with out reinstalling???

Hi, unfortunately a similar thing happened to me once I installed High Sierra on NVME. I can no longer see an SSD with Sierra from the boot option in bios. We have similar hardware and I have a question to ask you. With the playback of all the clips I have continuous video freeze as well as not being able to export h264 to FCPX, depends on the CPU or GPU? I use only one GPU as primary (RX 480, lilu, whatevergreen). I followed this excellent guide without having problems of installation up to power management. Do I still need a video card helper or can I fix this issue without it?
Thank you.
 
Joined
Nov 21, 2015
Messages
204
Motherboard
Gigabyte GA-X99P-SLI MB
CPU
i7 6800K
Graphics
RX480
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Hi, unfortunately a similar thing happened to me once I installed High Sierra on NVME. I can no longer see an SSD with Sierra from the boot option in bios. We have similar hardware and I have a question to ask you. With the playback of all the clips I have continuous video freeze as well as not being able to export h264 to FCPX, depends on the CPU or GPU? I use only one GPU as primary (RX 480, lilu, whatevergreen). I followed this excellent guide without having problems of installation up to power management. Do I still need a video card helper or can I fix this issue without it?
Thank you.
No need for video helper card with Lilu and whatevergreen worked oob with @kgp guide.
 
Joined
Jun 28, 2016
Messages
17
Motherboard
ASUS Rampage V Extreme
CPU
5960X
Graphics
SLI Titan X
What about enabling ACPI replacement ALZA -> HDEF in your config.plist?
Ok enabled, no change whatsoever. I have a ASUS Rampage V Extreme Mobo. Should I be using Reltek ALC1150 or VoodooHDA kexts?
 
Last edited:

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Ok enabled, no change whatsoever. I have a ASUS Rampage V Extreme Mobo. Any Reltek ALC or VoodooHDA kexts I should be using?

Maybe you need to inject an audio ID different from 1? This mainly depends on your onboard sound chip.
 
Joined
Feb 8, 2017
Messages
26
Motherboard
Asus X99 A-II
CPU
6800K
Graphics
Nvidia geforce gtx 1060
Hello, I have gone through this guide until the CPU power management section and my problem is I have a CPU water cooling system and another fan which sucks the air into the case and the CPU cooling pushes the air out of my case. my CPU fan is working but my other fan when I boot the system suddenly stops. could anyone help me with this problem?

Oh by the way before that I had a Sierra version of mac and I did not have this problem

I never get to thank you KPG. thank you for your great great post.
 
Last edited:
Joined
Sep 6, 2017
Messages
3
Motherboard
Asus x99
CPU
intel i-7 6850k
Graphics
GTX 1080
Mac
  1. MacBook Pro
I followed the guide and I'm still stuck at "+++++++++++++++". Anyway to get rid of this? I tryed to read as mush as possible but didnt fint the solution yet. (7 months ago i did it, but now idk, i fell realy stupid).

Ty for your help

____________
i7-6850X (6-core), ASUS STRIX X99 GAMING, ASUS GTX 1080 8GB, Corsair Vengeance 64GB
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
I followed the guide and I'm still stuck at "+++++++++++++++". Anyway to get rid of this? I tryed to read as mush as possible but didnt fint the solution yet. (7 months ago i did it, but now idk, i fell realy stupid).

Ty for your help

____________
i7-6850X (6-core), ASUS STRIX X99 GAMING, ASUS GTX 1080 8GB, Corsair Vengeance 64GB

Do you use TSCAdjustReset.kext or VoodooTSCSync.kext?
 
Status
Not open for further replies.
Top