Contribute
Register

How to extend the iMac Pro to X99 [Successful Build/Extended Guide]

Status
Not open for further replies.

kgp

Retired
Joined
May 30, 2014
Messages
6,771
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Do you have any points that I need to aware to build up the USB boot drive? The error is come from the 1st boot up from my USB boot drive

Anything important is mentioned in my guide..
 
Joined
Jun 18, 2011
Messages
378
Motherboard
Rog Strix z490 E gaming
CPU
i9 10900k
Graphics
5700xt
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@kgp maybe you can help me with my troubles... I follow your guide with my system (msi x99a sli plus krait edition and 6900k) but I can't get 10.13... I could install 10.12.6. I only can boot the installer with Kernel CPU activated in Clover, but when I install 10.13.2 (fresh install) in my HDD, when it reboots to continue installation, I get few errors. I opened a thread about it with all info, screenshots, folders, and so on. Maybe you can help me :( I think there is something wrong with my broadwell-e patches.
https://www.tonymacx86.com/threads/...i-x99-sli-plus-k-e-6900k.242304/#post-1664420
 
Joined
Jun 29, 2016
Messages
17
Motherboard
ASUS Rampage V Extreme
CPU
5960X
Graphics
SLI Titan X
Hey KGP, currently I have El Capitan booting of an External WD HDD, and I'm trying to fresh install High Sierra on a Samsung T3 external SSD. I followed the guide in the OP, but I can't seem to boot into the High Sierra installer. I took a screenshot (attached) of my Verbose boot right before it crashed and my computer restarted. Thanks in advance for your help!

System Specs:

--5960X
--ASUS Rampage V Extreme
--Nvidia GT710
--64GB Ram
 

Attachments

  • Boot Crash.jpg
    Boot Crash.jpg
    4.5 MB · Views: 103
Joined
Feb 14, 2013
Messages
117
Motherboard
Asus ROG Strix x99 Gaming
CPU
E5-2696v3
Graphics
RX 480
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hey KGP, currently I have El Capitan booting of an External WD HDD, and I'm trying to fresh install High Sierra on a Samsung T3 external SSD. I followed the guide in the OP, but I can't seem to boot into the High Sierra installer. I took a screenshot (attached) of my Verbose boot right before it crashed and my computer restarted. Thanks in advance for your help!

System Specs:

--5960X
--ASUS Rampage V Extreme
--Nvidia GT710
--64GB Ram
Wat are your bootflags? This seems like a graphic error.
Always with nVidia boot with nv_disable=1 and uncheck nVidia Webdrivers.

After installation of the webdriver you can set it to nvda_drv=1 and webdrivers checked.
 
Joined
Feb 14, 2013
Messages
117
Motherboard
Asus ROG Strix x99 Gaming
CPU
E5-2696v3
Graphics
RX 480
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
@kgp, I am trying to make Hardware-acceleration work here according here
https://github.com/vit9696/Shiki
Has anyone success in making hardware-acceleration work with Haswell-E CPU with Maxwell card ?
I don't know but on my secondary system i have a GTX970 and it is working with acceleration with nVidia Webdrivers so i don't know your problem... Be sure you installed Lilu.kext (latest version) this seems to be for iGPU
 
Joined
Jun 13, 2017
Messages
86
Motherboard
Asus X99-Pro
CPU
Intel i7-5820K
Graphics
Zotac GTX 970
Mac
  1. Mac Pro
Some clarification has to be made-What I mean by Hardware Acceleration is Video Decoder Acceleration. Tell me your specs on which VDA is working for you.
 
Joined
Jan 8, 2018
Messages
1
CPU
i7-6850K
Graphics
RX 580
ASUS x99a usb3.1 rx580 installation success
But it is impossible to identify nvme sm961
Unable to boot from WD 3TB
Black screen
 
Joined
Nov 27, 2010
Messages
96
Motherboard
ASUS X99-A II
CPU
E5 2690v3
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Your error messages do not say anything to me.. don't know what you are doing to obtain to such results..

Just find out that need to disable these 2 entries, and I can upgrade to 10.13.2 from 10.12.6 without problem... imessage/Facetime/Apple Watch unlock/USB, all are working. @kgp thanks for your guide

upload_2018-1-9_1-7-22.png


Now, 10.13.2 cannot see my Plextor M8Pe 512G M2, any suggestion how to configure it?
 
Joined
Jun 29, 2016
Messages
17
Motherboard
ASUS Rampage V Extreme
CPU
5960X
Graphics
SLI Titan X
Good catch! You're right, for some reason I forgot the nv_disable=1 argument on that boot; that was rather stupid on my part. However, I'm still unable to boot into the High Sierra installer. I'm attaching screenshots in the order that they occurred (left to right) (sorry for the blurry pics, text was scrolling fast lol). My computer gets stuck on the third screenshot and can't seem to break through, even after leaving it running for around 30 minutes. Thanks for your help!
 

Attachments

  • Boot (1).jpg
    Boot (1).jpg
    5.6 MB · Views: 204
  • Boot (2).jpg
    Boot (2).jpg
    3.1 MB · Views: 176
  • Boot (3).jpg
    Boot (3).jpg
    3.8 MB · Views: 183
Last edited:
Status
Not open for further replies.
Top