Contribute
Register

How to enable 'Kaby Lake' Intel 6xx Graphics (10.12.6+)

Status
Not open for further replies.
Joined
Jul 12, 2017
Messages
15
Motherboard
GA-B150M-D3H
CPU
i3-7100 Kaby Lake
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
After 10.12.6 update, in clover configurator
* SMBIOS changed to iMac18,2
* KERNEL AND KEXT PATCHES removed FakeCPUID
* DEVICES - Removed “Add Properties” for IntelGFX (GfxYTile)
* GRAPHICS - “ig-platform-id” changed to 0x59120000
* DEVICES - “Fake ID” for IntelGFX changed to 0x59128086
* BOOT - Add “-disablegfxfirmware” under Custom Flags
 

Attachments

  • Screen Shot 2017-07-20 at 20.38.46.png
    Screen Shot 2017-07-20 at 20.38.46.png
    99.2 KB · Views: 1,698
Joined
Oct 1, 2010
Messages
66
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm running 10.12.6 and my HD 630 is recognized without any kexts or Clover changes. It is not in use, however. I have seen in some forums questions about discrete graphics. Is this possible with HD630 and an nvidia card? (I assume I have to use the 630 as main)
 
Joined
Sep 26, 2015
Messages
126
Motherboard
Gigabyte H270N WiFi
CPU
i5-7500
Graphics
Quadro K1200
Mac
  1. MacBook Pro
@vinste I apologize for not understanding the graph.
Is Intel power gadget screen captured at the time you were running any video transcoding software?

Sleep does not work better. It still needs the iGPU as primary to wake
I thought the HD630/530 sleep/wake problem is that, on its own, the system would KP on wake which leads to a reboot after timeout. You meant dGPU right?
 
Joined
Oct 28, 2015
Messages
41
Motherboard
Asus Prime Z270-A
CPU
Intel i7-7700K
Graphics
Sapphire Nitro+ Radeon RX 580
Here is my config.plist. Im using Lilu.kext, IntelGraphicsFixup.kext and Shiki.kext(for QuickSync support->boot flag -shikigva).
Thanks a lot! I tried injecting the ig-platform-id along with the a few of your ACPI patches.. still graphics acceleration is not working.! I don’t have access to the config.plist now so couldn’t attach it here.

Btw, I am using high sierra public beta, not sure if posting to this thread is acceptable may be I will post in high sierra discussion forum
 
Joined
Jun 29, 2017
Messages
45
Motherboard
Gigabyte 170x SOC Force
CPU
i7-7700k
Graphics
Sapphire RX Vega 64 8GB
Mac
  1. Mac mini
  2. Mac Pro
@vinste I apologize for not understanding the graph.
Is Intel power gadget screen captured at the time you were running any video transcoding software?
Yes, in details, it shows GPU is active (green curve, GT=0.5GHz) while Final Cut Pro X 10.2.3 exports in h264 4K (faster than real time by the way).
Final Cut Pro X 10.3 or iMovie 10.1.6 still do not work :(

I thought the HD630/530 sleep/wake problem is that, on its own, the system would KP on wake which leads to a reboot after timeout. You meant dGPU right?
My config is: 2 monitors connected to dGPU (7950) and darwake=8.
With this config, the issue is the same as in 10.12.5: to be awaken, the 7950 needs the iGPU to be set as primary in Bios, otherwise I get a black screen on wake.
I did not face any KP on wake, neither in 10.12.5 nor in 10.12.6
 
Joined
Apr 5, 2017
Messages
3
Motherboard
Asus Z170 Pro Gaming
CPU
i7-7700
Graphics
HD 630 + RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
If you run Geekbench or OpenGL Extension Viewer does these tools detect your GPU as KBL?

I am not sure is it correct but Geekbench detects my Compute device as KBL graphics. But processor ID is written as "GenuineIntel Family 6 Model 158 Stepping 9".
 
Joined
Jun 28, 2011
Messages
35
Motherboard
I didn't read
CPU
the RULES
Graphics
so ignore me
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
After 10.12.6 update, in clover configurator
* SMBIOS changed to iMac18,2
* KERNEL AND KEXT PATCHES removed FakeCPUID
* DEVICES - Removed “Add Properties” for IntelGFX (GfxYTile)
* GRAPHICS - “ig-platform-id” changed to 0x59120000
* DEVICES - “Fake ID” for IntelGFX changed to 0x59128086
* BOOT - Add “-disablegfxfirmware” under Custom Flags

If you run Geekbench or OpenGL Extension Viewer does these tools detect your GPU as KBL?
 
Joined
Jul 16, 2010
Messages
6
Motherboard
Mac OSX 10.12.6
CPU
Intel i7-7700K
Graphics
NVIDIA GeForce GTX 750 Ti
Mac
  1. iMac
Mobile Phone
  1. iOS
  2. Other
Hello,

been struggling for quite long time, as I'm not able to get rid of the glitches that are appearing in the upper left corner of the menu bar and in Safari (glitch screenshot attached), which start appearing after enabling the Intel HD630 driver, I'm already using Lilu.kext and IntelGraphicsFixup.kext.

attached is my config.plist file, if anyone can help in fixing this issue.

Regards
 

Attachments

  • config.plist
    6.1 KB · Views: 377
  • Glitch_screenshot.png
    Glitch_screenshot.png
    19.1 KB · Views: 447
Status
Not open for further replies.
Top