Contribute
Register

How to Create a macOS High Sierra Public Beta Installation USB

Joined
Sep 29, 2017
Messages
1
Great guide in the most parts. For me only USB 2.0 thumb drive worked.
I have 2 questions.
1. NVIDIA drivers cannot be installed as I read from others but is there any way to prevent the OS from those hickups and weird renderings? I'm on a GTX980. Do AMD VGAs work? I can try an HD7970 if somebody can confirm the compatibility.
2. I think I do something wrong. Everytime I boot the SSD after the installation it appears nothing in the SSD. I have to boot from the installation USB stick and select the partition that I installed the OS. Is it possible to put the bootloader in the SSD?

Thanks in advance.
 
Joined
Jan 21, 2016
Messages
17
Motherboard
Asus P8B75-M
CPU
i5-3570
Graphics
gtx750ti
guys i want to share some knowledge with all.

once you install clover and all kexts, try to boot with the default config.plist, i spent like 2 hours trying to boot with the files that are available here to download and there was nothing i could do to make it boot the installer, finally i tried with the default config that clover installer comes with (+kexts) and it worked like a charm.

also i recommend adding the ps2 kexts, for some reason my mouse is usb but it does not work without them. (my bios prob emulates them as ps2 for higher imput priority)
 
Joined
Jun 13, 2017
Messages
15
Motherboard
GA-Z270X-Gaming 5
CPU
i7-7700K Kaby Lake
Graphics
STRIX-GTX1060-O6G-GAMING
I installed the HS PB on an APFS formatted SSD
Could you please share your EFI? I have same HW as yours but getting kernel panic. Not sure that I understand the reason.
 
Joined
Sep 23, 2017
Messages
6
Motherboard
Aorus Masterz390
CPU
i9900K
Graphics
RX570 / RTX 2070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Im trying too
 
Last edited:
Joined
Sep 5, 2016
Messages
52
Motherboard
Asus Z170i Pro Gaming
CPU
i7 6700k
Graphics
530HD
Mobile Phone
  1. Android
guys i want to share some knowledge with all.

once you install clover and all kexts, try to boot with the default config.plist, i spent like 2 hours trying to boot with the files that are available here to download and there was nothing i could do to make it boot the installer, finally i tried with the default config that clover installer comes with (+kexts) and it worked like a charm.

also i recommend adding the ps2 kexts, for some reason my mouse is usb but it does not work without them. (my bios prob emulates them as ps2 for higher imput priority)
Please upload your efi or config.plist. I had made a USB install High Sierra.
latest cloverv2.4k_r4233 and fakeSMC, IntelMausiEthernet-v2.2.0.
I replaced the config with the one provided on fist page. But usb not booting.
EFI problem?

My Machine specs:
Cpu Intel 6700k
Asus Z170i Gaming Pro
Samsung NVMe 960 evo M.2 SSD
Intel 530 graphics
 
Last edited:
Joined
Aug 17, 2010
Messages
14
Motherboard
MSI H87
CPU
i5-3470
Graphics
GT 1030 2GB
Mobile Phone
  1. iOS
ASUS H170M-E D3 + I3 6100 + INTEL HD 530
I followed the tutorial, copied the sample config.plist and added those Kext (all newest versions available):
- FakeSMC
- IntelGraphicsFixup
- Lilu
- NullCPUPowerManagement
- RealtekTRL8111
- USBInjectAll

When initialising installer it seems to work fine until IOGraphics 0x43 than the screen scrolls very fast and the system reboots....any help what could be the problem?
 

Attachments

  • config.plist
    21 KB · Views: 222
Joined
Nov 27, 2016
Messages
2
Hi everyone.

I'll try to install High Sierra with my Z170A SLI Plus from MSI... But it dosen't work :'(
My English is not perfect but I try this method for install my hackintosh :x anyone know what kext we need with msi ?
 
Joined
Oct 10, 2017
Messages
1
hey are you guys for real ?
unibeast and multibeast require mac os x...
when u try to make a hackintosh from windows...
*facepalm
 
Joined
Dec 14, 2016
Messages
356
Motherboard
Asus Prime z370 A-II
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
macOS High Sierra Public Beta.app does not appear to be a valid OS installer application?????

How did you guys solve this?
I have the same error...running Sierra 10.12.6
 
Top