Contribute
Register

How-to: Change your ATI Graphics Card fan speeds in OS X

Status
Not open for further replies.
Joined
Sep 10, 2010
Messages
14
Motherboard
x58a ud3r
CPU
i7 950
Graphics
xfx 6870
Mac
Classic Mac
Mobile Phone
I havent managed to have any luck yet, anyone got any further help?

Thanks in advance
 
Joined
Sep 10, 2010
Messages
14
Motherboard
x58a ud3r
CPU
i7 950
Graphics
xfx 6870
Mac
Classic Mac
Mobile Phone
Joined
Dec 7, 2011
Messages
2
Motherboard
Hackintosh
CPU
Core i7
Graphics
Gigabyte Radeon 6850
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I am having the same problem. I adjusted the settings and flashed the BIOS under Windows. Fans are nice and quiet there. Reboot to OS X and the fans go up to about 45% as soon as the logon screen shows. It's as though the BIOS change is being ignored somehow.

I am running OS X Lion (10.7.3).

I've combed the forums for answers and nobody seems to have one.
 
Joined
Jul 29, 2013
Messages
70
Motherboard
HP4530s
CPU
Corei5 Sandy
Graphics
HD3000
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
I am working on this at the moment...I had a Windows only 4870 and flashed it to add EFI portion so it would work in the Mac.

In answer to the question from page one of how to extract your original BIOS in Windows Boot Camp use GPU-z that extracts the BIOS..
extract it ..name it ORIGINAL or similar, copy it, work wit the copy and and keep ORIGINAL safe..so if you screw up you can go back to original settings.

On other mac rumour forums there is a post with a working ATI 4870 firmware with EFI section for MAC Thread title was something about dumping the 4870 ROM.. or Golden thread or similar but I won't post a link to it in case I am breaching rules here
 
Joined
Jun 21, 2016
Messages
10
BUMP !!!

I have same issue as others in this thread. I was succesfull flashing the Radeon HD 5770 bios (exactly as OP describe) with new fan speeds and it runs super quiet during PC portion of Hackintosh bootup but when the Apple Logo shows up the fans rev up to same speed as before BIOS flash... seems like the OSX once loaded in GUI mode decides to ignore BIOS values and runs the show himself, based on some generic default values in OSX... unfortunately these generic values are way too noisy... i tried couple Mac fan control apps but NONE OF THEM DETECT ANY GPU FANS...

it makes total sense to edit BIOS ROM on Windows unfortunatelly OSX overides / ignores the settings in GFX BIOS...

anyone had luck ?
 
Status
Not open for further replies.
Top