Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.

kgp

Retired
Joined
May 30, 2014
Messages
6,791
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
I put APIC.aml in /EFI/Clover/ACPI/patched/. In ioregistryexplorer see this (*photo).

this is the correct order to rename?
Seems that apic.aml did not apply at all in your case..
 
Joined
Mar 28, 2011
Messages
231
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
iOS

kgp

Retired
Joined
May 30, 2014
Messages
6,791
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
any idea, or method?
Not really.. apic.aml in my case reveals a correct PRxx implementation.. try to use ssdt-1.aml, and or ssdt-2.aml, and or ssdt-3.aml of the imac-pro dump in addition...

BTW, when using apic.aml you removed all former CPxx -> PRxx ACPI replacements from config.plist.. correct?
 
Joined
Mar 28, 2011
Messages
231
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
iOS
Not really.. apic.aml in my case reveals a correct PRxx implementation.. try to use ssdt-1.aml, and or ssdt-2.aml, and or ssdt-3.aml of the imac-pro dump in addition...

BTW, when using apic.aml you removed all former CPxx -> PRxx ACPI replacements from config.plist.. correct?
I Disable all CPXX -> PRXX and put apic.aml in clover , reset and show what the photo.

I enabled CPXX -> PRXX same your guide and shows like this.
 

Attachments

kgp

Retired
Joined
May 30, 2014
Messages
6,791
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
I Disable all CPXX -> PRXX and put apic.aml in clover , reset and show what the photo.

I enabled CPXX -> PRXX same your guide and shows like this.
You cannot use my replacements for the i9-7900X..

Search along this thread for the proper code snippet for the i9-7900X.
 
Joined
Mar 28, 2011
Messages
231
Motherboard
Asus Tuf X299 Mark 1
CPU
i9-7900X
Graphics
RX 5700 XT
Mobile Phone
iOS
You cannot use my replacements for the i9-7900X..

Search along this thread for the proper code snippet for the i9-7900X.
in post #9888 I found this " @4min cloverfield" and I think it was useful and it worked well.

Now it looks like this, now is it right?
 

Attachments

  • Like
Reactions: kgp
Joined
Feb 5, 2013
Messages
1,206
Motherboard
Asus X299 WS Sage
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac, Mac Pro
So, I just completed (almost) my upgrade to my X299 system. The only thing that is not working is my Broadcom 94360CD card, which is wireless and bluetooth.

The funny thing is Bluetooth works while Wireless does not (this was all working on my X99 system). With my X99, nothing was required.

Does anyone have a kext I can use to activate the Wireless on the card?

@4min .....you did offer to help, so I hate to ask, but might you have any thoughts?
 
Joined
Mar 17, 2011
Messages
8
Motherboard
Asus X299 Mark 2
CPU
i9-7940X
Graphics
Quadro M6000
Mac
Mac mini, Mac Pro
Mobile Phone
iOS
If you really think your config.plist is suspect, I would suggest you post your config.plist file (blank out the SMBIOS section) and screenshots of these directories in your EFI folder (sort with dates): Kexts/Other, ACPI/Patched, and Drivers64.efi so others can see if they can find something that might need correcting....

Also, what version of Clover are you using?
mm2margaret here are my details:
upload_2018-8-18_9-15-30.png


upload_2018-8-18_9-16-30.png


I dont have patched ACPI
Clover version 4644
 

Attachments

Joined
Feb 5, 2013
Messages
1,206
Motherboard
Asus X299 WS Sage
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac, Mac Pro
mm2margaret here are my details:
View attachment 346733

View attachment 346734

I dont have patched ACPI
Clover version 4644
So, did you follow the guide? It doesn't seem like you did. I think you should go back to post #1, download EFI-X299-10.13.6-Release-iMacPro1,1-280718, and start from there. Go through section by section building your EFI. Your directories and files in your existing EFI don't like right to me, but I'll leave that up to more senior posters to determine. I mean, you have an X99 file in there, and you don't have an X99 motherboard, right? If you download the file I mentioned from @kgp's starter EFI, you'll be much further along. I'm not a senior poster on this thread. I just got started, and as you can tell from my post above, I have my own set of issues.....
 
  • Like
Reactions: kgp
Status
Not open for further replies.
Top