Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Feb 5, 2011
Messages
125
Motherboard
Gigabyte X299 AORUS Gaming 7
CPU
i9-7900X
Graphics
2x GTX 1070 8GB
Mac
Mac Pro
Classic Mac
Apple, iBook, Performa, Power Mac, PowerBook, SE
Mobile Phone
Android
Can anyone tell me if this works with TWO gtx 1070 cards!?
 
D

dankium

Guest
Since the update, I cannot boot with both of my monitors plugged in. I can boot with 1 monitor, then I can plug in the second, but both plugged in at boot = black screen. Any thoughts? Any other Maxwell owners that can vouch for dual monitor on 10.13.4?

GFX: Titan X (Maxwell)

Thanks!
No problemo with 970 - 1 hdmi + 1 DP
 
Joined
Oct 19, 2015
Messages
125
Motherboard
ASUS Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Vega FE
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
No problemo with 970 - 1 hdmi + 1 DP
Thanks, and have you implemented the ssdt per the guide, or do you run without? Also I assume you are on .106 Nvidia driver...
 
Joined
Feb 24, 2013
Messages
2,308
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Since the update, I cannot boot with both of my monitors plugged in. I can boot with 1 monitor, then I can plug in the second, but both plugged in at boot = black screen. Any thoughts? Any other Maxwell owners that can vouch for dual monitor on 10.13.4?

GFX: Titan X (Maxwell)

Thanks!
nVidiaGraphicFixup.kext is installed, correct? Make sure you have the latest.
 
Joined
Jan 26, 2018
Messages
919
Motherboard
ASRock X299 Professional Gaming XE
CPU
i9-7980xe
Graphics
Vega
Mac
Mac Pro
Mobile Phone
Android
For those of you with sleep / wake issues, do you have a AIO connected to usb?

I built a hackintosh for a friend, and had the H100i that the system would wake after sleeping for 2 seconds.

The fix was to remove the USB port it was plugged in using the allusb.kext route.
It is connected yes. However the issue isn't about waking up the machine, it's to put it to sleep.
I had sleep/resume working on the Designare with the H115i plugged in, but only when nothing was connected to the thunderbolt ports.

Talking about H115i, there's now experimental support working in OSX. You can set the different profiles or read the fans speed.
 
Joined
Aug 13, 2015
Messages
28
Motherboard
Asus Prime X299-A
CPU
i9-7900X
Graphics
Sapphire Radeon RX Vega 64
Mac
iMac
Mobile Phone
iOS
My guess is that it doesn't work because of the thunderbolt devices I'm using (apple TB display), Promise Pegasus R4 and lacie TB ssd.
I have working Thunderbolt hotswap using Promise Pegasus R4 (TB1), Lacie 2big (TB3) and Drobo 5D (TB2). Using all devices in chain in this order - Lacie -> TB3 to TB2 adapter -> Drobo -> Pegasus. Before I got Lacie it was hotswaping fine using it like this - TB3 to TB2 adapter -> Drobo -> Pegasus.
Only thing I noticed is that for example if I plug Drobo into TB3 to TB2 adapter and then plug adapter into TB3 card, my Drobo wont show up, but if I plug it in diferent order - adapter into TB3 card first, then connect Drobo to adapter, it shows up fine.
 
Joined
Jan 26, 2018
Messages
919
Motherboard
ASRock X299 Professional Gaming XE
CPU
i9-7980xe
Graphics
Vega
Mac
Mac Pro
Mobile Phone
Android
I have working Thunderbolt hotswap using Promise Pegasus R4 (TB1), Lacie 2big (TB3) and Drobo 5D (TB2). Using all devices in chain in this order - Lacie -> TB3 to TB2 adapter -> Drobo -> Pegasus. Before I got Lacie it was hotswaping fine using it like this - TB3 to TB2 adapter -> Drobo -> Pegasus.
Only thing I noticed is that for example if I plug Drobo into TB3 to TB2 adapter and then plug adapter into TB3 card, my Drobo wont show up, but if I plug it in diferent order - adapter into TB3 card first, then connect Drobo to adapter, it shows up fine.
I have them connected like this:
TB3 -> TB3/TB2 adapter -> Pegasus 2 R4 -> Apple TB display -> Lacie

I tried just the Pegasus \, just the Apple display, or just the Lacie... Behaviour is always the same. All those devices are TB1 except the Pegasus (TB2)
I have a Samsung S8 connected to the second TB3 port via a 2m TB3 thunderbolt cable (that's just for charging). If I plug the S8 while the mac is running, it will cause the OS to hang.
the registry explorer shows that PCIHotplugCapable is properly set on the PC01->BR1A->UPSB->DSB0 device
and PCI-Thunderbolt is also set on PC01->BR1A->UPSB

I've had the same behaviour with the Asus ThunderboltEX (either in port 4 or port 7), the built-in TB3 ports on the designare, or with the ASRock TB3 card with either the Asus Prime Deluxe or the ASRock Professional Gaming EX...

Also, with the Asus ThunderboltEX card, I can't boot the machine if the Apple TB display is connected ; I get an error message about too great USB power draw and then it shuts down. This doesn't occur with the ASRock TB3 card (which uses exactly the same TB3 chipset has the real iMac Pro)
 
Joined
Nov 7, 2016
Messages
77
Motherboard
Gigabyte X299 Designare
CPU
i9-7940X
Graphics
Vega FE
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
I have no doubt an SSDT can help, but I'm yet to read anyone actually pinpointing which change was absolutely necessary or which change caused sleep/wake to suddenly work.
So I'm very curious about that.

People have reported sleep/wake to work for them, even without SSDT changes. Or people using the SSDTfor the asus with a different motherboard, even though nine of the ACPI paths matched.

DSM2 had sleep/wake working with nothing.
Me even though I have the exact same board as you and configuration, and use an identical EFI folder, I never managed to get sleep to work properly. I've tried with 4 different motherboards. Never worked.
So my guess is the sleep/wake works depending on what you actually connect.
I have a device in my system that prevents sleep. I can't figure out which one though.
I'm certain it has nothing to do with the SSDT
Hi, since 10.13.4 update my 2nd monitor do not work anymore.... do you have both monitors working?
Some suggestions? Did you changed anything in your efi?
 
Joined
Jan 26, 2018
Messages
919
Motherboard
ASRock X299 Professional Gaming XE
CPU
i9-7980xe
Graphics
Vega
Mac
Mac Pro
Mobile Phone
Android
Hi, since 10.13.4 update my 2nd monitor do not work anymore.... do you have both monitors working?
Some suggestions? Did you changed anything in your efi?
Yes, you need the VegaFixup kext with Lilu.kext installed.
They are linked to the first post or available there
https://github.com/jyavenard/Vega5KFixup/releases

You need the release version of lilu installed
 

kgp

Retired
Joined
May 30, 2014
Messages
6,902
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Status
Not open for further replies.
Top