Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Oct 5, 2013
Messages
145
Motherboard
Asus X299 A 32Gb Ram
CPU
i9 -7920X
Graphics
ATI RX 580 Sapphire Pulse
Mac
iMac
Debug version of Lilu.kext needs to be copied to build root folder in order to build Lilu plugins such as NvidiaGraphicsFixup.
So, first build a debug version of Lilu.kext with command
Code:
xcodebuild -configuration Debug
Copy what you just built from the build folder over to the NvidiaGraphicsFixup root and then build the NvidiaGraphicsFixup kext.
Thanks!
 
Joined
Oct 5, 2013
Messages
145
Motherboard
Asus X299 A 32Gb Ram
CPU
i9 -7920X
Graphics
ATI RX 580 Sapphire Pulse
Mac
iMac
.106 seems to be more stable and smoother than 103.. I've just experienced some major lag in iTunes, especially with scrolling in the library, not to mention the system almost locked up while the audio seem to start and stop a couple of times.

Update : Also experienced Graphic glitches in iTunes with .106 so u reverted to the old Lilu and NvidiaGraphicsFixup 1.2.3 with seems to have normalised my system and fixed the screen resolution issue from wake from sleep.

Will stick to this version till somebody else reports better stability with the new updates.
 
Last edited:
Joined
Jan 26, 2018
Messages
932
Motherboard
ASRock X299 Professional Gaming XE
CPU
i9-7980xe
Graphics
Vega
Mac
Mac Pro
Mobile Phone
Android
I'm pretty sure I'm using DSM2's USB kext. So far every port that I have tried is working. I need to find time to test TB ports. Either way, thanks for the info. I greatly appreciate it. I might have more questions later on :)
I was referring to the USB C ports. Did you get them working with hotplug?
 
Joined
Feb 6, 2017
Messages
38
Motherboard
Gigabyte X299 Designare EX
CPU
i9-7920X
Graphics
Rx 480
Mac
Mac Pro
I was referring to the USB C ports. Did you get them working with hotplug?
Haven't had a chance to test it yet. I've only used USB 2.0 and 3.0 devices. Not even sure if I have a USB C device for testing purposes.
 
Joined
Feb 24, 2013
Messages
2,292
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I haven't tried that yet, will do. Thought it was "obsolete."
It is, but there might have been something you missed from the original guide and this kext will help in the mean time.
 
Joined
Sep 27, 2017
Messages
53
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7900X
Graphics
RX 580
Mac
Mac Pro
Mobile Phone
Android
I have them connected like this:
TB3 -> TB3/TB2 adapter -> Pegasus 2 R4 -> Apple TB display -> Lacie

I tried just the Pegasus \, just the Apple display, or just the Lacie... Behaviour is always the same. All those devices are TB1 except the Pegasus (TB2)
I have a Samsung S8 connected to the second TB3 port via a 2m TB3 thunderbolt cable (that's just for charging). If I plug the S8 while the mac is running, it will cause the OS to hang.
the registry explorer shows that PCIHotplugCapable is properly set on the PC01->BR1A->UPSB->DSB0 device
and PCI-Thunderbolt is also set on PC01->BR1A->UPSB

I've had the same behaviour with the Asus ThunderboltEX (either in port 4 or port 7), the built-in TB3 ports on the designare, or with the ASRock TB3 card with either the Asus Prime Deluxe or the ASRock Professional Gaming EX...

Also, with the Asus ThunderboltEX card, I can't boot the machine if the Apple TB display is connected ; I get an error message about too great USB power draw and then it shuts down. This doesn't occur with the ASRock TB3 card (which uses exactly the same TB3 chipset has the real iMac Pro)
Hey @jyavenard, have you found a solution to the "USB Current Overload" message at boot with the TB Display plugged in? I've made it work by plugging the display during clover as you recommended, but I fear it could damage something on the mobo by doing it that way, I'm I just being paranoid?
 
Joined
Oct 19, 2015
Messages
128
Motherboard
ASUS Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Vega FE
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Does anyone have a Decklink (Mini monitor or extreme) working on their system? My Decklink worked fine without any SSDT in under the iMac SMBIOS, but since we all switched to iMac Pro SMBIOS, it hasn't worked. If I move it to a different slot it will work fine 1 time, then a reboot kills it.
 
Joined
Nov 7, 2017
Messages
30
Motherboard
Asus Prime x299 Deluxe
CPU
i9-7900x
Graphics
Radeon Vega Frontier Edition
Does anyone have a Decklink (Mini monitor or extreme) working on their system? My Decklink worked fine without any SSDT in under the iMac SMBIOS, but since we all switched to iMac Pro SMBIOS, it hasn't worked. If I move it to a different slot it will work fine 1 time, then a reboot kills it.
I have a DeckLink 4K Extreme. It was working fine before I created my SSDT. I haven't had much time to play with it since, but it seems to be working fine now...just a quick couple of tests.
 
Joined
Sep 4, 2015
Messages
78
Motherboard
ASUS Prime X299-A
CPU
i9-7920X
Graphics
RX Vega 64
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
.106 seems to be more stable and smoother than 103.. I've just experienced some major lag in iTunes, especially with scrolling in the library, not to mention the system almost locked up while the audio seem to start and stop a couple of times.

Update : Also experienced Graphic glitches in iTunes with .106 so u reverted to the old Lilu and NvidiaGraphicsFixup 1.2.3 with seems to have normalised my system and fixed the screen resolution issue from wake from sleep.

Will stick to this version till somebody else reports better stability with the new updates.
Hey @perfecto245,

I'm about to update to 10.13.4, so your input regarding the Nvidia drivers is greatly appreciated.

We have almost the exact same system. I've never been able to get sleep/wake to work but I haven't implemented an SSDT. The difference in our system is the graphics card (I have a 1070 Ti) but I'm wondering if there are differences in our setup.

Have you implemented an SSDT? If so, would you be open to sharing it with me?

I'm trying to run a lean a system as possible. The following are the only kexts I have installed:
AppleALC (1.2.4)
FakeSMC (6.26.1463, with sensors included as plugins)
IntelMausiEthernet (2.3.0)
Lilu (1.2.2)
TSCAdjustReset (from @interfernc, I'm running the new BIOS - 1301 and use it to unlock the MSR register)

Any insight you have would be extremely welcome.
 
Joined
Sep 4, 2015
Messages
46
Motherboard
ASRock Fatal1ty X299 Gaming K6
CPU
i7-7820X
Graphics
Vega 56
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
hello @kgp and @justdatruth, in the last few months I have been really busy working, so since my Skylake-X implementation with iMac17,1 definition was stable and solid I didn't bother updating to iMacPro1,1 definition nor to 10.13.3.
But lately for unknown reasons (at least to me) I have been getting many kernel panics! (see picture):

10.13.1 kernel panic detail.JPG


Any Idea to what might be the cause? Apparently I did not do any upgrades or changes to system related files, so why does it occur?

Anyway I thought it was time for an an update to Mac OS 12.13.4 and of course to iMacPro1,1 definition.
So this weekend I read KGP's updated guide, very detailed as usual, created a brand-new USB stick using 31-03-2018 EFI folder distribution and I followed all instructions to create a brand new fresh install, but no! USB stick brings me to Clover UI but after during the boot process it gets stuck right here (see picture):

10.13.4 USB stick installer with KGP EFI folder.JPG


I thought I did everything I needed to, but I guess it is not the case. From what I gather in my ASrock mobo the MSR 0xE2 register is unlocked when the CFG Lock is left disabled; I then just followed instructions from D.1 to D.4 also trying to prevent errors looking at section C.) Important General Note/Advice and Error Prevention.
any advices?

thanks

OZ
 
Status
Not open for further replies.
Top