Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Successful Update to macOS High Sierra 10.13.4 Public Beta 3 (17E160e)

10.13.4-17E160e.png


Guide update will follow tomorrow...

Enjoy and have fun,

kgp.png
 

RuleBreaker01

Banned
Joined
May 31, 2018
Messages
1,198
Advice wanted, I'm stuck booting on this new gigabyte board, always in the same spot, last line displayed being "[ PCI configuration begin ]".

I've followed exactly the gigabyte bios steps mentioned on page 1.

Here is a screen capture, any advices on what to do?
Thanks
 

Attachments

  • 43E51873-DB67-4DBB-B1CF-976F1CA5CD56.jpeg
    43E51873-DB67-4DBB-B1CF-976F1CA5CD56.jpeg
    3.8 MB · Views: 111

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Advice wanted, I'm stuck booting on this new gigabyte board, always in the same spot, last line displayed being "[ PCI configuration begin ]".

I've followed exactly the gigabyte bios steps mentioned on page 1.

Here is a screen capture, any advices on what to do?
Thanks

First at all and once more, please provide your Skylake-X/X299 system specs (mobo, CPU, GPU) in either your profile or signature. Otherwise you want receive any support or help by anybody...
 

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Big Progress in Skylake-X/X299 HWMonitoring

After a extensive tweet session between @BJango, @gxsolace and myself, it seems that we approached a major step forward towards a correct Skalyke-X/X299 HWMonitoring based on the HWSensor and FakeSMC kext distribution provided by @interferenc and iStatMenus provided by @BJango. Many thanks to both @interferenc and @Bjango for their awesome and extensive contributions and just brilliant work!

iStatMenus.png


The recent iStatMenus beta distribution can be achieved here: https://s3.amazonaws.com/bjango/files/istatmenus6/957.zip …
The HWSensor and FakeSMC kext distribution of @interferenc can be achieved here: https://github.com/interferenc/HWSensors
To compile the the HWSensor kexts, perform the individual steps detailed below:

1.)
Code:
git clone https://github.com/interferenc/HWSensors
2.)
Code:
cp HWSensors ~/Desktop/
3.)
Code:
cd ~/Desktop/HWSensors
4.)
Code:
xcodebuild -project Versioning\ And\ Distribution.xcodeproj/
5.)
Code:
xcodebuild -project HWMonitor.xcodeproj/
6.)
Code:
xcodebuild -project HWSensors.xcodeproj -alltargets

Subsequently, one finds the all compiled binaries in ~/Desktop/HWSensors/Binaries/.

Note that all compiled kext binaries are once more attached below. Just download and unzip HW-Sensors.zip and copy all kexts to /EFI/Clover/kexts/Other/.

Remaining problems:

a.) CPU Package Cores and CPU package DRAM power consumption apparently not supported by sensor kexts...
b.) GPU Fan speed at 100 rpm for water blocked Nvidia GPU :)

Enjoy and have fun,

kgp.png
 

Attachments

  • HW-Sensors.zip
    161.9 KB · Views: 107
Last edited:

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
my bad.. done

Just a few posts before, @DSM2 was so kind to provide his EFI-Folder especially adopted for the DESIGNARE EX! I am sure this will also solve your issues..

Good luck,

KGP
 
Joined
Sep 7, 2014
Messages
37
Motherboard
Asus X299 Deluxe
CPU
i9 7980XE
Graphics
2x VEGA FE
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Subsequently, one finds the all compiled binaries in ~/Desktop/HWSensors/Binaries/.
It's fine to add this generated FakeSMC to my /EFI/Clover/kexts/Other/. ? It won't break my system by not having something you tweaked?
 
Joined
Sep 3, 2017
Messages
2
Motherboard
Asus Rog Rampage VI Extreme
CPU
i9-7980XE
Graphics
2x EVGA Nvidia GTX1080TI Kingpin
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi,
I'm pretty new to this hackingtosh stuff.
only have had one hackingtosh build before a Asus P8H77-I Socket 1155 with an i5-3570k cpu and no gpu
and that hack was straigth forward. used unibeast to make the usb installer and just ran it and it worked..

But now i'm trying to get MacOS running on my daily user..
Have followed the instructions as in the first post,
i have configured the bios and done the patch (on the rampage u have to rename the patched bios file to R6E.CAP)
and the creation of the usb installer had no problems (at least i think)

Only when ran the installer i ran into some major problems..
2 min into the installation i get this screen
telling me
IMac.local com.apple.xpc.launchd[1] (com.apple.windowserver.XXX) <warning>: Service exited with abnormal code: 1
IMac.local com.apple.xpc.launchd[1] (com.apple.windowserver) <notice>: service only ran for 0 seconds. pushing respawn out by 10 sec
and so it goes on and on with XXX just increasing the numbers

not sure if this is caused by that i have a Rampage vi Extreme card or the 2x 1080ti's or my 128gb ram

only hoping someone here can tell me whats going on..
cuz i'm like so close to spending like 12k on a Imac Pro now. and i dont want that :D hehe
 

Attachments

  • IMG_2092.jpg
    IMG_2092.jpg
    108.9 KB · Views: 99
Joined
Sep 7, 2014
Messages
37
Motherboard
Asus X299 Deluxe
CPU
i9 7980XE
Graphics
2x VEGA FE
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
It's fine to add this generated FakeSMC to my /EFI/Clover/kexts/Other/. ? It won't break my system by not having something you tweaked?
I'm a wimp. Totally worked.
 
  • Like
Reactions: kgp
Joined
Nov 21, 2013
Messages
149
Motherboard
Gigabyte TRX40 Aorus Xtreme
CPU
Ryzen 3970X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi,
I have an IOGear Bluetooth 4.0 USB adapter (listed in the Accessories section of the Buyer's Guide here on Tonymacx86). It worked perfectly with my previous Yosemite/El-Captian/Sierra hackintoshes but is not working with 10.13.3. Is there a way to get it to work? Also I am a noob when it comes to SSDTs. Do we really need one? If so, how to create/extract it?
 
Last edited:
Status
Not open for further replies.
Top