Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Jan 3, 2013
Messages
131
Motherboard
Asus Rog Strix Z490-E Gaming
CPU
i7-10700
Graphics
UHD 630 - RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
MrBurns.jpg
 
Joined
Dec 3, 2017
Messages
16
Motherboard
ASROCK X299 KILLER
CPU
i7-7820X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Thank you very much for your guide.
I'm using 7820 x.
Your guide says that 7820x, 7900x do not use ssdtprgen.
Can you tell me why these two models are the only ones?
 
Joined
Nov 2, 2015
Messages
17
Motherboard
ASUS Prime x299 Deluxe
CPU
i9-7900X
Graphics
MSI GTX 1080 TWIN FROZR VI
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Good evening @kgp I've been struggling for several hours getting the USB installer to show in Clover with no luck. USB installers containing older versions of OSX do show up in Clover. So, I know the problem is related to OSX 10.13.2 and how I create the USB installer. Now, everything seems to work out well till the point where I have to make it bootable.
Code:
cd /Volumes/Install\ macOS\ High\ Sierra
mkdir .IABootFiles
cd .IABootFiles
cp /Volumes/Install\ macOS\ High\ Sierra/System/Library/CoreServices/boot.efi .
I receive the response:

Code:
usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file
cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_directory
Afterwards the the hidden folder .IABootFiles is empty? Could you please let me know if this is correct behaviour?
I can't eject the USB before I quit Terminal (As Terminal is using the USB disk). I fear it might be in process of something it never finishes
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Good evening @kgp I've been struggling for several hours getting the USB installer to show in Clover with no luck. USB installers containing older versions of OSX do show up in Clover. So, I know the problem is related to OSX 10.13.2 and how I create the USB installer. Now, everything seems to work out well till the point where I have to make it bootable.
Code:
cd /Volumes/Install\ macOS\ High\ Sierra
mkdir .IABootFiles
cd .IABootFiles
cp /Volumes/Install\ macOS\ High\ Sierra/System/Library/CoreServices/boot.efi .
I receive the response:

Code:
usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file
cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_directory
Afterwards the the hidden folder .IABootFiles is empty? Could you please let me know if this is correct behaviour?
I can't eject the USB before I quit Terminal (As Terminal is using the USB disk). I fear it might be in process of something it never finishes

Guess your path to your USB Drive is incomplete or wrong? :rolleyes: .. you should learn how to use unix commands..
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Thank you very much for your guide.
I'm using 7820 x.
Your guide says that 7820x, 7900x do not use ssdtprgen.
Can you tell me why these two models are the only ones?

Because these two Skylake-X models are up to my knowledge the only ones fully natively implemented by OSX so far. All others still seem to need a ssd.aml to properly run XCPM..
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Guide Update - 17.01.2018

EFI-Folder related modifications:
  • Implementation of Clover Boot Loader Clover_v2.4k_r4382
  • AptioMemoryFix.efi replaced by OsxAptioFix3Drv-64.efi of Clover_v2.4k_r4382
Note that a new EFI-Folder has been attached at the bottom of the originating post/guide and is once more attached here blow.

Guide related modifications:
  • Modifications of Section C.1
OsxAptioFix3Drv-64.efi maintains native NVRAM implementation for our iMac Pro Skylake-X/X299 Systems under macOS High Sierra 10.13.2 (17C2120) and 10.13.2 SA (17C2205), thus EmuVariableUefi-64.efi has been also omitted in the /EFI/Clover/drivers64UEFI/ directory contained in newly distributed EFI-Folder.

Further note that for native NVRAM implementation, Clover's RC Scripts have to be omitted during the clover boot loader installation. If already previously installed, remove Clover's RC Scripts from the /etc directory of your macOS USB Flash Drive Installer or System Disk as described in Section C.1) of my guide.

OsxAptioFix3Drv-64.efi works absolutely flawless on my system, without any memory allocation errors or slide issues even with the "slide" boot flag disabled.

Thanks for the hard work of @apianti et al. (Clover Team)!

Enjoy and have fun :thumbup:

kgp.png
 

Attachments

  • EFI-X299-10.13.2-Release-iMacPro1,1-170118.zip
    19.5 MB · Views: 110
Joined
Oct 10, 2011
Messages
15
Motherboard
Gigabyte X299 AORUS Gaming 7
CPU
i9-7900X
Graphics
Zotac GTX 1080 Ti Amp! Extreme
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
Hi KGP! Thank you so much for taking your time to write this guide and answer all the questions here!

I am at step D.2, using a MacBook Pro 14,3. I don't think you mentioned whether we need to download the Install High Sierra.app before hand but I do have it inside my applications folder and I ejected the InstallESD partition with Disk Utility after closing the install window that pops up automatically after downloading finished.

So attached please find the screenshot of my terminal output from both using the script as well as entering the command in the terminal directly. Thank you in advanced!
 

Attachments

  • Screen Shot 2018-01-16 at 10.40.35 PM.png
    Screen Shot 2018-01-16 at 10.40.35 PM.png
    599.4 KB · Views: 157
Joined
Jan 9, 2018
Messages
24
Motherboard
STRIX X299-E GAMING
CPU
I7-7820X
Graphics
ROG STRIX GTX 1080TI
Hey KGP, I am about to attempt to update my system from the iMac 17,1 to iMac pro 1,1 with the supplemental update. I was wondering if the motherboard patch to unlock the motherboard register is necessary in your opinion for my CPU (i7-7820X). Is there really any benefit to doing this or should I just enable "xcpm_core_scope_msrs" in KernalToPatch and just leave it locked. Hate to mess around with BIOS firmware if I don’t have to.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,769
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hey KGP, I am about to attempt to update my system from the iMac 17,1 to iMac pro 1,1 with the supplemental update. I was wondering if the motherboard patch to unlock the motherboard register is necessary in your opinion for my CPU (i7-7820X). Is there really any benefit to doing this or should I just enable "xcpm_core_scope_msrs" in KernalToPatch and just leave it locked. Hate to mess around with BIOS firmware if I don’t have to.

My recommendations are clear, aren't they? ;)
 
Status
Not open for further replies.
Top