Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
@DSM2 ok, but now it looks like the path is incorrect...btw i´m not a genius in in the hackintosh scene, it´s not my hobby, please do not be so strict with me...
 

Attachments

  • Bildschirmfoto 2018-01-14 um 10.43.27.png
    Bildschirmfoto 2018-01-14 um 10.43.27.png
    30.7 KB · Views: 134
Ok i try...good night
 
Which device and macOS build are you on?

I got the same error ERROR_B14B14D9B7.

I tried on my hack with 10.13.2 (17C205), SMBIOS is 18,3.

And also on my (true) Macbook Pro with 10.13.3 beta (17D29a).

The error comes from English.dist, it expects to be run with board id Mac-7BA5B2D9E42DDD94.
 
Last edited:
I succsesfully switched to iMacPro1,1 and implemented the new ACPI patching. Combined with the patched BIOS the DAW Power Management bug is finally really gone!
Thanks a lot to everyone involved in this great project and especially to @DSM2 and @kgp for your absolutely amazing work! It makes work much more comfortable :).

I have a few bugs left and some observations to mention (10.13.3 Beta (17D34a)):
-> In my case front USB 3 ports do not work without my USB Kext for the Asus Prime X299 A. USB 2 & 3.1 do!
-> My machine doesn´t shut down nor reboots properly. It sounds like it shuts down but the fans keep running indefinite.
-> I was never able to generate my own SSDT for my 7900X (IMac 17 & ImacPro). I´m currently using a one i found here in the thread. I´ve never had that before and it´s not the first time I´m using the ssdtPRGen script. The error is always the same "unknown processor model", but i know that my processor data is part of the skylake.cfg from ssdtPRGen.sh. I don´t get it does anyone have a clue what the problem could be?

My Clover folder ist attached...
 

Attachments

  • CLOVER.zip
    2.5 MB · Views: 64
@kgp why not test the appstore method since we need to be on imacpro smbios for the commands to work anyways?
 
Last edited:
Thank's KGP I have read carefully all this tread : the best guide written and
that i have ever seen congrats !
Cheers :D
 
Last edited:
@kgp why not test the appstore method since we need to be on imacpro smbios for the commands to work anyways?

We are working on a fix for the issue. You can try the Appstore method...

But it won't help anybody in case of a clean install...

Nobody without a iMac Pro build will be able to access the special iMac Pro MacOS build from the Appstore.

This is totally at odd with the idea of a clean install ...
 
I succsesfully switched to iMacPro1,1 and implemented the new ACPI patching. Combined with the patched BIOS the DAW Power Management bug is finally really gone!
Thanks a lot to everyone involved in this great project and especially to @DSM2 and @kgp for your absolutely amazing work! It makes work much more comfortable :).

I have a few bugs left and some observations to mention (10.13.3 Beta (17D34a)):
-> In my case front USB 3 ports do not work without my USB Kext for the Asus Prime X299 A. USB 2 & 3.1 do!
-> My machine doesn´t shut down nor reboots properly. It sounds like it shuts down but the fans keep running indefinite.
-> I was never able to generate my own SSDT for my 7900X (IMac 17 & ImacPro). I´m currently using a one i found here in the thread. I´ve never had that before and it´s not the first time I´m using the ssdtPRGen script. The error is always the same "unknown processor model", but i know that my processor data is part of the skylake.cfg from ssdtPRGen.sh. I don´t get it does anyone have a clue what the problem could be?

My Clover folder ist attached...

Delete the ssdtPRGen folder in ~/Library/ and rerun ssdtPRGen.sh!
 
Status
Not open for further replies.
Back
Top