Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Jun 26, 2010
Messages
47
Motherboard
Asus X299A
CPU
i7-7800X
Graphics
GTX 980 Ti
Mac
MacBook Pro
Mobile Phone
iOS
Hi, thanks for your reply.
As it turned out it's a Titan Ridge issue.
What I did is running a fresh 10.13.6 install on an older hackintosh where the Thunderbolt card works. This allowed me to find the correct driver.
Installing such driver on the Sage + Titan Ridge didn't make the UltraSTUDIO 3D work.
What's left at this point is just the Titan Ridge Card on the Sage.
The UltraSTUDIO 3D doesn't show up at all in IOReg.
All the other Thunderbolt 2 / 3 devices (Other BlackMagic cards, all the external hard disks) connected to the Sage + Titan Ridge work immediately.

I ordered an Alpine Ridge to see if it makes any difference.
Does it show up in Windows?
 
Joined
Dec 31, 2013
Messages
465
Motherboard
Huawei Matebook D i5-8250U 14"
CPU
Intel i5-8250U
Graphics
UHD 620
Mobile Phone
iOS
Does it show up in Windows?
Haven't tested in Windows yet. This machine has only High Sierra.
All the Thunderbolt 3 work grea but that one I mentioned which with the same driver works on a brand new high Sierra on an old Z170 Gigabyte hackintosh with built in Thunderbolt 3.
 
Joined
Feb 28, 2019
Messages
9
Motherboard
Asus Prime X299
CPU
i9-7920X
Graphics
Vega 64
I have a x299 build with a Vega 64 card that boots fine but then quickly crashes within a few minutes consistently. Would you be able to glean anything from this crash log? Another user had commented their might be a sleep issue. I'm not sure how to address this, except that I turned off all the energy saver options minus turn off hard drives when possible in the os once booted.
 

Attachments

kgp

Retired
Joined
May 30, 2014
Messages
6,902
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
I have a x299 build with a Vega 64 card that boots fine but then quickly crashes within a few minutes consistently. Would you be able to glean anything from this crash log? Another user had commented their might be a sleep issue. I'm not sure how to address this, except that I turned off all the energy saver options minus turn off hard drives when possible in the os once booted.
Try to provide a useful bug report and else, read beginning of Section C.) and provide requested information to allow others to help.
 
Joined
Jul 21, 2017
Messages
8
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac
I made my first build from this guide almost a year ago and thanks to all who have contributed. It seems the aml files are an addition since the first time I followed this guide and I am not sure where (what folder) to place them in. I have learned what they are/do and have seen the root directory of the hard drive as well as folders on the EFI as possible places to drop them into so it is not clear. Any help would be appreciated. I am trying to get my new Radeon VII working with acceleration and I think this is my stumbling block. Thanks
 
Joined
May 11, 2018
Messages
9
Hi!

Has anyone already built a Hackintosh on the Asus WS C621 Sage?
Is there a link to this subject?
I would be grateful for your help.
 
Joined
Apr 18, 2011
Messages
444
Motherboard
ASUS WS X299 Sage/10G
CPU
i9-7980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I made my first build from this guide almost a year ago and thanks to all who have contributed. It seems the aml files are an addition since the first time I followed this guide and I am not sure where (what folder) to place them in. I have learned what they are/do and have seen the root directory of the hard drive as well as folders on the EFI as possible places to drop them into so it is not clear. Any help would be appreciated. I am trying to get my new Radeon VII working with acceleration and I think this is my stumbling block. Thanks
There is currently no native support for the radeon VII. Hopefully with the release of 10.14.4
 
Joined
Jul 21, 2017
Messages
8
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac
There is currently no native support for the radeon VII. Hopefully with the release of 10.14.4
No native support but some success with the VII working with graphics acceleration in 10.14.4 beta with work arounds. Still wondering if anyone has info on AML file folder/directory locations.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,902
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
No native support but some success with the VII working with graphics acceleration in 10.14.4 beta with work arounds. Still wondering if anyone has info on AML file folder/directory locations.
Link to X299 SSDT Github repository is part of the guide in the originating post of this thread. Anyway once more here: https://github.com/KGP/X299-System-SSDTs
 
Joined
Jul 21, 2017
Messages
8
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7980XE
Graphics
Radeon VII
Mac
iMac
Link to X299 SSDT Github repository is part of the guide in the originating post of this thread. Anyway once more here: https://github.com/KGP/X299-System-SSDTs
Thanks. Once I read through the readme and did a few searches I realized the source of my confusion. Chimera/Chameleon and Clover use different folders. So for Clover, AMLs are dropped into

/EFI/CLOVER/ACPI/

per your guide “Any DSDT ACPI replacement in the config.plist is usually implemented under “DSDT” and “Patches” in Section “ACPI” of Clover Configurator” and I confirmed this in the newbie chart I found here: https://www.tonymacx86.com/threads/clover-basics-and-switching-advice.171680/
I will try this and see if they show up in the PCI section of the System Report (as would be expected).

1C0A6870-4231-48E9-952F-1095F81ACFD0.jpeg
 
Last edited:
Status
Not open for further replies.
Top