Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Nov 4, 2018
Messages
13
Motherboard
ASUS X299 DELUXE
CPU
i9-7920X
Graphics
GTX 1080 Ti
Hi Guys,
No Thunderbolt Hotplug. THB EX3 card well implemented. Hotplug under windows. Ok in Mac OS high sierra 13.6 if connected before booting. Impossible after. I try with differents thunderbolt cables and adapters. Nothing !!!!
Maybe something wrong in my Bios 1503 with power management ?
Any idea ?
Best.
 

Attachments

  • Capture d’écran 2019-03-05 à 10.29.59.png
    Capture d’écran 2019-03-05 à 10.29.59.png
    51.6 KB · Views: 194
  • Capture d’écran 2019-03-05 à 10.30.38.png
    Capture d’écran 2019-03-05 à 10.30.38.png
    179 KB · Views: 194

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hi Guys,
No Thunderbolt Hotplug. THB EX3 card well implemented. Hotplug under windows. Ok in Mac OS high sierra 13.6 if connected before booting. Impossible after. I try with differents thunderbolt cables and adapters. Nothing !!!!
Maybe something wrong in my Bios 1503 with power management ?
Any idea ?
Best.

I repeatedly outlined that the TBEX 3 is the less reliable TB adapter not only in terms of HotPlug.

391173


With the GC-Titan Ridge on the ASUS Prime Deluxe, you will just face issues on wake with TB devices connected during sleep, while HotPlug else works fine and reliable. With the GC-Titan Ridge on the ASUS WS X299 Sage 10G you will not even face issues with TB devices connected during sleep, given the respective user feedback.

Else the GC-Alpine Ridge would be also a thinkable alternative to be used with the ASUS Prime X299 Deluxe.
 
Joined
Nov 4, 2018
Messages
13
Motherboard
ASUS X299 DELUXE
CPU
i9-7920X
Graphics
GTX 1080 Ti
Thanks for your reply but reading your guide and informations you gave to users, I thought you had success with this card and the Thunderbolt Hotpug. I'am going to buy the Titan Ridge.
Anyway, thanks for your guide KPG, my machine turns really well !
Best.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Thanks for your reply but reading your guide and informations you gave to users, I thought you had success with this card and the Thunderbolt Hotpug. I'am going to buy the Titan Ridge.
Anyway, thanks for your guide KPG, my machine turns really well !
Best.

Partial success, yes.. unfortunately the TBEX 3 turned out to be very problematic, unstable and unreliable, when compared with the GC-Titan Ridge or GC-Alpine Ridge and therefore I am not using the primer anymore on my systems.
 
Joined
Nov 1, 2014
Messages
206
Motherboard
Asus Prime X299-Deluxe II
CPU
i9-9980XE
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi kgp

How are you?

I want to check with you please
If I remove the VEGA F.E from my computer
And connects in place GTX 1080ti

And instead of installing Mojave, I install High Sierra

Today nvdia's drivers work well?

I really do not like how VEGA F.E works for me in the system
Every computer is stable and works wonderfully .... Just a graphics card makes me especially trouble working at FCPX

My hardware
Motherboard: Asus Rampage VI Apex
CPU: i9-9980XE
Graphics: Vega F.E. (or 1080 ti)
64gb Ram @3000
 
Joined
Dec 7, 2017
Messages
133
Motherboard
MSI H81M-P33
CPU
i5-4670
Graphics
GTX 750
Mobile Phone
  1. Android
Most Vegas won't be correctly implemented without WEG.kext and one of the respective SSDTs provided in the Github library, which are mandatory for properly implementing all Vega DP1.4 and HDMI ports and for providing Display HotPlug and sleep/wake functionality.

There would at least be a visible desktop, were you to simply power off, swap out the nVidia card & replace with a Vega card, then re-boot while still running High Sierra, no? Then do an in-place O.S. upgrade to Mojave. Leaving fine tuning of extra features for afterwards.
 

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
There would at least be a visible desktop, were you to simply power off, swap out the nVidia card & replace with a Vega card, then re-boot while still running High Sierra, no? Then do an in-place O.S. upgrade to Mojave. Leaving fine tuning of extra features for afterwards.

Sure, of course, although maybe not all ports will be functional without WEG.kext and SSDT. Thus one just needs to connect the display to one of the working ports.
 
Last edited:

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hi kgp

How are you?

I want to check with you please
If I remove the VEGA F.E from my computer
And connects in place GTX 1080ti

And instead of installing Mojave, I install High Sierra

Today nvdia's drivers work well?

I really do not like how VEGA F.E works for me in the system
Every computer is stable and works wonderfully .... Just a graphics card makes me especially trouble working at FCPX

My hardware
Motherboard: Asus Rampage VI Apex
CPU: i9-9980XE
Graphics: Vega F.E. (or 1080 ti)
64gb Ram @3000

Install web drivers or 10.13.6. Don't install Cuda though.
 
Joined
Feb 15, 2011
Messages
121
Motherboard
Asus X299 Sage 10G
CPU
i9-7980XE
Graphics
WX7100
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. Android
Anyone having issues when installing high sierra? On two separate systems now each time I install the installer freezes at 2 mins left when booting to the installer USB and installing high sierra. Afterwards, I just restart and finish the installation, but it's a wonder why this happens. Any reason why this would be? I have a vanilla clover on a Deluxe II and Deluxe. @kgp Thanks!
 

kgp

Retired
Joined
May 30, 2014
Messages
6,780
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Anyone having issues when installing high sierra? On two separate systems now each time I install the installer freezes at 2 mins left when booting to the installer USB and installing high sierra. Afterwards, I just restart and finish the installation, but it's a wonder why this happens. Any reason why this would be? I have a vanilla clover on a Deluxe II and Deluxe. @kgp Thanks!

As we don't know about content and constitution of your EFI-Folder, I can just guess that there is something wrong with your CPU BIOS settings for now. Try to lower max. CPU core ratio (e.g. to 32 for all cores) depending on the sophistication of your CPU waterblocking but use core ratio = sync all cores and AVX/AVX-512 offsets in any case.

Else please read beginning of Section C.) and provide adequate information that others can help you in your issue. Due to repetitive unpleasant feedback along my threads and due to an already excessive workload in providing my user specific support, I stopped with the latter for now, which hopefully also will find your comprehension.

For the Deluxe II and with the help of @Maywitt, @AsEvil and @applemacosxGOD, we came up with a complete set of SSDTs and XHC USB kexts for the Deluxe II, which you will find in respective posts along my X299 threads, while the starting EFI-Folder remains being my default X299 EFI-Folder distribution + all necessary add-ons outlined in my guide.

You might be also interested in some of my general conclusions about the Deluxe II for now. Just see post #2,246 in this case.

Good luck, man!

KGP
 
Last edited:
Status
Not open for further replies.
Top