Contribute
Register

How to build your own iMac Pro [Successful Build/Extended Guide]

Status
Not open for further replies.
Joined
Nov 2, 2012
Messages
58
Motherboard
MSI Z170 A Gaming M7
CPU
i7-6700K
Graphics
GTX 1080 Ti
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
1.) Boot flag nvda-drv=1 is obsolete for more than one year. Check NvidiaWeb in config.plist under System Parameters of Clover Configurator instead for forcing the Web Driver to load, if the Web Driver does not load without.

2.) Remove NvidiaGraphicsFixup as it is obsolete and has been replaced by Whatevergreen. Never use both NvidiaGraphicsFixup and Whatevergreen!

3.) I do not use neither VoodooHDA nor USBInjectAll

4.) Again! Use either VoodooHDA or AppleALC

I you are not able to properly configure your system, upload BIOS screen shots, EFI-Folder and IOREG.sav
Thanks kgp for the info, It has been 2 years since my last build so I can feel that I am rusty and out of date :)
I will make these changes tonight/later today and if it does not fix itself I will follow your advice and upload what you suggested.
 
Joined
Jun 30, 2018
Messages
32
Motherboard
ASUS PRIME X299 DELUXE
CPU
Intel i9 7940X
Graphics
Asus Rog 1080 Ti GTX
Mac
iMac, MacBook Pro
Mobile Phone
iOS
The guide in the original post of this thread was already updated to 10.13.6 SU. Where to point to?

After first reboot you boot the "Install macOS on.." partition on your system disk

After the second reboot, you boot the "macOS .." partition on your system disk

What about reading my guide in the original post of this thread?
Yeah, I thought that, wasn't sure if i needed to change up any kexts or anything prior. I'm getting a sierra screen after loading on install mac drive partition that says 'macOS could not be installed on your computer. The installer resources were not found.' Is there an easy way i can delete the cached update files and start the update from scratch?
 

kgp

Retired
Joined
May 30, 2014
Messages
6,902
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Yeah, I thought that, wasn't sure if i needed to change up any kexts or anything prior. I'm getting a sierra screen after loading on install mac drive partition that says 'macOS could not be installed on your computer. The installer resources were not found.' Is there an easy way i can delete the cached update files and start the update from scratch?
Just boot again the macOS system instead of the MacOS installer, this will automatically erase the installer partition.
 
Joined
Jun 30, 2018
Messages
32
Motherboard
ASUS PRIME X299 DELUXE
CPU
Intel i9 7940X
Graphics
Asus Rog 1080 Ti GTX
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Just boot again the macOS system instead of the MacOS installer, this will automatically erase the installer partition.
Yup tried that a few times same problem, not sure if it's due to apfs and me having a windows ssd drive attached? Will muck around with it a bit more tomorrow.
 
Joined
Nov 2, 2012
Messages
58
Motherboard
MSI Z170 A Gaming M7
CPU
i7-6700K
Graphics
GTX 1080 Ti
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android, iOS
1.) Boot flag nvda-drv=1 is obsolete for more than one year. Check NvidiaWeb in config.plist under System Parameters of Clover Configurator instead for forcing the Web Driver to load, if the Web Driver does not load without.

2.) Remove NvidiaGraphicsFixup as it is obsolete and has been replaced by Whatevergreen. Never use both NvidiaGraphicsFixup and Whatevergreen!

3.) I do not use neither VoodooHDA nor USBInjectAll

4.) Again! Use either VoodooHDA or AppleALC

I you are not able to properly configure your system, upload BIOS screen shots, EFI-Folder and IOREG.sav

Just wanted to let you know that removing those kext files you mentioned solved my problem :)
Thanx again kgp!
 
  • Like
Reactions: kgp
Joined
Jul 25, 2015
Messages
2
Motherboard
ASUS X299 Prime Deluxe
CPU
i9-7940X
Graphics
GA 1080 TI
Mobile Phone
Android
Hello, KGP! Need your help!..
I builded same hack, according to your guide, with small difference. 7940x, ddr4 crucial elite3000, GA1080ti,x299primeDeluxe,970evo/apfs. System test 10.13.6 and 10.13.6SU. bios same you guide
All work good. Premiere with 4k video and lots of effects, working perfect. but if i send a queue render to adobe media encoder , hack freezes and no longer responds except reboot. all bench work good. render in ffmbc same freezes. CPU use 30-50%max
 

Attachments

kgp

Retired
Joined
May 30, 2014
Messages
6,902
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
Hello, KGP! Need your help!..
I builded same hack, according to your guide, with small difference. 7940x, ddr4 crucial elite3000, GA1080ti,x299primeDeluxe,970evo/apfs. System test 10.13.6 and 10.13.6SU. bios same you guide
All work good. Premiere with 4k video and lots of effects, working perfect. but if i send a queue render to adobe media encoder , hack freezes and no longer responds except reboot. all bench work good. render in ffmbc same freezes. CPU use 30-50%max
1.) What about AVX and AVX-512 offsets in your BIOS settings?
2.) Flash your mobo with actual BIOS firmware (1503)
3.) Disable MSR lock in BIOS settings
4.) Disable xcpm_core_scope_msrs in config.plist
5.) Uncheck KernelXCPM in config.plist! Skylake-X works native!
6.) Uncheck AppleIntelCPUPM in config.plist
7.) Remove FakeCPUID from config.plist
8.) Add SmUUID to config.plist
9.) SSDT-X299-HDEF.aml will never work without SSDT-DTPG.aml
10.) Remove drivers64 directory from EFI-Folder
11.) Update Clover or use my actual EFI-Folder distribution

Did you ever read my guide? Does not look like. All works good? If so, that would be really a miracle...

Good luck,

KGP
 
Joined
Jul 25, 2015
Messages
2
Motherboard
ASUS X299 Prime Deluxe
CPU
i9-7940X
Graphics
GA 1080 TI
Mobile Phone
Android
1.) What about AVX and AVX-512 offsets in your BIOS settings?
2.) Flash your mobo with actual BIOS firmware (1503)
3.) Disable MSR lock in BIOS settings
4.) Disable xcpm_core_scope_msrs in config.plist
5.) Uncheck KernelXCPM in config.plist! Skylake-X works native!
6.) Uncheck AppleIntelCPUPM in config.plist
7.) Remove FakeCPUID from config.plist
8.) Add SmUUID to config.plist
9.) SSDT-X299-HDEF.aml will never work without SSDT-DTPG.aml
10.) Remove drivers64 directory from EFI-Folder
11.) Update Clover or use my actual EFI-Folder distribution

Did you ever read my guide? Does not look like. All works good? If so, that would be really a miracle...

Good luck,

KGP
1.) avx set to 3
2.) avx 512 to 2
3.) msr disable
4.) tscaadjus fix and use
5.) bois last 1503
6.) Clover update

if I load cpu with a 100% script. then intelpowergadget shows 200-240wt load and works in this mode for hours. if i start rendering adobe , computer hangs in 5-10 minutes
 

kgp

Retired
Joined
May 30, 2014
Messages
6,902
Motherboard
ASUS WS X299 Sage 10G
CPU
i9-7980XE
Graphics
Vega 64
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
1.) avx set to 3
2.) avx 512 to 2
3.) msr disable
4.) tscaadjus fix and use
5.) bois last 1503
6.) Clover update

if I load cpu with a 100% script. then intelpowergadget shows 200-240wt load and works in this mode for hours. if i start rendering adobe , computer hangs in 5-10 minutes
1.) AVX to 3
2.) AVX-512 to 4
4.) Disable xcpm_core_scope_msrs in config.plist
5.) Uncheck KernelXCPM in config.plist! Skylake-X works native!
6.) Uncheck AppleIntelCPUPM in config.plist
7.) Remove FakeCPUID from config.plist
8.) Add SmUUID to config.plist
9.) SSDT-X299-HDEF.aml will never work without SSDT-DTPG.aml
10.) Remove drivers64 directory from EFI-Folder
 
Joined
Nov 1, 2012
Messages
11
Motherboard
Gigabyte X299 Aorus Gaming 9
CPU
i9-7940X
Graphics
RX Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
@kgp , Hi KGP, I just switched my 1080ti to SAPPHIRE NITRO+ Radeon RX Vega 64, and changed to the water cooler too. it works fine, but just one problem, it's black screen after sleep. my main board is x299 Gigabyte aorus gaming 9, CPU is 7940x. Here is my clover EFI file and exported IORegistryExplorer file. could you please guide me how to solve this black screen problem? Thanks!
 
Status
Not open for further replies.
Top