Contribute
Register

How should i enable Radeon 7850 on Mavericks (new public release)

Status
Not open for further replies.
Joined
Jun 15, 2012
Messages
7
Motherboard
Mavericks
CPU
i5-4670
Graphics
ASUS 7850
Mac
Classic Mac
Mobile Phone
Hi guys,

any ideas of enabling my 7850 card on the new public version of Mavericks (22nd october)? Seems like the kexts for 7xxx are changed. I can boot with it only by the UniBeast 3.0 USB installer with low resolution and not even recognized as a Radeon HD 7850 or 7xxx. It's "Display 3 MB" in the display info. I tried with a lot of boot flags with no help but i'm afraid that it's kinda kext related problem.

My specs:

GA-Z87-HD3 with i5-4670 (Intel 4600 iGPU)
ASUS Radeon HD 7850 2 GB

Thank You
 
Joined
Apr 18, 2013
Messages
36
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K OC@4.7Ghz
Graphics
Titan X
Mac
  1. Mac Pro
Mobile Phone
  1. Android
did you install with the intel integrated graphics then switch over to the 7850? Do you have your integrated graphics enabled and primary in the bios?
 
Joined
Jun 15, 2012
Messages
7
Motherboard
Mavericks
CPU
i5-4670
Graphics
ASUS 7850
Mac
Classic Mac
Mobile Phone
Thanks for the fast reply. I installed with the 7850 as primary. The integrated was disabled and it still is.
 
Joined
Jun 15, 2012
Messages
7
Motherboard
Mavericks
CPU
i5-4670
Graphics
ASUS 7850
Mac
Classic Mac
Mobile Phone
Now i tried also with IGPU as primary + IGPU enabled / disabled with no success. 7850 is still not recognized. Unfortunately, this is the only 7xxx card which is not natively supported in Mavericks that's why i should modify the 7xxx kexts or something like that. But since in this new release of Mavericks the 7xxx kexts have changed, i don't know what to do :(
 
Joined
Apr 18, 2013
Messages
36
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K OC@4.7Ghz
Graphics
Titan X
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Joined
Jun 15, 2012
Messages
7
Motherboard
Mavericks
CPU
i5-4670
Graphics
ASUS 7850
Mac
Classic Mac
Mobile Phone
idk if this will help maybe you could extract some good knowledge from it? http://www.insanelymac.com/forum/to...lover-to-patch-kexts-for-ati-hd-7850-in-1083/

- - - Updated - - -

idk if this will help maybe you could extract some good knowledge from it? http://www.insanelymac.com/forum/to...lover-to-patch-kexts-for-ati-hd-7850-in-1083/

In Mavericks GM this was useful but now AMD7000controller.kext is different and an updated solution is needed. It doesn't even contain Info.plist what i could modify.
 
Joined
Jun 15, 2012
Messages
7
Motherboard
Mavericks
CPU
i5-4670
Graphics
ASUS 7850
Mac
Classic Mac
Mobile Phone
I found the new Info.plist in AMD7000Controller.kext
It became a hidden file in the new Mavericks. Now i hope it's gonna work :)
 
Joined
Jun 15, 2012
Messages
7
Motherboard
Mavericks
CPU
i5-4670
Graphics
ASUS 7850
Mac
Classic Mac
Mobile Phone
It works with IGPU primary and enabled, GraphicsEnabler=Yes. I'm happy enough :)
But if anyone has an idea how to boot with primary as 7850 without getting freezed with weird characters before chimera bootscreen, do not hesitate :)
 
Joined
Apr 1, 2013
Messages
73
CPU
MateBook X Pro 2018
Mobile Phone
  1. iOS
It works with IGPU primary and enabled, GraphicsEnabler=Yes. I'm happy enough :)
But if anyone has an idea how to boot with primary as 7850 without getting freezed with weird characters before chimera bootscreen, do not hesitate :)

I am trying to get my 7950 working..can you please help? What steps did you take?

- - - Updated - - -

I found the new Info.plist in AMD7000Controller.kext
It became a hidden file in the new Mavericks. Now i hope it's gonna work :)

So did you unhide it?
 
Joined
Jun 15, 2012
Messages
7
Motherboard
Mavericks
CPU
i5-4670
Graphics
ASUS 7850
Mac
Classic Mac
Mobile Phone
Yes but you don't have to do anything with kexts because your card is natively supported since 10.8.3
If you have problems you can

-set your internal GPU as primary in BIOS
-enable/disable your internal GPU in BIOS (if you don't have 2 screens you can only boot blindly)

if these don't help you can try to start your OS with these boot flags:

GraphicsEnabler=No
GraphicsEnabler=Yes
npci=0x2000
npci=0x3000
PCIRootUID=0
PCIRootUID=1

you can try to mix these flags and also retry with different BIOS settings.
If you use Mountain Lion and you get a white screen while booting:

http://www.osx86.net/files/file/345-ati-hd-7xxx-fix-white-screen/

But don't worry, your card should work, especially if you use Mavericks :)
 
Status
Not open for further replies.
Top