How can I use the bluetooth with BCM94352HMB

Discussion in 'Yosemite Laptop Support' started by swattw, May 12, 2015.

  1. swattw

    swattw

    Joined:
    Mar 10, 2013
    Messages:
    18
    Mobo:
    MSI Z97S-SLI-PLUS
    CPU:
    E3-1231V3
    Graphics:
    R9-280X
    Mobile Phone:
    Android
    May 12, 2015 at 2:30 PM #1
    swattw

    swattw

    Joined:
    Mar 10, 2013
    Messages:
    18
    Mobo:
    MSI Z97S-SLI-PLUS
    CPU:
    E3-1231V3
    Graphics:
    R9-280X
    Mobile Phone:
    Android
    As title
    My laptop is using chamelon+Yosemite10.10.3

    I install the card BCM94352HB to my laptop

    Restart it the Wifi is work but there is no bluetooth
    I cannot understand this post's guide
    But i've try all of the guides
    and it doesn't work.

    Screen Shot 2015-05-12 at 9.27.59 PM.png
    Once I've tried using Kext Wizard.
    And it crashed
    I reboot the laptop and it doesn't change anything.

    Is there any one can help me the bluetooth?
     
  2. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    May 12, 2015 at 2:47 PM #2
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    BCM94352 requirements:
    - FakePCIID.kext and FakePCIID_BCM94352Z_as_BCM94360CS2.kext: https://github.com/RehabMan/OS-X-Fake-PCI-ID. Install with Kext Wizard to /S/L/E.
    - BrcmPatchRAM.kext: https://github.com/RehabMan/OS-X-BrcmPatchRAM. Install with Kext Wizard to /S/L/E.
    - 5Ghz patch for WiFi documented here: http://www.tonymacx86.com/network/104850-guide-airport-pcie-half-mini-v2.html
    - handoff patch for bluetooth documented here: http://www.tonymacx86.com/network/104850-guide-airport-pcie-half-mini-v2.html
     
  3. swattw

    swattw

    Joined:
    Mar 10, 2013
    Messages:
    18
    Mobo:
    MSI Z97S-SLI-PLUS
    CPU:
    E3-1231V3
    Graphics:
    R9-280X
    Mobile Phone:
    Android
    May 12, 2015 at 3:53 PM #3
    swattw

    swattw

    Joined:
    Mar 10, 2013
    Messages:
    18
    Mobo:
    MSI Z97S-SLI-PLUS
    CPU:
    E3-1231V3
    Graphics:
    R9-280X
    Mobile Phone:
    Android
    Screen Shot 2015-05-12 at 10.50.24 PM.png Screen Shot 2015-05-12 at 10.50.30 PM.png
    Is this wworking correct?
     
  4. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    May 12, 2015 at 7:31 PM #4
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
  5. swattw

    swattw

    Joined:
    Mar 10, 2013
    Messages:
    18
    Mobo:
    MSI Z97S-SLI-PLUS
    CPU:
    E3-1231V3
    Graphics:
    R9-280X
    Mobile Phone:
    Android
    May 13, 2015 at 3:52 AM #5
    swattw

    swattw

    Joined:
    Mar 10, 2013
    Messages:
    18
    Mobo:
    MSI Z97S-SLI-PLUS
    CPU:
    E3-1231V3
    Graphics:
    R9-280X
    Mobile Phone:
    Android
    I've already install it with Kext wizard
    But it hasn't change.......
    Screen Shot 2015-05-13 at 10.50.05 AM.png
    What's wrong with it?
     
  6. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    May 13, 2015 at 4:11 AM #6
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Did you also install FakePCIID.kext (same build)?

    Do you have kext-dev-mode=1 kernel flag?

    Did you repair permissions & rebuild cache?

    Make sure you have no other patches for WiFi other than the 5ghz patch (no branding patch -- it and FakePCIID will cancel each other).
     
  7. mingmanhk

    mingmanhk

    Joined:
    Dec 2, 2011
    Messages:
    5
    Mobo:
    GA-Z68XP-UD3P
    CPU:
    Intel i7 2600K
    Graphics:
    Geforce GTC 560
    Mac:
    MacBook Pro
    Sep 13, 2015 at 7:13 PM #7
    mingmanhk

    mingmanhk

    Joined:
    Dec 2, 2011
    Messages:
    5
    Mobo:
    GA-Z68XP-UD3P
    CPU:
    Intel i7 2600K
    Graphics:
    Geforce GTC 560
    Mac:
    MacBook Pro
  8. RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sep 13, 2015 at 11:06 PM #8
    RehabMan

    RehabMan Moderator

    Joined:
    May 3, 2012
    Messages:
    160,239
    Mobo:
    Intel DH67BL
    CPU:
    Core i7-2600K
    Graphics:
    Intel HD 3000
    Mac:
    MacBook Air
    Mobile Phone:
    iOS

Share This Page