Contribute
Register

Solved > HIS RX560 successfully working in MacOS Mojave.

Joined
Apr 20, 2019
Messages
2
Motherboard
Intel® H81 Chipset (Dell Optiplex 3020 SFF)
CPU
i5-4570
Graphics
HD Graphics 4600
Hi. I'm here to share my experience getting my graphics card to work in Mojave.
My graphics card is an "HIS, RX560 iCooler Green OC 4G, Radeon RX 560 Series, (1196 / 1750)"

>> tl;dr : I flashed my card's BIOS with this one : ASUS BIOS link, and it worked properly.


My computer is a Dell Optiplex 3020 (SFF), and I previously installed Mojave on it using its integrated GPU (HD4600). No problems. Could use for programming and some light video editing.

Then I wanted to get a GPU, and first priority was getting it cheap :lol:, so I bought an RX560 I found on sale for ~30$. Reason for picking up an RX560 was that I saw people saying most RX560 would be plug and play (if it isn't from XFX, yes I know XFX is a trouble brand).

However, I forgot to look up if this particular brand (HIS) has had any successes.
The thing worked well in Windows, and so I knew it was working, then I booted into MacOS and... Apple logo, then progress bar 3/4 full, progressing slower than usual, then RESTART. Every single time. Tried setting the GPU priority to integrated and whatnot. Didn't work.
IMG_7548.jpg
Verbose kernel logs aren't helpful either.

Then I found a thread over at insanelymac, and one thing I noticed from the post was that the Config file for his HIS card was identified to be from XFX! Surely enough, I booted into Windows, and my Config file was identified as one from XFX. Well, HIS is a Hong Kong based manufacturer after all, wouldn't be surprised if they used a Config file from a fellow Chinese company.

So I surmised my graphics card wouldn't work because of the XFX-based BIOS, and that I needed to flash a new BIOS.
Now I just needed to identify ones that are compatible.

I found out from A TechPowerup Thread the following details about HIS's RX560 (And this is my first time knowing that not all RX560s are equal. For those of you who still don't know; AMD reduced the specs for RX560 so that it could either have 14 (down by two from the original) or 16 compute units, so they they could rebrand old RX460s as RX560s!)

Identifying your card by HIS SKU (the inventory id on the card)
- Full Power RX 560: HS-560R4SCNR : 16 compute units
- Weakened RX 560: HS-560J4SCNR : 14 compute units

So I looked at my card : 16 compute units, OK now I have somewhere I could follow.
Used GPU-Z and compared my BIOS to ones on TechPowerup
Mine's exactly the same as this one : HIS, RX560 iCooler Green OC 4G

I compared a few BIOS files on TechPowerup's database, and found that the ones that are most similar to mine (which is identified according to the database as being based on "RX560 896SP") are..
- ASUS RX 560 Dual Fan OC 4 GB
- MSI RX 560 AERO ITX OC

Their BIOSs looked similar to mine too, ~48-50 W power limit, similar memory timings and such.
So, having heard that MSI cards work out of the box, I downloaded the MSI BIOS, then flashed using ATIFlash (required a forced flash using the shell command argument, of course)
MSI BIOS : MSI BIOS link (Don't use this, won't work)
Card still wouldn't boot, plus, now the card wouldn't even work in Windows, showing error -43.

Not knowing much about BIOS flashing, and seeing that this is a cheap-as-heck card, I figured I'd try Flashing the ASUS BIOS.
ASUS BIOS : ASUS BIOS link

Ran ATIFlash again, no problems seen, then restarted.
This time I booted into Windows first, and was happily surprised when the graphics card was running properly! No errors this time. Could play games at the same speed, no crashing or such.

So I booted into MacOS, and it booted right up.
405131


405132



Just wanted to share an experience, and as a potential guide for those who have this same card. :)
 
Top