Contribute
Register

High Sierra support for Dell OptiPlex 3020

Joined
Feb 28, 2019
Messages
7
Motherboard
Dell 3020
CPU
i5-5490
Graphics
HD 4600
I would start by first making a custom SSDT for your USB ports. After that do some more troubleshooting if it still isn't working.

thanks @trs96 , ill give it a try ..everything's works just fine include PM and FaceTime etc...now everytime I get to sleep my hackintosh it will go to KP.. here is the report I got. ill attach also my config.plist for your reference.

as for customs SSDT I will give It a shot . I will get back to you soon..thanks for the link above.

"system I'm running is Dell Optilex 3020 with i5-4590 and intel HD 4600 GFX "
 

Attachments

trs96

Moderator
Joined
Jul 31, 2012
Messages
12,192
Motherboard
GA-Z97X-UD3H-BK
CPU
I5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Try removing everything but your mouse from the USB ports, put it to sleep and see if that changes anything.
 
Joined
Mar 14, 2019
Messages
2
Motherboard
DELL 490P1
CPU
I5-4590
Graphics
HP AMD Radeon HD 6570
thanks @trs96 , ill give it a try ..everything's works just fine include PM and FaceTime etc...now everytime I get to sleep my hackintosh it will go to KP.. here is the report I got. ill attach also my config.plist for your reference.

as for customs SSDT I will give It a shot . I will get back to you soon..thanks for the link above.

"system I'm running is Dell Optilex 3020 with i5-4590 and intel HD 4600 GFX "
Hello i also have a Dell Optilex 3020 with i5-4590 i would like to know if you were able to solve your problems and if you would be willing to share your efi folder with me.
 
Joined
Feb 28, 2019
Messages
7
Motherboard
Dell 3020
CPU
i5-5490
Graphics
HD 4600
Try removing everything but your mouse from the USB ports, put it to sleep and see if that changes anything.
ok..I've done as instructed and the result was the same..it got interesting though coz when I remove everything and leave my mouse, instead of sleep, the display goes off (fan still spinning) ..and sometimes it goes to sleep too (with fan is turning off) and whenever I try to wake my pc up, only the fan is turning on while the display still sleep/black. I have to force shut down and when it booted up again then KP report has present indicate the sleep did not work.
################################

aside of this problems, I did face this problem with my HP 6300 i7-3770 but it was solved by simply change my display from VGA to DP and sleep/wake function work just fine.

here I attached my bootlog for your reference incase I'd loaded wrong kexts or configuration and KP that I'm facing after force reboot using leaving only mouse USB port when sleep.
 

Attachments

Last edited:
Joined
Feb 28, 2019
Messages
7
Motherboard
Dell 3020
CPU
i5-5490
Graphics
HD 4600
Joined
Mar 14, 2019
Messages
2
Motherboard
DELL 490P1
CPU
I5-4590
Graphics
HP AMD Radeon HD 6570
hey , what method you re using installing your MacOS ? btw you can check my config.plist here https://www.tonymacx86.com/threads/high-sierra-support-for-dell-optiplex-3020.243797/page-9#post-1923503
I followed the instructions from morgonaut that are on YouTube. Its the vanilla method.When i reboot all i see is a black screen and cursor flicking. So i must have created my usb wrong. I made recommended changes on bios and still nothing. I wonder if i am doing those wrong as well . My other concern is that I have a sata selector with a separate drive that has windows. When i make bios changes that drive doesn't work no more.
 
Last edited:
Joined
Feb 28, 2019
Messages
7
Motherboard
Dell 3020
CPU
i5-5490
Graphics
HD 4600
I followed the instructions from morgonaut that are on YouTube. Its the vanilla method.When i reboot all i see is a black screen and cursor flicking. So i must have created my usb wrong. I made recommended changes on bios and still nothing. I wonder if i am doing those wrong as well . My other concern is that I have a sata selector with a separate drive that has windows. When i make bios changes that drive doesn't work no more.
yes..im following her guide also and everything work fine, installation works fine, boot, PM etc, except for sleep/wake function..I never had those prob ( reboot and black sceen and cursor flicking) . Did you successfully install HS/Mojave or not? as for sleep/wake function not working..I will continue follow @trs96 and ill get back to this post after successfully create the customs SSTD .

p/s I suggested just using onboard HD4600 for clean installation and after your macOS up and running smoothly then add those HD 6570 GFX later coz my config.plist specified for HD 4600 .
 
Top