Contribute
Register

High Sierra support for Dell OptiPlex 3020

Joined
Jun 14, 2018
Messages
13
Motherboard
Dell Optiplex 3020
CPU
i3 4130
Graphics
RX 480 8GB
ok, what optiplex do you have? at what point of the installation process are you getting the boot loop?
I have Optiplex 3020 with i3 4130. Managed to get the installation started by using EFI file provided in the begining of this thread. But now on the second reboot during installation i get..
EBBB3113-6BDD-4690-867A-6EDC5102B914.jpeg
 
Joined
Jul 23, 2014
Messages
95
Motherboard
GA-Z270X-Gaming 7 Aorus
CPU
i7 7700K
Graphics
HD 630
Mac
iMac
Mobile Phone
iOS
are you using these bios settings?

BIOS Settings



Under General

-Set Boot Sequence to UEFI

-Enable Legacy Option ROMs


Under System Configuration

-Set Integrated NIC to Enabled

-Set SATA Option to AHCI

-Set Audio\Enable Audio

Under Video


-Set Primary Display as Intel HD Graphics (NOT Auto)

Under Secure Boot


-Set Secure Boot Enable to Disabled

Under Performance


-Set MultiCore to All

-Set C-State Control to True

-Set Limit CPUI Value to False

-Set Intel TurboBoost to False

Under Virtualization Support


-Set Virtualization to Enabled
 
Joined
Jun 14, 2018
Messages
13
Motherboard
Dell Optiplex 3020
CPU
i3 4130
Graphics
RX 480 8GB
looking at your picture, the drive your selecting to install to is too small. Are you trying to install to a HDD/SDD? Are you partitioning it with Mac OS Extended (Journaled) or APFS in Disk Utility at the start of your install process?
I’m installing in a Hard Drive and its 500GB. Yes BIOS settings are all OK and i formated the disk on Disk Utility before i started to install.
 
Joined
Jun 14, 2018
Messages
13
Motherboard
Dell Optiplex 3020
CPU
i3 4130
Graphics
RX 480 8GB
As long as your selecting the hdd/ssd to install to instead of the usb I don’t know of a reason why it wouldn’t let you proceed. The EFI you refer to is that the one I provided or someone else’s?
Someone else EFI.One provided by atun on the first page. I got it to install by retrying. Now this is my first hackintosh can you please provide me with things to do to get it up and running? Thanks for your immense help man.
 
Joined
Jul 23, 2014
Messages
95
Motherboard
GA-Z270X-Gaming 7 Aorus
CPU
i7 7700K
Graphics
HD 630
Mac
iMac
Mobile Phone
iOS
For me I downloaded and installed clover using these settings

Install for UEFI booting only
Install Clover in the ESP
Drivers64UEFI\OsxAptioFixDrv-64
Install RC scripts on target volume
Install Clover Preference Pane

Then I copied my efi folder to the efi drive of my hdd and after a rebooted.

Once I restarted I set bios to boot from the hdd and job done. Using my efi I had audio sorted and audio over DP and it sorted my intel graphics out. You could try that.

If you get stuck in a boot loop again then boot from your usb and copy that efi folder to the efi drive of your hdd for now
 
Joined
Jun 14, 2018
Messages
13
Motherboard
Dell Optiplex 3020
CPU
i3 4130
Graphics
RX 480 8GB
Let me know how you get on. If that doesn’t work we can see what we can do
So I have been immersing my self in all things Hackintosh and I managed to get my install working along with my RX 480 with full acceleration pheew. The only caveat is I have to boot the computer with iGPU and then switch inputs manually to the dGPU but I can live with that until 10.13.6 because I hear it brings support OOB support for AMD cards. Only issue now is audio..

I used VOODOO 2.9.1 kexts and KEXTBEAST to install and audio worked for a while until it stopped. What method did you use to install AppleALC for audio?
 
Top