Contribute
Register

High Sierra - RX Vega & Final Cut h.264 fix

Status
Not open for further replies.
Joined
Aug 21, 2010
Messages
197
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
6900 XT (Spoofed)
Mac
  1. iMac
OK guys,
this one :
SMB_BIOS_VERSION "IM191.88Z.0058.B00.1705091711"
SMB_PRODUCT_NAME "iMac19,1"
SMB_BOARD_PRODUCT "Mac-CF21D135A7D34AA6"

worked for me !!!

Please open Chrome browser, and surf www.tv2.dk (danish tv news site). How does it work for you?
 
Joined
Sep 16, 2017
Messages
65
Motherboard
Gigabyte Z270X- Gaming 5
CPU
i7-i7700
Graphics
RX Vega 64
Mac
  1. iMac
Please open Chrome browser, and surf www.tv2.dk (danish tv news site). How does it work for you?

I've messed up my config.plist :( cant go into high siera now. Only in safe mode. Mama help me....
 
Joined
Sep 16, 2017
Messages
65
Motherboard
Gigabyte Z270X- Gaming 5
CPU
i7-i7700
Graphics
RX Vega 64
Mac
  1. iMac
I've messed up my config.plist :( cant go into high siera now. Only in safe mode. Mama help me....

Edited:
unmessed it, but google does't work. Freeze the whole thing
 
Joined
Dec 24, 2015
Messages
157
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Please open Chrome browser, and surf www.tv2.dk (danish tv news site). How does it work for you?

Ok. I can confirm that chrome froze for me too when I surfed that website. Also, it froze on Youtube!

For now, I disabled acceleration in chrome by going to Preferences and turning off acceleration. It has not crashed since then.

If you can't even get to chrome settings, then open chrome from terminal by passing a flag to turn of gpu acceleration ( first result on google for "start google chrome terminal disable acceleration")
 
Joined
Dec 24, 2015
Messages
157
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
@dashingncool

That made better sense. I got the SMBIOS to be nearly filled out (was missing ROM), but didn't change anything about the Chrome website: www.tv2.dk / hardcrash. So I tried your EFI folder, same thing. I tried to use your EFI folder and then swap the uuidgen number with mine, same thing.

Says my card is Vega 64 but it's an 56 (I guess you modified something?:))

Is there anything else I can try?

I have whatever green n lilu kexts which helped me identify my RX 64. Maybe they are out of date and not recognizing your card properly. There shouldn't be any thing else affecting your GPU model detection
 
Joined
Aug 21, 2010
Messages
197
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
6900 XT (Spoofed)
Mac
  1. iMac
I have whatever green n lilu kexts which helped me identify my RX 64. Maybe they are out of date and not recognizing your card properly. There shouldn't be any thing else affecting your GPU model detection

I have the latest Lilu / Green at home, I will try and swap them to see if it helps.

@dashingncool does your computer freeze if you go to www.tv2.dk in Chrome? (I am pretty sure if I get the chrome problem fixed, then my FCP X will be good - so that's why I test in Chrome).
 
Joined
Dec 24, 2015
Messages
157
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
I have the latest Lilu / Green at home, I will try and swap them to see if it helps.

@dashingncool does your computer freeze if you go to www.tv2.dk in Chrome? (I am pretty sure if I get the chrome problem fixed, then my FCP X will be good - so that's why I test in Chrome).
Yes :( , see my last 2 replies.
 
Joined
Aug 21, 2010
Messages
197
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
6900 XT (Spoofed)
Mac
  1. iMac
Yes :( , see my last 2 replies.

Ahh sorry! missed it. That is good news I guess, so it’s wide ‘spread. I guess that will be fixed when we get a real iMac 19.1.

Thanks for every help @dashingncool - This upgrade for me has been the most Vanilla osx ever, running the 5k with 2x dp cables just works OOB with that single kext patch has been bliss. Not worried about updates is the real deal too (Damn Nvidia got complicated on last minor update).

I will keep watching lilu/green updates in hopes we get a solution sooner then december :)
 
Joined
Dec 24, 2015
Messages
157
Motherboard
Asus Maximus X Code Z-370
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Awesome! Glad to be be of help.

This is the best hack build for me as well. After disabling hardware acceleration, its all good.
 
Joined
Mar 5, 2011
Messages
40
Mobile Phone
  1. iOS
Hi all - recently installed HS on my build (Asus ROG Hero VIII, i7 6700k, Vega 56 flashed with Vega 64 bios, wifi/bluetooth card).. works pretty well so far OOTB except for the known crashes in Electron Apps (Discord in my case). I've added Lilu/EverGreen. Now just one thing bugging me.. getting the computer to wake from sleep. Tried various darkmodes all to no avail - anybody have any tips pls? Would iMac 19,1 help?
 
Status
Not open for further replies.
Top