Contribute
Register
Status
Not open for further replies.
Joined
Nov 28, 2012
Messages
21
Motherboard
GA-X79-UP4
CPU
i7 3930K
Graphics
EVGA GTX 770
Mac
Classic Mac
Mobile Phone
Gigabyte X79-UD5 (BIOS f12) BIOS Date 07/05/2012
i7 3930K
Radeon 7970
Samsung SSD

16GB USB2 key Mac OS Extended (Journaled) GUID Partition Map
High Sierra direct from App Store 5.21GB downloaded to genuine MacBook Pro
Unibeast8.1.0 & Multibeast 10.2.0
Clover_v2.4k_r4369
CloverConfigurator 4.59.0.0.


** scroll down to interesting part to skip my setup details **

Whilst attempting a High Sierra install I encountered serious problems booting to the Unibeast USB installer - resulting in error
Reboot and Select proper Boot device

I am not new to Hackintosh & I had previously made a successful install of HS on this exact same system so was somewhat confused, blaming perhaps a faulty USB key.

I have checked USB3 is disabled, Legacy USB is enabled, other BIOS settings double-checked, Boot order etc is all as expected.
Load Optimized defaults, AHCI Mode enabled, XHCI & EHCI enabled etc etc
I have tested all front & rear USB ports
I have removed all peripherals and checked mouse, keyboard, alternate GPU etc etc
apfs.efi (transferred from my original HS download) was correctly placed in EFI partition etc etc - other kexts and alternative boot files were attempted (HFSPlus-64.efi)
the backup BIOS was re-loaded (dual BIOS system) CMOS cleared & battery replaced
also suggest USB boot via USB hub was attempted - no joy
After SEVERAL deep formats and alternative USB sticks and different install routes I soon discovered I was completely unable to boot from UEFI.

So instead I tried a Unibeast LEGACY HS install USB

This worked flawlessly - a full install of High Sierra onto the SSD. (APFS format)

Multibeast was also successful, UEFI boot & basic kexts loaded etc

HOWEVER the SSD now encountered the same error, and will not boot to Clover without the legacy USB boot key. HS is also behaving erratically (slow mouse, crashes etc)..

at this point I decided to attempt a final total clean install and wiped everything to revert back to Sierra.

horror! - a clean UEFI install of Sierra (previously running fine on same system 2 weeks ago) resulted in same error -
Reboot and Select proper Boot device
at this point I decided the UEFI boot of the motherboard must somehow be corrupted..
I decided to flash the BIOS to confirm a clean working version - from possible corrupted F12 back to a clean F12.
I removed the Unibeast USB install key and replaced it with an MS-DOS format key with new BIOS file

** here's where we get to the 'interesting' part -


i power up the system with a PC keyboard, holding down END to successfully enter the Q-Flash Utility (v1.02)
Concerned about my new BIOS USB, I unexpectedly decide instead to abort here and key down to
'Exit Q-Flash' and hit enter..

Lo and Behold Clover menu boots from the SSD

I check the boot options are correct and select Boot macOS from High Sierra (the only option available)

verbose mode tells me

OsxAptioFix2Drv: Starting overrides for \System\Library\Coreservices\boot.efi
Using reloc block: no, hibernate wake: no
+++++


pauses, quickly scrolls more info then very quickly we are into the HS desktop. This time there is no mouse issue, no crash and I can resume normal work...

So my question is WHAT is going on here - what can be the error with my hardware setup or BIOS settings.. what files have I misplaced or installed incorrectly?

the clue here is that I can only boot through Q-Flash but nowhere else -
I cannot boot via Function12 or delete key - Reboot and Select proper Boot device
I cannot boot from BIOS Save&Exit Setup - Reboot and Select proper Boot device
I cannot boot from BIOS Quit without saving - Reboot and Select proper Boot device
I cannot boot from BIOS Boot Override UEFI:SSD - (i cycle back to the same menu)
I cannot boot from BIOS Boot Override P0:SSD (legacy method) - Reboot and Select proper Boot device
I cannot boot from UEFI:USB - Reboot and Select proper Boot device

ALSO - if first i enter BIOS and the click Q-Flash utility then choose exit Q-Flash i am returned to the BIOS which then also allows me to boot into Clover however here i am faced with does printf work? then stuck flashing cursor
i suspect something is amiss with OsxAptioFix2Drv?

my only options are booting via an exit from Q-Flash utility! What system files or boot sequence does Q-Flash use that the main BIOS or EFI partition does not? Do I have a file or folder missing from my SSD? is OsxAptioFix2Drv in the wrong folder?
I am reluctant now to flash the BIOS incase my position is made worse..

I have an excellent working system - only issue is ridiculous boot procedure!
All comments warmly welcomed!

more info available upon request!
 
Last edited:
Status
Not open for further replies.
Top