Contribute
Register

High Sierra Random Freezing

Joined
Jan 31, 2011
Messages
448
Motherboard
ASUS ROG RAMPAGE VI EXTREME
CPU
i9-7980XE
Graphics
Nvidia GeForce GTX Titan X (Maxwell)
I think I've been able to narrow down what's causing the issue. Please find the changes I've made below:

- Upgraded from Clover r4380 to Clover r4392
- Compiled latest AptioMemoryFix.efi (instead of OsxAptioFix3Drv-64.efi) and placed it in Clover's drivers64UEFI folder
- Compiled and Patched (to have per Core multiplier and frequency) the latest FakeSMC from https://github.com/kozlek/HWSensors
- SSD Trim Enabler patch disabled


Could you guys tell me if any of the above changes apply to your config? For example if you have any SSD Trim Enabler patch in Clover, or if you need to use AptioMemoryFix or equivalent to boot, etc.

Current uptime: 1d 16h still no freeze/KP so far.
 
Joined
Jul 1, 2014
Messages
21
Motherboard
Asus H87
CPU
Intel Core i7 4770 3.4GHz
Graphics
Intel HD4600
I haven't gotten any KPs from this, so nothing to share there.

My /EFI/CLOVER/kexts/Other is:
- FakeSMC.kext (RehabMan's branch, from his bitbucket)
- Lilu.kext
- IntelGraphicsFixup.kext
- RealtekRTL8111.kext
/EFI/CLOVER/kexts/10.13:
- realtekALC.kext

Based on your suggestions, I updated Clover to 4392 and from the installer, removed the previous Aptio fixes and installed AptioInputFix and AptioMemoryFix. We'll see how this works!
 
Joined
Sep 14, 2011
Messages
283
Motherboard
Z97X-UD5H rev. 1.0
CPU
4690K
Graphics
EVGA NVIDIA GeForce GTX 650 (not Ti)
I haven't had a KP so macos has not suggested reporting anything.

My hack sometimes works for several days between freezes so it's extremely hard to know what helps and what doesn't.

In CLOVER/kexts there is nothing except FakeSMC.kext (from https://www.tonymacx86.com/resources/categories/kexts.11/) in Other. From MultiBeast (which I kinda regret using now) I installed "7/8/9 Series USB Support" and "IntelMausiEthernet v2.3.0". So I have

Code:
~ ➜  kextstat | grep -v apple
Index Refs Address            Size       Wired      Name (Version) UUID <Linked Against>
   16    0 0xffffff7f80d28000 0x12000    0x12000    org.netkas.driver.FakeSMC (1765) 9EEC6103-EEBA-34B3-B9AF-8FE333C43E90 <11 7 5 4 3 1>
   52    1 0xffffff7f80d3e000 0x8000     0x8000     org.rehabman.driver.FakePCIID (1.3.9) BC738576-B800-3E7F-992D-3851C67CCAA9 <12 7 5 4 3 1>
   53    0 0xffffff7f80f14000 0x3000     0x3000     org.rehabman.driver.FakePCIID.XHCIMux (1.3.9) C99262C4-7FDD-33F9-85EB-D53240B71FE5 <52 12 7 5 4 3 1>
   56    0 0xffffff7f80f74000 0x14000    0x14000    com.insanelymac.IntelMausiEthernet (2.3.0) 8E3F92D7-AB89-3E72-8CFB-6B93236F5001 <17 12 5 4 3 1>
   90    0 0xffffff7f80e6d000 0x4000     0x4000     com.intel.driver.EnergyDriver (2.0) 7FE9AF4A-A8C2-3099-A956-971DDC86A467 <7 5 4 3>
  124    3 0xffffff7f82abf000 0x63000    0x63000    org.virtualbox.kext.VBoxDrv (5.2.6) C32CCC8B-7E44-3974-BEC0-9C1FA570690D <7 5 4 3 1>
  128    0 0xffffff7f82b22000 0x8000     0x8000     org.virtualbox.kext.VBoxUSB (5.2.6) A60E8437-734A-3C07-8488-5885145AEE0C <127 124 64 7 5 4 3 1>
  129    0 0xffffff7f82b2a000 0x5000     0x5000     org.virtualbox.kext.VBoxNetFlt (5.2.6) 552BD757-0D66-3F90-9A20-C6C7881F4A2F <124 7 5 4 3 1>
  130    0 0xffffff7f82b2f000 0x6000     0x6000     org.virtualbox.kext.VBoxNetAdp (5.2.6) 8B8163C1-1125-36B8-AC6A-1AA38506938D <124 5 4 1>
 
Joined
Jul 1, 2014
Messages
21
Motherboard
Asus H87
CPU
Intel Core i7 4770 3.4GHz
Graphics
Intel HD4600
No luck with AptioMemoryFix. I also tried disabling Aggressive Link Power Management for SATA in the BIOS (as others on insanelymac have found this to help intermittent freezing) with no success.
 
Joined
Sep 28, 2011
Messages
44
Motherboard
Gigabyte GA-Z87MX-D3H
CPU
i7 4770K
Graphics
HD 4600
Mobile Phone
iOS
Hey everyone, I'm going to jump on this thread too. I've been experiencing random hard freezes as well since installing a new SSD and laboring through a clean install of High Sierra. I'm on the verge of jumping ship and going back to my extremely stable El Capitan install.

I'm at work, so I'll have to post later tonight what kexts I have installed where, and see if there's anything in the logs.

The only common thing that I can figure is that every time the crash happened we've been on the internet. But that's where the commonality ends. Happened with Safari and Firefox, VPN turned on, turned off. There is one sure-fire way I can get the freeze to occur, and that is to try and play a Netflix video in Safari. 100% of the time, as the video is loading, the computer locks up. Does not happen in Firefox, just Safari (havent tested Chrome yet). Which really stinks because Safari is the only way to get 1080p Netflix on a Mac.

Another interesting side effect of the crash is that if I dont restart the computer, but leave it on and frozen, it eventually crashes the router and we lose the internet connection. If I restart right away, no router problems. Once or twice I couldnt even release and renew the WAN IP address in the router, but had to go unplug the FIOS box in the basement for a bit and plug it back in first before the router could obtain an IP address again.

I dont know if that helps anyone, but in searching, I seem to be the only person in the world having Netflix in Safari crash my computer but work fine in Firefox. I'd be most curious to see if anyone else can get that to happen.
 
Joined
Jan 31, 2011
Messages
448
Motherboard
ASUS ROG RAMPAGE VI EXTREME
CPU
i9-7980XE
Graphics
Nvidia GeForce GTX Titan X (Maxwell)
Current uptime: 2d 2h 40min.

I've written a complete changelog from the two system profiles I've got, one has KP after 15h, the other one hasn't had any KP so far after more than 2 days.

#4652
 
Joined
Jan 31, 2011
Messages
448
Motherboard
ASUS ROG RAMPAGE VI EXTREME
CPU
i9-7980XE
Graphics
Nvidia GeForce GTX Titan X (Maxwell)
Just a few minutes after I wrote the lines above the system just froze again. My screens were off (because I put them to sleep), system was unresponsive when I tried to bring it back to life. No SSH, no HD LED blinking, hard frozen :(. Back to investigating the issue from zero. Sorry guys for the false hope.
 
Joined
Jan 31, 2011
Messages
448
Motherboard
ASUS ROG RAMPAGE VI EXTREME
CPU
i9-7980XE
Graphics
Nvidia GeForce GTX Titan X (Maxwell)
There is one sure-fire way I can get the freeze to occur, and that is to try and play a Netflix video in Safari. 100% of the time, as the video is loading, the computer locks up. Does not happen in Firefox, just Safari (havent tested Chrome yet).
Known issue, DRM-related. Can't remember where I saw people reporting this issue sorry :s. Shiki might fix it.
 
Top