High Sierra, fast network in Windows, slow on Mac - BCM4360

Discussion in 'Network' started by petrikleynhans, Oct 4, 2017.

  1. petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 4, 2017 at 9:00 AM #1
    petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    For some reason, I've been struggling to get proper speeds on my Hackintosh the last few days.

    I ran High Sierra Beta 4 and had no issues. Now I'm running the full version. I have the BCM4360 card with built-in Bluetooth.

    I'm running speedtests on both Hackintosh and iMac, stationed right next to each other, and I'm getting huge differences.
    Hackintosh: Ping 114 Download 1.81mbps Upload 0.06mbps
    iMac: Ping 120 Download 2.79mbps Upload 0.13mbps

    Looking at system information, I noticed the following differences under Network Information in the Wifi tab:
    Country code: Hackintosh DE, Imac X3
    Transmit rate: Hackintosh 52, Imac 130
    MCD Index: Hackintosh 5, Imac 15

    I also booted into Windows to check if it's something to do with the hardware, but I'm getting full speeds on Windows, so it has to be the setup on my Hackintosh.

    Can anyone help please?
     
    Last edited: Oct 4, 2017
  2. petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 5, 2017 at 6:15 AM #2
    petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Am I really the only person experiencing this?
     
  3. petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 6, 2017 at 4:02 AM #3
    petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Still having this issue. Please help anyone.
     
  4. petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 26, 2017 at 2:47 PM #4
    petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    I still haven't been able to resolve this issue. In Windows I'm getting full speed both up and down. My latency and jitter is great. But in Mac it's another story. My speeds are cut in half (at least) while the latency and jitter jumps from around 20 to 200.

    Seeing as it's working fine in Windows, it means it has to be the Mac drivers right?

    Please have a look at my EFI folder and help out.
     
  5. petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 27, 2017 at 8:13 AM #5
    petrikleynhans

    petrikleynhans

    Joined:
    May 11, 2017
    Messages:
    102
    Mac:
    iMac
    Mobile Phone:
    iOS
    Made another discovery this morning. I tested running an ethernet cable from my range extender into my system. Thus swopping from Wifi to Ethernet, my connection became substantially better. It's still not what the Windows connection is, but at least double the speed of my Wifi connection.

    Is there a way of updating or replacing my BCM4360 driver? Could it be something else?
     

    Attached Files:

Share This Page