Contribute
Register

High Sierra AppleHDA Audio

toleda

Moderator
Joined
May 20, 2010
Messages
24,223
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
371002
High Sierra AppleHDA Audio

Installation
- Native AppleHDA.kext, install one method only, uninstall previous audio methods
Note: 885/887/889/892/898/1150/1200/1220 codec and layout 1, 2 or 3 Desktop support on this site.

A. MultiBeast 10.4
  1. See Uninstall Previous Audio Methods (below)
  2. Download
    1. MultiBeast 10.4.0 - High Sierra
  3. Supports AppleALC method below
  4. MultiBeast > Drivers > Audio > √ AppleALC
    1. If applicable,
      1. Skylake/Kaby Lake/Coffee Lake motherboards: √ 100 / 200 / 300 Series Audio Support (HDAS > HDEF)
      2. Kaby Lake: 200 Series/Z370/X299 motherboards: √ 200 / Z370 / X299 Audio Device ID Patch
      3. 3 port motherboard audio (2 In/1 Out > 3 Out): √ Optional 3 port (5.1) Audio
    2. Example (all possible choices, select attributes that apply to your motherboard): 389740
    3. Build/Install
  5. Set Audio (clean install only, no config.plist edit required for High Sierra to Mojave upgrade)
    1. Select layout
    2. Set layout
      • Xcode/edit: config.plist/Devices/Audio/Inject/layout
      • Example: Desktop/layout = 1 (recommended)
      • 370999
  6. Restart
B. acidanthera/AppleALC - AppleALC
  1. See Uninstall Previous Audio Methods (below)
  2. Downloads
    1. AppleALC
    2. Lilu
  3. Install Downloads/AppleALC.kext and Lilu.kext to Library/Extensions with KextBeast
  4. Set Audio (clean install only, no config.plist edit required for High Sierra to Mojave upgrade)
    1. Select layout
    2. Set layout
      • Xcode/edit: config.plist/Devices/Audio/Inject/layout
      • Desktop/layout = 1 (recommended)
      • If 3 port motherboard audio, 2 In/1 Out:
        • repurpose to 3 Out: Desktop/layout = 2
        • native, 2 In/1 Out: Desktop/layout = 3
    3. As applicable, see IX. Unsupported/Non-working AppleHDA Realtek Audio (below):
      • 300/200/100 Series motherboards (HDAS > HDEF)
        • 300-Coffee Lake/200-Kaby Lake/100-Skylake
      • X299 motherboards (CAVS > HDEF)
      • X99 motherboards (ALZA > HDEF)
  5. Restart
Problems - No audio devices/Installation failure
  1. 885/887/889/892/898/1150/1200/1220 codec and 1/2/3 layout Desktop support only:
  2. All other codecs and layouts:
  3. Problems posted to this thread will be removed.
Fixes - macOS/HDEF Audio: Intel 100/200/300 Series, X299, X99 Unsupported
  1. See AppleHDA Realtek Audio/Post #1/IX. Unsupported/Non-working AppleHDA Realtek Audio:
  • 100/200/300 Series/Intel High Definition Audio (HDAS > HDEF)
  • X299/Intel High Definition Audio (CAVS > HDEF)
  • X99/Intel High Definition Audio (ALZA > HDEF)
Native AppleHDA.kext required (skip, if clean install)
  1. Choose one option
Uninstall Previous Audio Methods (skip, if clean install)
  1. See AppleHDA Realtek Audio/Post #1/X. Uninstall AppleHDA Realtek Audio
Details - AppleHDA Realtek Audio
 
Last edited:
Joined
Nov 17, 2012
Messages
14
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
GTX 1050 Ti
  1. Description of audio problem : Audio OK after boot but only cracking sounds after sleep (inputs and outputs still there in system preferences)
  2. OS X version: 10.13.4 /Gigabyte GA-Z97X-UD5H /BIOS version: F10 (last) /processor: Intel Core i7 4790k /graphics: GTX 1050 Ti
  3. Procedure/Guide Used : clover install à audio_cloverALC-130_v0.5.command
https://www.tonymacx86.com/threads/applehda-realtek-audio-guide.234732/

- Removed all older installs (AppleHDA.kext, realtekALC.kext, config.plist entries, Lilu.kext)

- Installed S/L/E/AppleHDA.kext (extracted original file from High Sierra installer with Pacifist and installed with Kext Utility)

- Disabled SIP

I’ve been using this clover method for a while and, before updating to 10.13.6 some days ago, it worked well…

I also tried removing everything and applied the Multibeast 10.4 or 11.0 methods, but it wasn’t better.
Even gave a try with Reset Apple HDA app, which I used in the past for this kind of problem.

Here is a link to my config.plist
https://www.dropbox.com/s/4i7fex6mfybw04f/config.plist?dl=0


Can you help me please?
 
Top