Contribute
Register

High Sierra - 660ti graphics issues?

Status
Not open for further replies.
Joined
Jun 9, 2013
Messages
10,736
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
So how would you recommend I fix my problems? Sorry to be such a noob but if you could spell it out that would be a big help!

Add Change PEGP to GFX0 from post_install.plist. Same with change _DSM to XDSM. You can just drag and drop. Then you will need to make a SSDT-GFX0 injector. Look at https://github.com/VoiletDragon/Z77-DS3H-Clover-Hotpatch-Patches

Code:
DefinitionBlock ("", "SSDT", 2, "hack", "GFX0_HDA", 0x00000000)
{
    External (_SB_.PCI0.PEG0, DeviceObj)    // (from opcode)
    External (_SB_.PCI0.PEG0.GFX0, DeviceObj)    // (from opcode)
    External (GFX0, DeviceObj)    // Warning: Unknown object

    Scope (_SB.PCI0.PEG0)
    {
        Scope (GFX0)
        {
            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LNot (Arg2))
                {
                    Return (Buffer (One)
                    {
                         0x03                                          
                    })
                }

                Return (Package (0x0E)
                {
                    "@0,connector-type",
                    Buffer (0x04)
                    {
                         0x00, 0x08, 0x00, 0x00                        
                    },

                    "@1,connector-type",
                    Buffer (0x04)
                    {
                         0x00, 0x08, 0x00, 0x00                        
                    },

                    "@2,connector-type",
                    Buffer (0x04)
                    {
                         0x00, 0x08, 0x00, 0x00                        
                    },

                    "@3,connector-type",
                    Buffer (0x04)
                    {
                         0x00, 0x08, 0x00, 0x00                        
                    },

                    "@4,connector-type",
                    Buffer (0x04)
                    {
                         0x00, 0x08, 0x00, 0x00                        
                    },

                    "@5,connector-type",
                    Buffer (0x04)
                    {
                         0x00, 0x08, 0x00, 0x00                        
                    },

                    "hda-gfx",
                    Buffer (0x0A)
                    {
                        "onboard-2"
                    }
                })
            }
        }

        Device (HDAU)
        {
            Name (_ADR, One)  // _ADR: Address
            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LNot (Arg2))
                {
                    Return (Buffer (One)
                    {
                         0x03                                          
                    })
                }

                Return (Package (0x02)
                {
                    "hda-gfx",
                    Buffer (0x0A)
                    {
                        "onboard-2"
                    }
                })
            }
        }
    }
}
 
Joined
May 22, 2011
Messages
132
Motherboard
ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
CPU
Intel i7 6700
Graphics
MSI GTX 1070 Gaming X
Mobile Phone
  1. iOS
Don't use Clover Configurator to add ACPI, DSDT, Patches to config it will destroy the config

I don't have this problem, but I have seen many people talking about DSDT, patches and other stuff to have better stability than doing it inside Clover. Is it true? If so, is there a Noob Friendly guide which I can follow to do my patches. I always feel my Hackintosh isn't up to desired performance, I am hoping this will iron out most of it. Most of the build guides end with a basic post installation and finishing everything in clover.
 
Joined
Jun 9, 2013
Messages
10,736
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
I don't have this problem, but I have seen many people talking about DSDT, patches and other stuff to have better stability than doing it inside Clover. Is it true? If so, is there a Noob Friendly guide which I can follow to do my patches. I always feel my Hackintosh isn't up to desired performance, I am hoping this will iron out most of it. Most of the build guides end with a basic post installation and finishing everything in clover.

I don't bother with DSDTs no more. All of my Desktops including both Servers I have are on Clover hot patch with a set of SSDTs.
 
Joined
Sep 9, 2010
Messages
471
Motherboard
Asrock Z490m pro-4
CPU
i9-10850K
Graphics
Vega 64 (flashed Vega 56)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Has anyone been able to resolve this? I am having the same issue. I tried Replacing PEGP with GFX0 as well as trying iMac 14,2 SMBIOS.
 
Joined
Apr 14, 2013
Messages
4
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i5-3570K
Graphics
HD 4000
Mac
  1. iMac
Mobile Phone
  1. iOS
Just wondering if anyone would be so kind as to check out my ioreg and Clover folders as well since I'm having the same problem. Most of the patches are from "Gigabyte-GA-Z77X-macOS-Install" on github (don't think I could edit the SSDT.aml files myself).
 
Joined
Oct 21, 2016
Messages
14
hi, same problem here, with evga gtx 560, have artifacts everywhere after a while, if i put the machine to sleep artifacts are completely gone after wake up for a few minutes and the artifacts come again.
tried official drivers and nvidia webdrivers, but the problem continues with both drivers. in sierra or el capitan i didnt have any artifacts.
im out of ideas :banghead:
 
Last edited:
Joined
Dec 15, 2015
Messages
370
Motherboard
MSI Z270 M7
CPU
i7-7700K
Graphics
RX 5700 XT
Mobile Phone
  1. iOS
Same problem with standard GTX 660. Driver problem in High Sierra = we need to wait until next release and hope that Apple will fix this. Or we will need to use web drivers...
 
Joined
Oct 5, 2011
Messages
24
Motherboard
Asrock H77M-ITX
CPU
Core i5 3470
Graphics
Gigabyte 660Ti Windforce
Mac
  1. MacBook Air
  2. Mac Pro
Classic Mac
  1. iBook
Mobile Phone
  1. Android
Same here and out of ideas. Tried changing the system id from iMac 14.2 to 13.2, tried disabling inject intel in the Clover configurator, tried both Mac OS and nVidia Web drivers.
 
Status
Not open for further replies.
Top